diff mbox series

bmaptool: add PROVIDES bmap-tools for compatibility

Message ID 20240419203140.461439-1-rasmus.villemoes@prevas.dk
State New
Headers show
Series bmaptool: add PROVIDES bmap-tools for compatibility | expand

Commit Message

Rasmus Villemoes April 19, 2024, 8:31 p.m. UTC
From: Rasmus Villemoes <rasmus.villemoes@prevas.dk>

This is very often a build dependency, such as in my case using a
class from meta-ptx, which fails with

ERROR: Nothing PROVIDES 'bmap-tools-native'. Close matches:
  bmaptool-native
  bpftool-native
  mtools-native

due to the renaming.

Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk>
---
 meta/recipes-support/bmaptool/bmaptool_git.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Alexander Kanavin April 19, 2024, 9 p.m. UTC | #1
This was already proposed, and rejected.
https://lists.openembedded.org/g/openembedded-core/topic/104753355

You need to fix the metadata that refers to the old name.

Alex


On Fri, 19 Apr 2024 at 22:31, Rasmus Villemoes via
lists.openembedded.org
<rasmus.villemoes=prevas.dk@lists.openembedded.org> wrote:
>
> From: Rasmus Villemoes <rasmus.villemoes@prevas.dk>
>
> This is very often a build dependency, such as in my case using a
> class from meta-ptx, which fails with
>
> ERROR: Nothing PROVIDES 'bmap-tools-native'. Close matches:
>   bmaptool-native
>   bpftool-native
>   mtools-native
>
> due to the renaming.
>
> Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk>
> ---
>  meta/recipes-support/bmaptool/bmaptool_git.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-support/bmaptool/bmaptool_git.bb b/meta/recipes-support/bmaptool/bmaptool_git.bb
> index fd53c21c06..b4b3fa1fbd 100644
> --- a/meta/recipes-support/bmaptool/bmaptool_git.bb
> +++ b/meta/recipes-support/bmaptool/bmaptool_git.bb
> @@ -23,6 +23,7 @@ RDEPENDS:${PN} = "python3-core python3-compression python3-misc python3-mmap pyt
>  inherit setuptools3
>
>  # For compatibility with layers before scarthgap
> +PROVIDES = "bmap-tools"
>  RREPLACES:${PN} = "bmap-tools"
>  RCONFLICTS:${PN} = "bmap-tools"
>
> --
> 2.40.1.1.g1c60b9335d
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#198562): https://lists.openembedded.org/g/openembedded-core/message/198562
> Mute This Topic: https://lists.openembedded.org/mt/105625834/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Rasmus Villemoes April 19, 2024, 9:16 p.m. UTC | #2
On 19/04/2024 23.00, Alexander Kanavin wrote:
> This was already proposed, and rejected.
> https://lists.openembedded.org/g/openembedded-core/topic/104753355
> 
> You need to fix the metadata that refers to the old name.

So, how can a layer then be compatible with both nanbield and scarthgap?
Could this perhaps be applied just to the scarthgap branch, but not master?

Rasmus
Tim Orling April 19, 2024, 9:25 p.m. UTC | #3
On Fri, Apr 19, 2024 at 2:16 PM Rasmus Villemoes via lists.openembedded.org
<rasmus.villemoes=prevas.dk@lists.openembedded.org> wrote:

> On 19/04/2024 23.00, Alexander Kanavin wrote:
> > This was already proposed, and rejected.
> > https://lists.openembedded.org/g/openembedded-core/topic/104753355
> >
> > You need to fix the metadata that refers to the old name.
>
> So, how can a layer then be compatible with both nanbield and scarthgap?
> Could this perhaps be applied just to the scarthgap branch, but not master?


Ask yourself why you are choosing one branch to be compatible with multiple
releases? And then have your push scripts push to a “nanbield” branch and a
“scarthgap” branch. This means the Layer Index will also automatically know
about your compatibility. This means any traditional Yocto project user
will have zero questions about which of your branches to choose.

Multiple LAYERSERIES_COMPAT is not really intent. It’s also often not
accurate (layers with addpylib are not actually compatible with dunfell).

Branches are cheap. Use them as intended.


>
> Rasmus
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#198565):
> https://lists.openembedded.org/g/openembedded-core/message/198565
> Mute This Topic: https://lists.openembedded.org/mt/105625834/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-support/bmaptool/bmaptool_git.bb b/meta/recipes-support/bmaptool/bmaptool_git.bb
index fd53c21c06..b4b3fa1fbd 100644
--- a/meta/recipes-support/bmaptool/bmaptool_git.bb
+++ b/meta/recipes-support/bmaptool/bmaptool_git.bb
@@ -23,6 +23,7 @@  RDEPENDS:${PN} = "python3-core python3-compression python3-misc python3-mmap pyt
 inherit setuptools3
 
 # For compatibility with layers before scarthgap
+PROVIDES = "bmap-tools"
 RREPLACES:${PN} = "bmap-tools"
 RCONFLICTS:${PN} = "bmap-tools"