diff mbox series

[master/scarthgap] php: cleanup more places where php-fpm is creeping in

Message ID 20240417190722.2983348-1-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [master/scarthgap] php: cleanup more places where php-fpm is creeping in | expand

Commit Message

Denys Dmytriyenko April 17, 2024, 7:07 p.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

As php has started giving an error now:

ERROR: php-8.2.16-r0.arago1 do_package: php-fpm does not appear in package list, please add it

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-arago-distro/recipes-devtools/php/php_%.bbappend | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-devtools/php/php_%.bbappend b/meta-arago-distro/recipes-devtools/php/php_%.bbappend
index 7db1f1cb..c2cca255 100644
--- a/meta-arago-distro/recipes-devtools/php/php_%.bbappend
+++ b/meta-arago-distro/recipes-devtools/php/php_%.bbappend
@@ -11,10 +11,14 @@  SRC_URI:append:virtclass-native = " file://0001-php-native-Fix-host-contaminatio
 # Issue mentioned here: https://bugs.php.net/bug.php?id=60144
 
 EXTRA_OECONF:remove = "--enable-fpm"
+EXTRA_OECONF:append = " --disable-fpm"
 
 PACKAGES:remove = "${PN}-fpm"
 PACKAGES:remove = "${PN}-fpm-apache2"
 
+SYSTEMD_PACKAGES:remove = "${PN}-fpm"
+INITSCRIPT_PACKAGES:remove = "${PN}-fpm"
+
 do_install:prepend:pn-php() {
     # Add the below file even though we aren't going to use it.
     # do_install will complain and fail if this file isn't found.