diff mbox series

[meta-arago,scarthgap] meta-arago-extras: packagegroups: Fix QA Issue

Message ID 20240416062317.223194-1-c-shilwant@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,scarthgap] meta-arago-extras: packagegroups: Fix QA Issue | expand

Commit Message

Chirag Shilwant April 16, 2024, 6:23 a.m. UTC
- Since packagegroup.bbclass is using inherit_defer in oe-core, some classes are
now appearing after nativesdk resulting in following QA errors.

 ```
  QA Issue: nativesdk-packagegroup-arago-tisdk-host: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Classes inherited after native/nativesdk: allarch.bbclass [native-last]
  QA Issue: nativesdk-packagegroup-arago-qte-toolchain-host: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Classes inherited after native/nativesdk: allarch.bbclass [native-last]

 ```

- To fix this issue, use inherit_defer that was added in bitbake recently [1].

[1]: https://github.com/openembedded/bitbake/commit/5c2e840eafeba1f0f754c226b87bfb674f7bea29

Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
---
 .../nativesdk-packagegroup-arago-qte-toolchain-host.bb         | 3 ++-
 .../packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb   | 3 ++-
 2 files changed, 4 insertions(+), 2 deletions(-)

Comments

Denys Dmytriyenko April 16, 2024, 3:07 p.m. UTC | #1
On Tue, Apr 16, 2024 at 11:53:17AM +0530, Chirag Shilwant wrote:
> - Since packagegroup.bbclass is using inherit_defer in oe-core, some classes are
> now appearing after nativesdk resulting in following QA errors.
> 
>  ```
>   QA Issue: nativesdk-packagegroup-arago-tisdk-host: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Classes inherited after native/nativesdk: allarch.bbclass [native-last]
>   QA Issue: nativesdk-packagegroup-arago-qte-toolchain-host: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Classes inherited after native/nativesdk: allarch.bbclass [native-last]
> 
>  ```
> 
> - To fix this issue, use inherit_defer that was added in bitbake recently [1].
> 
> [1]: https://github.com/openembedded/bitbake/commit/5c2e840eafeba1f0f754c226b87bfb674f7bea29

Please also merge this to master, not just scarthgap.


> Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
> ---
>  .../nativesdk-packagegroup-arago-qte-toolchain-host.bb         | 3 ++-
>  .../packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb   | 3 ++-
>  2 files changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb
> index 4d2a98ad..23c45abf 100644
> --- a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb
> +++ b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb
> @@ -2,7 +2,8 @@ DESCRIPTION = "Host packages for Qt Embedded SDK"
>  PR = "r10"
>  LICENSE = "MIT"
>  
> -inherit packagegroup nativesdk
> +inherit packagegroup
> +inherit_defer nativesdk
>  
>  RDEPENDS:${PN} = "\
>      nativesdk-packagegroup-arago-tisdk-host \
> diff --git a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb
> index 7e77d12f..92a80b6b 100644
> --- a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb
> +++ b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb
> @@ -2,7 +2,8 @@ SUMMARY = "Host packages for a standalone Arago SDK with TI tools"
>  PR = "r2"
>  LICENSE = "MIT"
>  
> -inherit packagegroup nativesdk
> +inherit packagegroup
> +inherit_defer nativesdk
>  
>  PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
>  
> -- 
> 2.34.1
>
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb
index 4d2a98ad..23c45abf 100644
--- a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb
+++ b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-qte-toolchain-host.bb
@@ -2,7 +2,8 @@  DESCRIPTION = "Host packages for Qt Embedded SDK"
 PR = "r10"
 LICENSE = "MIT"
 
-inherit packagegroup nativesdk
+inherit packagegroup
+inherit_defer nativesdk
 
 RDEPENDS:${PN} = "\
     nativesdk-packagegroup-arago-tisdk-host \
diff --git a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb
index 7e77d12f..92a80b6b 100644
--- a/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb
+++ b/meta-arago-extras/recipes-core/packagegroups/nativesdk-packagegroup-arago-tisdk-host.bb
@@ -2,7 +2,8 @@  SUMMARY = "Host packages for a standalone Arago SDK with TI tools"
 PR = "r2"
 LICENSE = "MIT"
 
-inherit packagegroup nativesdk
+inherit packagegroup
+inherit_defer nativesdk
 
 PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"