diff mbox series

[meta-python,5/5] python3-pydantic-core: Skip failing ptests

Message ID 20240404203546.285796-5-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/5] python3-pydantic-core: Enable benchmark tests | expand

Commit Message

Khem Raj April 4, 2024, 8:35 p.m. UTC
possibly due to oe using newer version of pytest

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-devtools/python/python3-pydantic-core_2.16.3.bb      | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
index 40478cdbb6..934e3e2bb2 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
@@ -48,4 +48,5 @@  do_install:append() {
 
 do_install_ptest() {
     cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
+    sed -i -e "/--automake/ s/$/ -k 'not test_model_class_root_validator_wrap and not test_model_class_root_validator_before and not test_model_class_root_validator_after'/" ${D}${PTEST_PATH}/run-ptest
 }