diff mbox series

[meta-python,3/5] python3-netaddr: Ignore failing tests on musl

Message ID 20240404203546.285796-3-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/5] python3-pydantic-core: Enable benchmark tests | expand

Commit Message

Khem Raj April 4, 2024, 8:35 p.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb b/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb
index 082e7c5025..bedf0dab01 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_1.2.1.bb
@@ -20,3 +20,6 @@  do_install_ptest() {
     cp -rf ${S}/netaddr/tests/* ${D}${PTEST_PATH}/tests/
 }
 
+do_install_ptest:append:libc-musl () {
+    sed -i -e "/--automake/ s/$/ -k 'not test_strategy_ipv6'/" ${D}${PTEST_PATH}/run-ptest
+}