diff mbox series

[meta-python,12/47,v2] python3-blivet: upgrade 3.9.1 -> 3.9.2

Message ID 1711983079-16849-12-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-gnome,01/47,v2] gjs: upgrade 1.80.0 -> 1.80.2 | expand

Commit Message

Mingyu Wang (Fujitsu) April 1, 2024, 2:50 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0006-tweak-btrfs-packages.patch
0011-invoking-dd-with-infinite-timeout.patch
refreshed for 3.9.2

Changelog:
==========
-tests: Add a simple unit test for listing btrfs subvolumes
-Fix getting default subvolume ID for mounted btrfs volumes
-Do not try to get btrfs subvolumes without libblockdev
-Do not raise not implemented exception when checking if btrfs is empty
-Try to start stratisd before checking its availability
-Fix creating Stratis filesystem without size specified
-Fix printing the partition type UUID
-Adjust check for btrfs filesystem being empty
-Fix util.detect_virt on Amazon
-misc: Vagrantfile update
-misc: Run pip with --break-system-packages
-misc: Add missing libmount build dependencies
-availability: Check for mpath friendly names availability
-Allow running blivet without libmount Python bindings
-Fstab cleanup fix
-Fix getting subvolumes for mounted btrfs volumes

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python3-blivet/0006-tweak-btrfs-packages.patch   | 12 ++++++------
 .../0011-invoking-dd-with-infinite-timeout.patch     |  8 ++++----
 ...thon3-blivet_3.9.1.bb => python3-blivet_3.9.2.bb} |  2 +-
 3 files changed, 11 insertions(+), 11 deletions(-)
 rename meta-python/recipes-extended/python-blivet/{python3-blivet_3.9.1.bb => python3-blivet_3.9.2.bb} (93%)
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch
index b98dafeab..6c53f03db 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch
@@ -1,7 +1,7 @@ 
-From 359bc9f60a4bcf6be64a72c3825af65269f6c6c9 Mon Sep 17 00:00:00 2001
+From b55b1023f8f1ad3121928eb9d0ee9902f5474752 Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Mon, 8 May 2017 16:33:15 +0800
-Subject: [PATCH 06/11] tweak btrfs packages
+Subject: [PATCH] tweak btrfs packages
 
 In oe-cre/yocto, we name btrfs package with btrfs-tools,
 rather than btrfs-progs.
@@ -15,10 +15,10 @@  Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  2 files changed, 2 insertions(+), 2 deletions(-)
 
 diff --git a/blivet/devices/btrfs.py b/blivet/devices/btrfs.py
-index 259bcf8..8e4eb2b 100644
+index c446e7e..37c183e 100644
 --- a/blivet/devices/btrfs.py
 +++ b/blivet/devices/btrfs.py
-@@ -57,7 +57,7 @@ class BTRFSDevice(StorageDevice):
+@@ -58,7 +58,7 @@ class BTRFSDevice(StorageDevice):
  
      """ Base class for BTRFS volume and sub-volume devices. """
      _type = "btrfs"
@@ -28,10 +28,10 @@  index 259bcf8..8e4eb2b 100644
  
      def __init__(self, *args, **kwargs):
 diff --git a/blivet/formats/fs.py b/blivet/formats/fs.py
-index 932307a..865b863 100644
+index 1e102b6..f16941e 100644
 --- a/blivet/formats/fs.py
 +++ b/blivet/formats/fs.py
-@@ -1049,7 +1049,7 @@ class BTRFS(FS):
+@@ -1050,7 +1050,7 @@ class BTRFS(FS):
      _formattable = True
      _linux_native = True
      _supported = True
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch
index 48ffaf2cb..ea4cffa9b 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch
@@ -1,7 +1,7 @@ 
-From 3d398173f02bb641473299abb1166fdcc3643666 Mon Sep 17 00:00:00 2001
+From 5ee527fab06f9d33b162a6cd0c068d7b3ac2ecb0 Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Tue, 6 Mar 2018 17:28:56 +0800
-Subject: [PATCH 11/11] invoking dd with infinite timeout
+Subject: [PATCH] invoking dd with infinite timeout
 
 This large timeout is needed when running on machines with
 lots of disks, or with slow disks.
@@ -14,10 +14,10 @@  Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py
-index b60b9b4..fa8858b 100644
+index 2d67be8..a4cf9a0 100644
 --- a/blivet/devices/partition.py
 +++ b/blivet/devices/partition.py
-@@ -667,7 +667,7 @@ class PartitionDevice(StorageDevice):
+@@ -677,7 +677,7 @@ class PartitionDevice(StorageDevice):
          cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs,
                 "seek=%d" % start, "count=%d" % count]
          try:
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.9.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.9.2.bb
similarity index 93%
rename from meta-python/recipes-extended/python-blivet/python3-blivet_3.9.1.bb
rename to meta-python/recipes-extended/python-blivet/python3-blivet_3.9.2.bb
index e9c27548e..f0ce98148 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.9.1.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.9.2.bb
@@ -16,7 +16,7 @@  SRC_URI += "\
            file://0010-invoking-mkfs-with-infinite-timeout.patch \
            file://0011-invoking-dd-with-infinite-timeout.patch \
 "
-SRC_URI[sha256sum] = "fda09ac9ddbbacbb0c00e867006cf36b213b8f5707accdfaaebfd27378f362d8"
+SRC_URI[sha256sum] = "9d97e37ebba01db28a1e6155cbd71c54fb55e9c2be5921982dc85bed316d8cfe"
 
 inherit pypi features_check systemd setuptools3_legacy