[meta-zephyr] zephyr-openthread-rcp: add recipe for OpenThread radio co-processor sample

Message ID 20220223143045.227246-1-stefan@datenfreihafen.org
State New
Headers show
Series [meta-zephyr] zephyr-openthread-rcp: add recipe for OpenThread radio co-processor sample | expand

Commit Message

Stefan Schmidt Feb. 23, 2022, 2:30 p.m. UTC
From: Stefan Schmidt <stefan.schmidt@huawei.com>

This builds the sample for the radio co-processor firmware with a specific
set of overlays to work over USB transport.

Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com>
---
 .../zephyr-kernel/zephyr-openthread-rcp.bb             | 10 ++++++++++
 1 file changed, 10 insertions(+)
 create mode 100644 meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb

Patch

diff --git a/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb b/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
new file mode 100644
index 0000000..708e56a
--- /dev/null
+++ b/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
@@ -0,0 +1,10 @@ 
+include zephyr-sample.inc
+
+ZEPHYR_SRC_DIR = "${S}/samples/net/openthread/coprocessor"
+
+EXTRA_OECMAKE += "-DCONF_FILE="prj.conf overlay-rcp.conf overlay-usb-nrf-br.conf" -DDTC_OVERLAY_FILE="usb.overlay""
+
+# The overlay config and OpenThread itself imposes some specific requirements
+# towards the boards (e.g. flash layout and ieee802154 radio) so we need to
+# limit to known working machines here.
+COMPATIBLE_MACHINE = "(arduino-nano-33-ble)"