diff mbox series

[2/2] arm: use UPSTREAM_CHECK_COMMITS for git versioned recipes

Message ID 20240328201206.14812-2-jon.mason@arm.com
State New
Headers show
Series [1/2] arm/sbsa-acs: use UPSTREAM_CHECK_URI for version checking | expand

Commit Message

Jon Mason March 28, 2024, 8:12 p.m. UTC
Signed-off-by: Jon Mason <jon.mason@arm.com>
---
 meta-arm/recipes-devtools/gn/gn_git.bb                 | 2 ++
 meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb | 3 ++-
 scripts/machine-summary.py                             | 2 ++
 3 files changed, 6 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-arm/recipes-devtools/gn/gn_git.bb b/meta-arm/recipes-devtools/gn/gn_git.bb
index 5a6f19dbab02..7ec340c9d1b8 100644
--- a/meta-arm/recipes-devtools/gn/gn_git.bb
+++ b/meta-arm/recipes-devtools/gn/gn_git.bb
@@ -4,6 +4,8 @@  DEPENDS += "ninja-native"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d"
 
+UPSTREAM_CHECK_COMMITS = "1"
+
 SRC_URI = "git://gn.googlesource.com/gn;protocol=https;branch=main \
            file://0001-Replace-lstat64-stat64-functions-on-linux.patch"
 SRCREV = "4bd1a77e67958fb7f6739bd4542641646f264e5d"
diff --git a/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb b/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb
index df1f3bddc8df..7996e9b36c3f 100644
--- a/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb
+++ b/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb
@@ -22,9 +22,10 @@  FTPM_UUID="bc50d971-d4c9-42c4-82cb-343fb7f37896"
 
 SRC_URI = "gitsm://github.com/Microsoft/ms-tpm-20-ref;branch=main;protocol=https \
            file://0001-add-enum-to-ta-flags.patch"
-
 SRCREV = "d638536d0fe01acd5e39ffa1bd100b3da82d92c7"
 
+UPSTREAM_CHECK_COMMITS = "1"
+
 S = "${WORKDIR}/git"
 
 OPTEE_CLIENT_EXPORT = "${STAGING_DIR_HOST}${prefix}"
diff --git a/scripts/machine-summary.py b/scripts/machine-summary.py
index 477bdfc709ef..455a5176fe5d 100755
--- a/scripts/machine-summary.py
+++ b/scripts/machine-summary.py
@@ -146,9 +146,11 @@  recipes = ("virtual/kernel",
            "edk2-firmware",
            "u-boot",
            "optee-os",
+           "optee-ftpm",
            "hafnium",
            "boot-wrapper-aarch64",
            "gator-daemon",
+           "gn",
            "opencsd",
            "gcc-aarch64-none-elf-native",
            "gcc-arm-none-eabi-native")