diff mbox series

[meta-python,kirkstone,2/3] python3-pyyaml-include: switch to pytest --automake

Message ID 20240327071636.2207445-2-mingli.yu@windriver.com
State New
Headers show
Series [meta-python,kirkstone,1/3] python3-pyyaml-include: add initial recipe for version 1.3.2 | expand

Commit Message

Yu, Mingli March 27, 2024, 7:16 a.m. UTC
From: Tim Orling <ticotimo@gmail.com>

* Also replace ${PYTHON_PN} with python3

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit 182f31a182f6572a3538b875cec7ee761e2da1e6)
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 .../python/python3-pyyaml-include/run-ptest                | 2 +-
 .../python/python3-pyyaml-include_1.3.2.bb                 | 7 ++++---
 2 files changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
index 3385d6893..8d2017d39 100755
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb
index 9bfaa2194..3a5bd99a7 100644
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb
@@ -2,7 +2,7 @@  SUMMARY = "Extending PyYAML with a custom constructor for including YAML files w
 HOMEPAGE = "https://github.com/tanbro/pyyaml-include"
 LICENSE = "GPL-3.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+DEPENDS += "python3-setuptools-scm-native"
 SRCREV = "36b6975aa8fc7a6cbf37de40aa2ed6d996b2f7be"
 
 SRC_URI = " \
@@ -20,9 +20,10 @@  do_install_ptest() {
 }
 
 RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-pyyaml \
+    python3-pyyaml \
 "
 RDEPENDS:${PN}-ptest += " \
-    ${PYTHON_PN}-pytest \
+    python3-pytest \
+    python3-unittest-automake-output \
 "