diff mbox series

[meta-oe,1/2] libcpr: add new recipe

Message ID 20240326203034.532236-1-peter.marko@siemens.com
State Accepted
Headers show
Series [meta-oe,1/2] libcpr: add new recipe | expand

Commit Message

Peter Marko March 26, 2024, 8:30 p.m. UTC
From: Peter Marko <peter.marko@siemens.com>

Curl for People C++ Requests is a simple wrapper around
libcurl inspired by the excellent Python Requests project.

Signed-off-by: Peter Marko <peter.marko@siemens.com>
---
 .../packagegroup-meta-networking.bb           |  1 +
 .../recipes-support/libcpr/libcpr_1.10.5.bb   | 24 +++++++++++++++++++
 2 files changed, 25 insertions(+)
 create mode 100644 meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb
diff mbox series

Patch

diff --git a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
index 941efedd6..2e3aa5441 100644
--- a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
+++ b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
@@ -241,6 +241,7 @@  RDEPENDS:packagegroup-meta-networking-support = "\
     vnstat \
     wpan-tools \
     ettercap \
+    libcpr \
 "
 RDEPENDS:packagegroup-meta-networking-support:remove:mipsarch = "memcached"
 RDEPENDS:packagegroup-meta-networking-support:remove:riscv64 = "memcached"
diff --git a/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb b/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb
new file mode 100644
index 000000000..93fdb78eb
--- /dev/null
+++ b/meta-networking/recipes-support/libcpr/libcpr_1.10.5.bb
@@ -0,0 +1,24 @@ 
+SUMMARY = "Curl for People - C++ Requests"
+DESCRIPTION = "Curl for People C++ Requests is a simple wrapper around \
+    libcurl inspired by the excellent Python Requests project."
+HOMEPAGE = "https://docs.libcpr.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=08beaae5deae1c43c065592da8f38095"
+
+DEPENDS = "curl openssl"
+
+SRC_URI = "git://github.com/libcpr/cpr.git;protocol=https;branch=1.10.x"
+SRCREV = "3b15fa82ea74739b574d705fea44959b58142eb8"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+# building tests is currently using FetchContent for mongoose
+EXTRA_OECMAKE += "\
+    -DCPR_USE_SYSTEM_CURL=ON \
+    -DCPR_BUILD_TESTS=OFF \
+"
+
+BBCLASSEXTEND = "native nativesdk"