diff mbox series

tcl: Forward port skip logic for musl ptests

Message ID 20240326052708.3109288-1-raj.khem@gmail.com
State New
Headers show
Series tcl: Forward port skip logic for musl ptests | expand

Commit Message

Khem Raj March 26, 2024, 5:27 a.m. UTC
commit 9d1df0596f6f3db6f63ae83559fbea3cc372503a overhauled
run-ptest script which did not consider the edits being
done from recipe especially for musl ptests. Bring the skip
editing to follow the new logic in run-ptest

Fixes Failed ptests:
{'tcl': ['unixInit.test']}

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/tcltk/tcl_8.6.14.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.14.bb b/meta/recipes-devtools/tcltk/tcl_8.6.14.bb
index 964824e434a..de4f5b878f6 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.14.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.14.bb
@@ -87,7 +87,7 @@  do_install_ptest() {
 
 do_install_ptest:append:libc-musl () {
 	# Assumes locales other than provided by musl-locales
-	sed -i -e "s|SKIPPED_TESTS='|SKIPPED_TESTS='unixInit-3* |" ${D}${PTEST_PATH}/run-ptest
+	sed -i '/SKIP="$SKIP socket.*$/a # unixInit-3* is suppressed due to hardcoded locale assumptions\nSKIP="$SKIP unixInit-3\\\*"' ${D}${PTEST_PATH}/run-ptest
 }
 
 # Fix some paths that might be used by Tcl extensions