diff mbox series

[[meta-oe] aer-inject:add new recipe] [[meta-oe][PATCH]aer-inject:add new recipe]

Message ID 20240324140659.237067-1-chen_heyun@163.com
State New
Headers show
Series [[meta-oe] aer-inject:add new recipe] [[meta-oe][PATCH]aer-inject:add new recipe] | expand

Commit Message

chenheyun March 24, 2024, 2:06 p.m. UTC
aer-inject allows to inject PCIE AER errors on the software
level into a running Linux kernel. This is intended for validation of the
PCIE driver error recovery handler and CIE AER core handler.

References:
https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/

Signed-off-by: chenheyun <chen_heyun@163.com>
---
 .../aer-inject/aer-inject_1.0.bb              | 25 +++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb

Comments

Khem Raj March 24, 2024, 3:09 p.m. UTC | #1
On Sun, Mar 24, 2024 at 7:07 AM chenheyun <chen_heyun@163.com> wrote:
>
> aer-inject allows to inject PCIE AER errors on the software
> level into a running Linux kernel. This is intended for validation of the
> PCIE driver error recovery handler and CIE AER core handler.
>
> References:
> https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/
>
> Signed-off-by: chenheyun <chen_heyun@163.com>
> ---
>  .../aer-inject/aer-inject_1.0.bb              | 25 +++++++++++++++++++
>  1 file changed, 25 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
>
> diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
> new file mode 100644
> index 000000000..4b1b5e093
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
> @@ -0,0 +1,25 @@
> +SUMMARY = "Inject PCIE AER errors on the software level into a running Linux kernel."
> +DESCRIPTION = "\
> +aer-inject allows to inject PCIE AER errors on the software \
> +level into a running Linux kernel. This is intended for \
> +validation of the PCIE driver error recovery handler and \
> +PCIE AER core handler."
> +HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/"
> +SECTION = "pcie/misc"
> +LICENSE = "GPL-2.0"
> +
> +LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
> +
> +SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;branch=master \

it should need protocol=git as well

> +"
> +SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
> +
> +S = "${WORKDIR}/git"
> +
> +DEPENDS = "bison-native"
> +
> +do_install() {
> +    oe_runmake 'DESTDIR=${D}' install
> +}
> +FILES:${PN} += "/usr/local/aer-inject"

can we change do_install to install it into /usr and not /usr/local

> +BBCLASSEXTEND = "native nativesdk"
> \ No newline at end of file
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109565): https://lists.openembedded.org/g/openembedded-devel/message/109565
> Mute This Topic: https://lists.openembedded.org/mt/105119602/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
chenheyun March 25, 2024, 5:39 a.m. UTC | #2
hi
it is ok to install aer-intall to usr.
like this:
"
do_install() {
echo ${PREFIX}
echo ${D}
oe_runmake 'DESTDIR=${D}' *'PREFIX=/usr/'* install
}
FILES:${PN} += *"/usr/aer-inject* "
"
i reply before this mail. but i dont find history. so i reply newly.
thanks for your suggestions very much!
chenheyun March 25, 2024, 1:56 p.m. UTC | #3
hi
i fix it in 109586;
https://lists.openembedded.org/g/openembedded-devel/message/109586
thanks。
Khem Raj March 25, 2024, 4:50 p.m. UTC | #4
there is another issue

WARNING: aer-inject-1.0-r0 do_package_qa: QA Issue: Recipe LICENSE
includes obsolete licenses GPL-2.0 [obsolete-license]
WARNING: aer-inject-1.0-r0 do_package_qa: QA Issue: File
/usr/.debug/aer-inject in package aer-inject-dbg contains reference to
TMPDIR [buildpaths]

Please look into these too.

On Mon, Mar 25, 2024 at 6:56 AM chenheyun <chen_heyun@163.com> wrote:
>
> hi
>     i fix it in 109586;
> https://lists.openembedded.org/g/openembedded-devel/message/109586
>    thanks。
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109587): https://lists.openembedded.org/g/openembedded-devel/message/109587
> Mute This Topic: https://lists.openembedded.org/mt/105119602/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
chenheyun March 26, 2024, 2:43 p.m. UTC | #5
sorry, i run it on older meta-openembedded,so i dont find this WARNING. now, i know it ,thanks.

this is note in README:
"You should find a copy of v2 of the GNU General Public License
somewhere on your Linux system; if not, write to the Free Software
Foundation,"

then,can i copy  "kernel-source\LICENSES\preferred\GPL-2.0" to files to fix " obsolete licenses GPL-2.0"?

thanks for your suggestions very much!
Khem Raj March 26, 2024, 3:43 p.m. UTC | #6
On Tue, Mar 26, 2024 at 7:43 AM chenheyun <chen_heyun@163.com> wrote:
>
> sorry, i run it on older meta-openembedded,so i dont find this WARNING. now, i know it ,thanks.
>
> this is note in README:
> "You should find a copy of v2 of the GNU General Public License
>    somewhere on your Linux system; if not, write to the Free Software
>    Foundation,"
>
> then,can i copy  "kernel-source\LICENSES\preferred\GPL-2.0" to files to fix "obsolete licenses GPL-2.0"?
>

I think you should change

LICENSE = "GPL-2.0" to
LICENSE = "GPL-2.0-only"

That should fix one problem, for the second problem some object file
is encoding paths into it.
so things like __FILE__ macros in code can do so, they must be removed.

> thanks for your suggestions very much!
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109622): https://lists.openembedded.org/g/openembedded-devel/message/109622
> Mute This Topic: https://lists.openembedded.org/mt/105119602/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
chenheyun March 27, 2024, 1:13 p.m. UTC | #7
hi
i fix it in 109642.like this:
"
LICENSE = "GPL-2.0-only"
+SECTION = "pcie/misc"
*+LICENSE = "GPL-2.0-only"*
+
+LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;protocol=https;branch=master \
+"
+SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "bison-native"
+
*+do_compile() {*
*+    oe_runmake CFLAGS="-Wall -D_GNU_SOURCE"*
*+}*

"
Thanks for the guidance!
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
new file mode 100644
index 000000000..4b1b5e093
--- /dev/null
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
@@ -0,0 +1,25 @@ 
+SUMMARY = "Inject PCIE AER errors on the software level into a running Linux kernel."
+DESCRIPTION = "\
+aer-inject allows to inject PCIE AER errors on the software \
+level into a running Linux kernel. This is intended for \
+validation of the PCIE driver error recovery handler and \
+PCIE AER core handler."
+HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/"
+SECTION = "pcie/misc"
+LICENSE = "GPL-2.0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;branch=master \
+"
+SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "bison-native"
+
+do_install() {
+    oe_runmake 'DESTDIR=${D}' install
+}
+FILES:${PN} += "/usr/local/aer-inject"
+BBCLASSEXTEND = "native nativesdk"
\ No newline at end of file