diff mbox series

sbc: add PACKAGECONFIG tester to make libsndfile1 optional

Message ID 902V.1711219893327416786.MIfH@lists.openembedded.org
State New
Headers show
Series sbc: add PACKAGECONFIG tester to make libsndfile1 optional | expand

Commit Message

Alibek Omarov March 23, 2024, 6:51 p.m. UTC
Noticed that enabling sbc brought libsndfile1->{flac,libogg,vorb
is,etc} chain
dependency. As it wasn't really used by anything critical, made this dependency
optional.

Fixes: fc6375426f94 ("sbc: SBC audio codec")
Signed-off-by: Alibek Omarov < a1ba.omarov@gmail.com >
---
meta/recipes-multimedia/sbc/ s bc_2.0.bb ( http://sbc_2.0.bb ) | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

--
2.34.1

Comments

patchtest@automation.yoctoproject.org March 23, 2024, 7:04 p.m. UTC | #1
Thank you for your submission. Patchtest identified one
or more issues with the patch. Please see the log below for
more information:

---
Testing patch /home/patchtest/share/mboxes/sbc-add-PACKAGECONFIG-tester-to-make-libsndfile1-optional.patch

FAIL: test mbox format: Series has malformed diff lines. Create the series again using git-format-patch and ensure it applies using git am (test_mbox.TestMbox.test_mbox_format)

PASS: test Signed-off-by presence (test_mbox.TestMbox.test_signed_off_by_presence)
PASS: test author valid (test_mbox.TestMbox.test_author_valid)
PASS: test commit message presence (test_mbox.TestMbox.test_commit_message_presence)
PASS: test max line length (test_metadata.TestMetadata.test_max_line_length)
PASS: test non-AUH upgrade (test_mbox.TestMbox.test_non_auh_upgrade)
PASS: test shortlog format (test_mbox.TestMbox.test_shortlog_format)
PASS: test shortlog length (test_mbox.TestMbox.test_shortlog_length)
PASS: test target mailing list (test_mbox.TestMbox.test_target_mailing_list)

SKIP: pretest pylint: Python-unidiff parse error (test_python_pylint.PyLint.pretest_pylint)
SKIP: pretest src uri left files: Patch cannot be merged (test_metadata.TestMetadata.pretest_src_uri_left_files)
SKIP: test CVE check ignore: No modified recipes or older target branch, skipping test (test_metadata.TestMetadata.test_cve_check_ignore)
SKIP: test CVE tag format: Parse error Hunk diff line expected: file://src/sbcenc.c; beginline=1;endline=24;md5=08e 7a70b127f4100ff2cd7d629147d8d \
SKIP: test Signed-off-by presence: Parse error Hunk diff line expected: file://src/sbcenc.c; beginline=1;endline=24;md5=08e 7a70b127f4100ff2cd7d629147d8d \
SKIP: test Upstream-Status presence: Parse error Hunk diff line expected: file://src/sbcenc.c; beginline=1;endline=24;md5=08e 7a70b127f4100ff2cd7d629147d8d \
SKIP: test bugzilla entry format: No bug ID found (test_mbox.TestMbox.test_bugzilla_entry_format)
SKIP: test lic files chksum modified not mentioned: No modified recipes, skipping test (test_metadata.TestMetadata.test_lic_files_chksum_modified_not_mentioned)
SKIP: test lic files chksum presence: No added recipes, skipping test (test_metadata.TestMetadata.test_lic_files_chksum_presence)
SKIP: test license presence: No added recipes, skipping test (test_metadata.TestMetadata.test_license_presence)
SKIP: test pylint: Python-unidiff parse error (test_python_pylint.PyLint.test_pylint)
SKIP: test series merge on head: Merge test is disabled for now (test_mbox.TestMbox.test_series_merge_on_head)
SKIP: test src uri left files: Patch cannot be merged (test_metadata.TestMetadata.test_src_uri_left_files)
SKIP: test summary presence: No added recipes, skipping test (test_metadata.TestMetadata.test_summary_presence)

---

Please address the issues identified and
submit a new revision of the patch, or alternatively, reply to this
email with an explanation of why the patch should be accepted. If you
believe these results are due to an error in patchtest, please submit a
bug at https://bugzilla.yoctoproject.org/ (use the 'Patchtest' category
under 'Yocto Project Subprojects'). For more information on specific
failures, see: https://wiki.yoctoproject.org/wiki/Patchtest. Thank
you!
diff mbox series

Patch

diff --git a/meta/recipes-multimedia/sbc/ sbc_2.0.bb ( http://sbc_2.0.bb ) b/meta/recipes-multimedia/sbc/ sbc_2.0.bb ( http://sbc_2.0.bb )
index d25be9e80c..2b1e2d0441 100644
--- a/meta/recipes-multimedia/sbc/ sbc_2.0.bb ( http://sbc_2.0.bb )
+++ b/meta/recipes-multimedia/sbc/ sbc_2.0.bb ( http://sbc_2.0.bb )
@@ -10,13 +10,14 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae 1ff87c09e5b7ccc2c4ca7e \
file://src/sbcenc.c; beginline=1;endline=24;md5=08e 7a70b127f4100ff2cd7d629147d8d \
file://sbc/sbc.h;beginline=1; endline=26;md5=0f57d0df22b0d40 746bdd29805a4361b"

-DEPENDS = "libsndfile1"
-
SRC_URI = "${KERNELORG_MIRROR}/linux/blu etooth/${BP}.tar.xz"

SRC_URI[sha256sum] = "8f12368e1dbbf55e14536520473cf b338c84b392939cc9b64298360fd4a 07992"

inherit autotools pkgconfig

+PACKAGECONFIG ??= "tester"
+PACKAGECONFIG[tester] = ",--disable-tester,libsndfile1 "
+
PACKAGES =+ "${PN}-examples"
FILES:${PN}-examples += "${bindir}/*"