diff mbox series

[meta-python,41/50] python3-requests-oauthlib: upgrade 1.3.1 -> 1.4.0

Message ID 1710827139-30056-41-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-oe,01/50] boost-sml: upgrade 1.1.9 -> 1.1.11 | expand

Commit Message

Mingyu Wang (Fujitsu) March 19, 2024, 5:45 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-OAuth2Session now correctly uses the self.verify value if verify is not overridden in fetch_token and refresh_token.
-OAuth2Session constructor now uses its client.scope when a client is provided and scope is not overridden.
-Add refresh_token_request and access_token_request compliance hooks
-Add PKCE support and Auth0 example
-Add support for Python 3.8-3.12
-Remove support of Python 2.x, <3.7
-Migrated to Github Action
-Updated dependencies
-Cleanup some docs and examples

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...sts-oauthlib_1.3.1.bb => python3-requests-oauthlib_1.4.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-requests-oauthlib_1.3.1.bb => python3-requests-oauthlib_1.4.0.bb} (66%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-requests-oauthlib_1.3.1.bb b/meta-python/recipes-devtools/python/python3-requests-oauthlib_1.4.0.bb
similarity index 66%
rename from meta-python/recipes-devtools/python/python3-requests-oauthlib_1.3.1.bb
rename to meta-python/recipes-devtools/python/python3-requests-oauthlib_1.4.0.bb
index 8c2f891c1..76b14585b 100644
--- a/meta-python/recipes-devtools/python/python3-requests-oauthlib_1.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-requests-oauthlib_1.4.0.bb
@@ -1,7 +1,7 @@ 
 LICENSE = "ISC"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=22d117a849df10d047ed9b792838e863"
 
-SRC_URI[sha256sum] = "75beac4a47881eeb94d5ea5d6ad31ef88856affe2332b9aafb52c6452ccf0d7a"
+SRC_URI[sha256sum] = "acee623221e4a39abcbb919312c8ff04bd44e7e417087fb4bd5e2a2f53d5e79a"
 
 inherit pypi setuptools3