[v3,28/32] numpy: set PIP_INSTALL_PACKAGE

Message ID 0ce1d22a61cf8978ec9672ee0bbeb5153ec102dc.1645557032.git.tim.orling@konsulko.com
State New
Headers show
Series [v3,01/32] python3-wheel: move 0.37.1 from meta-python | expand

Commit Message

Tim Orling Feb. 22, 2022, 7:16 p.m. UTC
The recipe does not inherit pypi so we need to manually set
PIP_INSTALL_PACKAGE appropriately.

[YOCTO #14638]

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta/recipes-devtools/python/python3-numpy_1.22.2.bb | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta/recipes-devtools/python/python3-numpy_1.22.2.bb b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
index 52fbca94e2c..d2b2f3e38d5 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.22.2.bb
@@ -20,6 +20,7 @@  UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
 DEPENDS += "python3-cython-native"
 
 inherit ptest setuptools3
+PIP_INSTALL_PACKAGE = "numpy"
 
 S = "${WORKDIR}/numpy-${PV}"