diff mbox series

[33/36] tcl: upgrade 8.6.13 -> 8.6.14

Message ID 1710313714-12541-33-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [01/36] debianutils: upgrade 5.16 -> 5.17 | expand

Commit Message

Mingyu Wang (Fujitsu) March 13, 2024, 7:08 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

fix_issue_with_old_distro_glibc.patch
fix_non_native_build_issue.patch
refreshed for 8.6.14

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../tcl/fix_issue_with_old_distro_glibc.patch | 28 +++++++++++--------
 .../tcl/fix_non_native_build_issue.patch      | 25 ++++++++++-------
 .../tcltk/{tcl_8.6.13.bb => tcl_8.6.14.bb}    |  2 +-
 3 files changed, 33 insertions(+), 22 deletions(-)
 rename meta/recipes-devtools/tcltk/{tcl_8.6.13.bb => tcl_8.6.14.bb} (97%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/tcltk/tcl/fix_issue_with_old_distro_glibc.patch b/meta/recipes-devtools/tcltk/tcl/fix_issue_with_old_distro_glibc.patch
index 2c31cec8e3..f8acaf406f 100644
--- a/meta/recipes-devtools/tcltk/tcl/fix_issue_with_old_distro_glibc.patch
+++ b/meta/recipes-devtools/tcltk/tcl/fix_issue_with_old_distro_glibc.patch
@@ -14,12 +14,15 @@  Fixes tcl target recipe build on old distros which have glibc older than 2.14
 
 Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
 2012/04/26
+---
+ unix/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
 
-Index: unix/Makefile.in
-===================================================================
---- a/unix.orig/Makefile.in	2013-11-10 23:38:01.787425628 -0800
-+++ b/unix/Makefile.in	2013-11-10 23:37:59.807425578 -0800
-@@ -686,7 +686,7 @@
+diff --git a/unix/Makefile.in b/unix/Makefile.in
+index 7604959..c52cf2d 100644
+--- a/unix/Makefile.in
++++ b/unix/Makefile.in
+@@ -792,7 +792,7 @@ topDirName:
  # tcltest executable gets the build directory burned into its ld search path.
  # This keeps tcltest from picking up an already installed version of the Tcl
  # library.
@@ -28,12 +31,15 @@  Index: unix/Makefile.in
  		TCLLIBPATH="@abs_builddir@/pkgs" \
  		TCL_LIBRARY="${TCL_BUILDTIME_LIBRARY}"
  
-@@ -712,7 +712,7 @@
+@@ -818,7 +818,7 @@ test-tcl: ${TCLTEST_EXE}
  	$(SHELL_ENV) ${TCLTEST_EXE} $(TOP_DIR)/tests/all.tcl $(TESTFLAGS)
  
  gdb-test: ${TCLTEST_EXE}
--	@echo "set env @LD_LIBRARY_PATH_VAR@=`pwd`:$${@LD_LIBRARY_PATH_VAR@}" > gdb.run
-+	@echo "set env @LD_LIBRARY_PATH_VAR@=$${@LD_LIBRARY_PATH_VAR@}" > gdb.run
- 	@echo "set env TCL_LIBRARY=${TCL_BUILDTIME_LIBRARY}" >> gdb.run
- 	@echo "set args $(TOP_DIR)/tests/all.tcl $(TESTFLAGS) -singleproc 1" >> gdb.run
- 	$(GDB) ${TCLTEST_EXE} --command=gdb.run
+-	@printf '%s ' set env @LD_LIBRARY_PATH_VAR@=\"`pwd`$${@LD_LIBRARY_PATH_VAR@:+:$${@LD_LIBRARY_PATH_VAR}}\" > gdb.run
++	@printf '%s ' set env @LD_LIBRARY_PATH_VAR@=\"$${@LD_LIBRARY_PATH_VAR@:+:$${@LD_LIBRARY_PATH_VAR}}\" > gdb.run
+ 	@printf '\n' >>gdb.run
+ 	@printf '%s ' set env TCL_LIBRARY=\'$(call shquotesingle,${TCL_BUILDTIME_LIBRARY})\' >> gdb.run
+ 	@printf '\n' >>gdb.run
+-- 
+2.34.1
+
diff --git a/meta/recipes-devtools/tcltk/tcl/fix_non_native_build_issue.patch b/meta/recipes-devtools/tcltk/tcl/fix_non_native_build_issue.patch
index 6dbef7077f..931ea1e975 100644
--- a/meta/recipes-devtools/tcltk/tcl/fix_non_native_build_issue.patch
+++ b/meta/recipes-devtools/tcltk/tcl/fix_non_native_build_issue.patch
@@ -4,16 +4,15 @@  Date: Fri, 13 Aug 2010 12:24:00 -0700
 Subject: [PATCH] tcl: fix a build issue
 
 Upstream-Status: Inappropriate [upstream does not support installed tests]
-
 ---
- unix/Makefile.in | 20 ++++++++++----------
- 1 file changed, 10 insertions(+), 10 deletions(-)
+ unix/Makefile.in | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
 
 diff --git a/unix/Makefile.in b/unix/Makefile.in
-index b110fe9..d7b35a8 100644
+index 9dd053d..7604959 100644
 --- a/unix/Makefile.in
 +++ b/unix/Makefile.in
-@@ -814,23 +814,23 @@ tcltest-real:
+@@ -815,7 +815,7 @@ tcltest-real:
  test: test-tcl test-packages
  
  test-tcl: ${TCLTEST_EXE}
@@ -21,9 +20,11 @@  index b110fe9..d7b35a8 100644
 +	$(SHELL_ENV) ${TCLTEST_EXE} $(TOP_DIR)/tests/all.tcl $(TESTFLAGS)
  
  gdb-test: ${TCLTEST_EXE}
- 	@echo "set env @LD_LIBRARY_PATH_VAR@=`pwd`:$${@LD_LIBRARY_PATH_VAR@}" > gdb.run
- 	@echo "set env TCL_LIBRARY=${TCL_BUILDTIME_LIBRARY}" >> gdb.run
- 	@echo "set args $(TOP_DIR)/tests/all.tcl $(TESTFLAGS) -singleproc 1" >> gdb.run
+ 	@printf '%s ' set env @LD_LIBRARY_PATH_VAR@=\"`pwd`$${@LD_LIBRARY_PATH_VAR@:+:$${@LD_LIBRARY_PATH_VAR}}\" > gdb.run
+@@ -824,17 +824,17 @@ gdb-test: ${TCLTEST_EXE}
+ 	@printf '\n' >>gdb.run
+ 	@printf '%s ' set args $(call shquotequote,$(TOP_DIR))/tests/all.tcl\
+ 		$(call shquotequote,$(TESTFLAGS)) -singleproc 1 >> gdb.run
 -	$(GDB) ./${TCLTEST_EXE} --command=gdb.run
 +	$(GDB) ${TCLTEST_EXE} --command=gdb.run
  	rm gdb.run
@@ -41,7 +42,7 @@  index b110fe9..d7b35a8 100644
  
  # The following target generates the shared libraries in dltest/ that are used
  # for testing; they are included as part of the "tcltest" target (via the
-@@ -848,28 +848,28 @@ dltest.marker: ${STUB_LIB_FILE}
+@@ -852,28 +852,28 @@ dltest.marker: ${STUB_LIB_FILE}
  # This target can be used to run tclsh from the build directory
  # via `make shell SCRIPT=/tmp/foo.tcl`
  shell: ${TCL_EXE}
@@ -54,7 +55,8 @@  index b110fe9..d7b35a8 100644
 +	$(SHELL_ENV) $(GDB) ${TCL_EXE}
  
  lldb: ${TCL_EXE}
- 	$(SHELL_ENV) $(LLDB) ./${TCL_EXE}
+-	$(SHELL_ENV) $(LLDB) ./${TCL_EXE}
++	$(SHELL_ENV) $(LLDB) ${TCL_EXE}
  
  valgrind: ${TCL_EXE} ${TCLTEST_EXE}
 -	$(SHELL_ENV) $(VALGRIND) $(VALGRINDARGS) ./${TCLTEST_EXE} \
@@ -76,3 +78,6 @@  index b110fe9..d7b35a8 100644
  
  #--------------------------------------------------------------------------
  # Installation rules
+-- 
+2.34.1
+
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.13.bb b/meta/recipes-devtools/tcltk/tcl_8.6.14.bb
similarity index 97%
rename from meta/recipes-devtools/tcltk/tcl_8.6.13.bb
rename to meta/recipes-devtools/tcltk/tcl_8.6.14.bb
index bb75353a5a..8fdccbaa90 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.13.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.14.bb
@@ -25,7 +25,7 @@  SRC_URI = "${BASE_SRC_URI} \
            file://interp.patch \
            file://run-ptest \
 "
-SRC_URI[sha256sum] = "c61f0d6699e2bc7691f119b41963aaa8dc980f23532c4e937739832a5f4a6642"
+SRC_URI[sha256sum] = "ff604f43862a778827d7ecd1ad7686950ac2ef48d9cf69d3424cea9de08d9a72"
 
 SRC_URI:class-native = "${BASE_SRC_URI}"