diff mbox series

[26/36] python3-pyparsing: upgrade 3.1.1 -> 3.1.2

Message ID 1710313714-12541-26-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [01/36] debianutils: upgrade 5.16 -> 5.17 | expand

Commit Message

Mingyu Wang (Fujitsu) March 13, 2024, 7:08 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
- Added 'ieee_float' expression to 'pyparsing.common', which parses float values,
  plus "NaN", "Inf", "Infinity".
- Updated pep8 synonym wrappers for better type checking compatibility.
- Fixed empty error message bug. This _should_ return pyparsing's exception
  messages to a former, more helpful form. If you have code that parses the
  exception messages returned by pyparsing, this may require some code changes.
- Added unit tests to test for exception message contents, with enhancement to
  'pyparsing.testing.assertRaisesParseException' to accept an expected exception message.
- Updated example 'select_parser.py' to use PEP8 names and added Groups for better retrieval
  of parsed values from multiple SELECT clauses.
- Added example 'email_address_parser.py'
- Added example 'directx_x_file_parser.py' to parse DirectX template definitions, and
  generate a Pyparsing parser from a template to parse .x files.
- Some code refactoring to reduce code nesting
- All internal string expressions using '%' string interpolation and 'str.format()'
  converted to f-strings.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pyparsing_3.1.1.bb => python3-pyparsing_3.1.2.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-pyparsing_3.1.1.bb => python3-pyparsing_3.1.2.bb} (90%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pyparsing_3.1.1.bb b/meta/recipes-devtools/python/python3-pyparsing_3.1.2.bb
similarity index 90%
rename from meta/recipes-devtools/python/python3-pyparsing_3.1.1.bb
rename to meta/recipes-devtools/python/python3-pyparsing_3.1.2.bb
index 6f34091c86..64210ade53 100644
--- a/meta/recipes-devtools/python/python3-pyparsing_3.1.1.bb
+++ b/meta/recipes-devtools/python/python3-pyparsing_3.1.2.bb
@@ -10,7 +10,7 @@  BUGTRACKER = "https://github.com/pyparsing/pyparsing/issues"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1"
 
-SRC_URI[sha256sum] = "ede28a1a32462f5a9705e07aea48001a08f7cf81a021585011deba701581a0db"
+SRC_URI[sha256sum] = "a1bac0ce561155ecc3ed78ca94d3c9378656ad4c94c1270de543f621420f94ad"
 
 UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar"