diff mbox series

[meta-python] python3-invoke: add recipe

Message ID 20240306165441.429620-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-invoke: add recipe | expand

Commit Message

alperak March 6, 2024, 4:54 p.m. UTC
Invoke is a Python library for managing shell-oriented subprocesses and organizing executable Python code into CLI-invokable tasks. It draws inspiration from various sources (make/rake, Fabric 1.x, etc) to arrive at a powerful & clean feature set.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-invoke_2.2.0.bb             | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb

Comments

Tim Orling March 7, 2024, 4:23 a.m. UTC | #1
On Wed, Mar 6, 2024 at 8:55 AM Alper Ak <alperyasinak1@gmail.com> wrote:

> Invoke is a Python library for managing shell-oriented subprocesses and
> organizing executable Python code into CLI-invokable tasks. It draws
> inspiration from various sources (make/rake, Fabric 1.x, etc) to arrive at
> a powerful & clean feature set.


We should really gently judge upstream to update their pyproject.toml to
use a proper build-backend. There is nothing special in their setup.py

>
>
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  .../python/python3-invoke_2.2.0.bb             | 18 ++++++++++++++++++
>  1 file changed, 18 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/
> python3-invoke_2.2.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb
> b/meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb
> new file mode 100644
> index 000000000..3f2e6232d
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb
> @@ -0,0 +1,18 @@
> +SUMMARY = "Pythonic task execution"
> +HOMEPAGE = "https://www.pyinvoke.org/"
> +LICENSE = "BSD-2-Clause"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=a8815068973f31b78c328dc067e297ab"
> +
> +SRC_URI[sha256sum] =
> "ee6cbb101af1a859c7fe84f2a264c059020b0cb7fe3535f9424300ab568f6bd5"
> +
> +inherit pypi setuptools3
> +
> +RDEPENDS:${PN} += " \
> +        python3-fcntl \
> +        python3-json \
> +        python3-logging \
> +        python3-pprint \
> +        python3-terminal \
> +        python3-unittest \
> +        python3-unixadmin \
> +"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109172):
> https://lists.openembedded.org/g/openembedded-devel/message/109172
> Mute This Topic: https://lists.openembedded.org/mt/104769770/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb b/meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb
new file mode 100644
index 000000000..3f2e6232d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-invoke_2.2.0.bb
@@ -0,0 +1,18 @@ 
+SUMMARY = "Pythonic task execution"
+HOMEPAGE = "https://www.pyinvoke.org/"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a8815068973f31b78c328dc067e297ab"
+
+SRC_URI[sha256sum] = "ee6cbb101af1a859c7fe84f2a264c059020b0cb7fe3535f9424300ab568f6bd5"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+        python3-fcntl \
+        python3-json \
+        python3-logging \
+        python3-pprint \
+        python3-terminal \
+        python3-unittest \
+        python3-unixadmin \
+"