diff mbox series

[meta-oe,1/2] abseil-cpp: A little clean-up

Message ID 20240306162737.1722284-1-pkj@axis.com
State Accepted
Headers show
Series [meta-oe,1/2] abseil-cpp: A little clean-up | expand

Commit Message

Peter Kjellerstedt March 6, 2024, 4:27 p.m. UTC
* Remove ASNEEDED:class-native and ASNEEDED:class-nativesdk as they make
  no difference since ${ASNEEDED} is only added to TARGET_LDFLAGS.
* Remove additions to FILES:${PN}-dev since the added paths are already
  added by default.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---
 .../recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)

Comments

Khem Raj March 6, 2024, 4:49 p.m. UTC | #1
Which branch is it intended for?, if it is master then always rebase
and test patches on latest master or master-next, otherwise add the
name of branch in subject prefix
makes it easy for maintainers to route the patch.

On Wed, Mar 6, 2024 at 8:27 AM Peter Kjellerstedt
<peter.kjellerstedt@axis.com> wrote:
>
> * Remove ASNEEDED:class-native and ASNEEDED:class-nativesdk as they make
>   no difference since ${ASNEEDED} is only added to TARGET_LDFLAGS.
> * Remove additions to FILES:${PN}-dev since the added paths are already
>   added by default.
>
> Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
> ---
>  .../recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb | 9 ++-------
>  1 file changed, 2 insertions(+), 7 deletions(-)
>
> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> index 1ce6ff3fc..667693a4c 100644
> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> @@ -1,7 +1,7 @@
>  SUMMARY = "Abseil is a cpp library like STL"
>  DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
>  additional useful libraries like algorithm, container, debugging, hash, memory, \
> -meta, numeric, strings, synchronization, time, types and utility"
> +meta, numeric, strings, synchronization, time, types and utility."
>  HOMEPAGE = "https://abseil.io/"
>  SECTION = "libs"
>  LICENSE = "Apache-2.0"
> @@ -19,9 +19,6 @@ SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
>
>  S = "${WORKDIR}/git"
>
> -ASNEEDED:class-native = ""
> -ASNEEDED:class-nativesdk = ""
> -
>  inherit cmake
>
>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> @@ -29,8 +26,6 @@ EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
>                   -DABSL_ENABLE_INSTALL=ON \
>                  "
>
> -BBCLASSEXTEND = "native nativesdk"
> -
>  SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
>
> -FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"
> +BBCLASSEXTEND = "native nativesdk"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109170): https://lists.openembedded.org/g/openembedded-devel/message/109170
> Mute This Topic: https://lists.openembedded.org/mt/104769052/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Peter Kjellerstedt March 6, 2024, 5:05 p.m. UTC | #2
> -----Original Message-----
> From: openembedded-devel@lists.openembedded.org <openembedded-
> devel@lists.openembedded.org> On Behalf Of Khem Raj
> Sent: den 6 mars 2024 17:49
> To: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
> Cc: openembedded-devel@lists.openembedded.org
> Subject: Re: [oe] [meta-oe][PATCH 1/2] abseil-cpp: A little clean-up
> 
> Which branch is it intended for?, if it is master then always rebase
> and test patches on latest master or master-next, otherwise add the
> name of branch in subject prefix
> makes it easy for maintainers to route the patch.

It _is_ based on current master. I do not use master-next as I assume 
it to be a work in progress until it is merged to master.

//Peter

> 
> On Wed, Mar 6, 2024 at 8:27 AM Peter Kjellerstedt <peter.kjellerstedt@axis.com> wrote:
> >
> > * Remove ASNEEDED:class-native and ASNEEDED:class-nativesdk as they make
> >   no difference since ${ASNEEDED} is only added to TARGET_LDFLAGS.
> > * Remove additions to FILES:${PN}-dev since the added paths are already
> >   added by default.
> >
> > Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
> > ---
> >  .../recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb | 9 ++-------
> >  1 file changed, 2 insertions(+), 7 deletions(-)
> >
> > diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> > index 1ce6ff3fc..667693a4c 100644
> > --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> > +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> > @@ -1,7 +1,7 @@
> >  SUMMARY = "Abseil is a cpp library like STL"
> >  DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
> >  additional useful libraries like algorithm, container, debugging, hash, memory, \
> > -meta, numeric, strings, synchronization, time, types and utility"
> > +meta, numeric, strings, synchronization, time, types and utility."
> >  HOMEPAGE = "https://abseil.io/"
> >  SECTION = "libs"
> >  LICENSE = "Apache-2.0"
> > @@ -19,9 +19,6 @@ SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
> >
> >  S = "${WORKDIR}/git"
> >
> > -ASNEEDED:class-native = ""
> > -ASNEEDED:class-nativesdk = ""
> > -
> >  inherit cmake
> >
> >  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> > @@ -29,8 +26,6 @@ EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> >                   -DABSL_ENABLE_INSTALL=ON \
> >                  "
> >
> > -BBCLASSEXTEND = "native nativesdk"
> > -
> >  SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
> >
> > -FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"
> > +BBCLASSEXTEND = "native nativesdk"
> >
> >
> >
Khem Raj March 6, 2024, 5:22 p.m. UTC | #3
On Wed, Mar 6, 2024 at 9:05 AM Peter Kjellerstedt
<peter.kjellerstedt@axis.com> wrote:
>
> > -----Original Message-----
> > From: openembedded-devel@lists.openembedded.org <openembedded-
> > devel@lists.openembedded.org> On Behalf Of Khem Raj
> > Sent: den 6 mars 2024 17:49
> > To: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
> > Cc: openembedded-devel@lists.openembedded.org
> > Subject: Re: [oe] [meta-oe][PATCH 1/2] abseil-cpp: A little clean-up
> >
> > Which branch is it intended for?, if it is master then always rebase
> > and test patches on latest master or master-next, otherwise add the
> > name of branch in subject prefix
> > makes it easy for maintainers to route the patch.
>
> It _is_ based on current master. I do not use master-next as I assume
> it to be a work in progress until it is merged to master.

Thanks, there is an upgrade for this recipe staged in master-next. perhaps
would be good to test it on top of that and see if this works as you
intend it to

>
> //Peter
>
> >
> > On Wed, Mar 6, 2024 at 8:27 AM Peter Kjellerstedt <peter.kjellerstedt@axis.com> wrote:
> > >
> > > * Remove ASNEEDED:class-native and ASNEEDED:class-nativesdk as they make
> > >   no difference since ${ASNEEDED} is only added to TARGET_LDFLAGS.
> > > * Remove additions to FILES:${PN}-dev since the added paths are already
> > >   added by default.
> > >
> > > Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
> > > ---
> > >  .../recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb | 9 ++-------
> > >  1 file changed, 2 insertions(+), 7 deletions(-)
> > >
> > > diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> > > index 1ce6ff3fc..667693a4c 100644
> > > --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> > > +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
> > > @@ -1,7 +1,7 @@
> > >  SUMMARY = "Abseil is a cpp library like STL"
> > >  DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
> > >  additional useful libraries like algorithm, container, debugging, hash, memory, \
> > > -meta, numeric, strings, synchronization, time, types and utility"
> > > +meta, numeric, strings, synchronization, time, types and utility."
> > >  HOMEPAGE = "https://abseil.io/"
> > >  SECTION = "libs"
> > >  LICENSE = "Apache-2.0"
> > > @@ -19,9 +19,6 @@ SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
> > >
> > >  S = "${WORKDIR}/git"
> > >
> > > -ASNEEDED:class-native = ""
> > > -ASNEEDED:class-nativesdk = ""
> > > -
> > >  inherit cmake
> > >
> > >  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> > > @@ -29,8 +26,6 @@ EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> > >                   -DABSL_ENABLE_INSTALL=ON \
> > >                  "
> > >
> > > -BBCLASSEXTEND = "native nativesdk"
> > > -
> > >  SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
> > >
> > > -FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"
> > > +BBCLASSEXTEND = "native nativesdk"
> > >
> > >
> > >
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
index 1ce6ff3fc..667693a4c 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20230802.1.bb
@@ -1,7 +1,7 @@ 
 SUMMARY = "Abseil is a cpp library like STL"
 DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
 additional useful libraries like algorithm, container, debugging, hash, memory, \
-meta, numeric, strings, synchronization, time, types and utility"
+meta, numeric, strings, synchronization, time, types and utility."
 HOMEPAGE = "https://abseil.io/"
 SECTION = "libs"
 LICENSE = "Apache-2.0"
@@ -19,9 +19,6 @@  SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
 
 S = "${WORKDIR}/git"
 
-ASNEEDED:class-native = ""
-ASNEEDED:class-nativesdk = ""
-
 inherit cmake
 
 EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
@@ -29,8 +26,6 @@  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
                  -DABSL_ENABLE_INSTALL=ON \
                 "
 
-BBCLASSEXTEND = "native nativesdk"
-
 SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
 
-FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"
+BBCLASSEXTEND = "native nativesdk"