diff mbox series

[meta-python,12/26] python3-astroid: upgrade 3.0.3 -> 3.1.0

Message ID 1709714608-19296-12-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-oe,01/26] abseil-cpp: upgrade 20230802.1 -> 20240116.1 | expand

Commit Message

Mingyu Wang (Fujitsu) March 6, 2024, 8:43 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
-Include PEP 695 (Python 3.12) generic type syntax nodes in get_children(),
 allowing checkers to visit them.
-Add __main__ as a possible inferred value for __name__ to improve
 control flow inference around if __name__ == "__main__": guards.
-Following a deprecation period, the names arg to the Import constructor and
 the op arg to the BoolOp constructor are now required, and the doc args
 to the PartialFunction and Property constructors have been removed (call
 postinit(doc_node=...) instead.)
-Following a deprecation announced in astroid 1.5.0, the alias
 AstroidBuildingException is removed in favor of AstroidBuildingError.
-Include modname in AST warnings. Useful for invalid escape sequence warnings
 with Python 3.12.
-RecursionError is now trapped and logged out as UserWarning during astroid node
 transformations with instructions about raising the system recursion limit.
 Suppress SyntaxWarning for invalid escape sequences on Python 3.12 when parsing modules.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-astroid_3.0.3.bb => python3-astroid_3.1.0.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-astroid_3.0.3.bb => python3-astroid_3.1.0.bb} (90%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-astroid_3.0.3.bb b/meta-python/recipes-devtools/python/python3-astroid_3.1.0.bb
similarity index 90%
rename from meta-python/recipes-devtools/python/python3-astroid_3.0.3.bb
rename to meta-python/recipes-devtools/python/python3-astroid_3.1.0.bb
index b02b15113..3c68f1e58 100644
--- a/meta-python/recipes-devtools/python/python3-astroid_3.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-astroid_3.1.0.bb
@@ -4,7 +4,7 @@  SECTION = "devel/python"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
 
-SRC_URI[sha256sum] = "4148645659b08b70d72460ed1921158027a9e53ae8b7234149b1400eddacbb93"
+SRC_URI[sha256sum] = "ac248253bfa4bd924a0de213707e7ebeeb3138abeb48d798784ead1e56d419d4"
 
 inherit pypi python_setuptools_build_meta