diff mbox series

[meta-rockchip] rock-5[ab]: use regular yocto kernel

Message ID 20240303231309.33027-1-twoerner@gmail.com
State New
Headers show
Series [meta-rockchip] rock-5[ab]: use regular yocto kernel | expand

Commit Message

Trevor Woerner March 3, 2024, 11:13 p.m. UTC
Upstream kernel support for both the rock-5a and rock-5b landed in version
6.5. Nanbield contained linux-yocto recipes for both 6.1 and 6.5 so it
was best to simply have these MACHINEs use linux-yocto-dev. Post-nanbield
oecore master only has a recipe for 6.6 (so far), therefore these two
MACHINEs can use linux-yocto by default, instead of linux-yocto-dev.

Signed-off-by: Trevor Woerner <twoerner@gmail.com>
---
 conf/machine/rock-5a.conf                     | 1 -
 conf/machine/rock-5b.conf                     | 1 -
 recipes-kernel/linux/linux-yocto-dev.bbappend | 4 ----
 recipes-kernel/linux/linux-yocto_%.bbappend   | 2 ++
 4 files changed, 2 insertions(+), 6 deletions(-)

Comments

Trevor Woerner March 7, 2024, 10:05 p.m. UTC | #1
On Sun 2024-03-03 @ 06:13:09 PM, Trevor Woerner wrote:
> Upstream kernel support for both the rock-5a and rock-5b landed in version
> 6.5. Nanbield contained linux-yocto recipes for both 6.1 and 6.5 so it
> was best to simply have these MACHINEs use linux-yocto-dev. Post-nanbield
> oecore master only has a recipe for 6.6 (so far), therefore these two
> MACHINEs can use linux-yocto by default, instead of linux-yocto-dev.
> 
> Signed-off-by: Trevor Woerner <twoerner@gmail.com>
> ---
>  conf/machine/rock-5a.conf                     | 1 -
>  conf/machine/rock-5b.conf                     | 1 -
>  recipes-kernel/linux/linux-yocto-dev.bbappend | 4 ----
>  recipes-kernel/linux/linux-yocto_%.bbappend   | 2 ++
>  4 files changed, 2 insertions(+), 6 deletions(-)

Applied to meta-rockchip, master branch.
diff mbox series

Patch

diff --git a/conf/machine/rock-5a.conf b/conf/machine/rock-5a.conf
index 5ace4dac8fe4..1a6aa36fe649 100644
--- a/conf/machine/rock-5a.conf
+++ b/conf/machine/rock-5a.conf
@@ -5,7 +5,6 @@ 
 
 require conf/machine/include/rk3588s.inc
 
-PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
 KERNEL_DEVICETREE = "rockchip/rk3588s-rock-5a.dtb"
 MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
 
diff --git a/conf/machine/rock-5b.conf b/conf/machine/rock-5b.conf
index d1371084becc..c3a9b0afa57d 100644
--- a/conf/machine/rock-5b.conf
+++ b/conf/machine/rock-5b.conf
@@ -5,7 +5,6 @@ 
 
 require conf/machine/include/rk3588.inc
 
-PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
 KERNEL_DEVICETREE = "rockchip/rk3588-rock-5b.dtb"
 MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
 
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
index 38fbb77a0f2b..b6a63d7b7b29 100644
--- a/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,9 +1,5 @@ 
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
-COMPATIBLE_MACHINE:rock-5a = "rock-5a"
-COMPATIBLE_MACHINE:rock-5b = "rock-5b"
 COMPATIBLE_MACHINE:orangepi-5-plus = "orangepi-5-plus"
 
-SRC_URI:append:rock-5a = " file://rockchip-kmeta;type=kmeta;name=rockchip-kmeta;destsuffix=rockchip-kmeta"
-SRC_URI:append:rock-5b = " file://rockchip-kmeta;type=kmeta;name=rockchip-kmeta;destsuffix=rockchip-kmeta"
 SRC_URI:append:orangepi-5-plus = " file://rockchip-kmeta;type=kmeta;name=rockchip-kmeta;destsuffix=rockchip-kmeta"
diff --git a/recipes-kernel/linux/linux-yocto_%.bbappend b/recipes-kernel/linux/linux-yocto_%.bbappend
index 41451dfeefb1..5528bab0d17c 100644
--- a/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -20,6 +20,8 @@  COMPATIBLE_MACHINE:roc-rk3328-cc = "roc-rk3328-cc"
 COMPATIBLE_MACHINE:roc-rk3308-cc = "roc-rk3308-cc"
 COMPATIBLE_MACHINE:rock-3a = "rock-3a"
 COMPATIBLE_MACHINE:rock-4c-plus = "rock-4c-plus"
+COMPATIBLE_MACHINE:rock-5a = "rock-5a"
+COMPATIBLE_MACHINE:rock-5b = "rock-5b"
 
 SRC_URI:append = " file://rockchip-kmeta;type=kmeta;name=rockchip-kmeta;destsuffix=rockchip-kmeta"
 SRC_URI:append:nanopi-r4s = " file://nanopi-r4s.scc"