diff mbox series

python3-bcrypt: allow building native package

Message ID 20240227113023.3194930-1-andreas.muetzel@emlix.com
State New
Headers show
Series python3-bcrypt: allow building native package | expand

Commit Message

Andreas Mützel Feb. 27, 2024, 11:30 a.m. UTC
The native and nativesdk variants of this package build fine, but the
corresponding BBCLASSEXTENDS was missing. Add it.

Signed-off-by: Andreas Mützel <andreas.muetzel@emlix.com>
---
 meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Alexander Kanavin Feb. 27, 2024, 11:35 a.m. UTC | #1
What is the use case for this? Why would you want these variants? Why
not set them from .bbappend if it's something really specific to your
build?

Alex

On Tue, 27 Feb 2024 at 12:30, Andreas Mützel <andreas.muetzel@emlix.com> wrote:
>
> The native and nativesdk variants of this package build fine, but the
> corresponding BBCLASSEXTENDS was missing. Add it.
>
> Signed-off-by: Andreas Mützel <andreas.muetzel@emlix.com>
> ---
>  meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> index 8328594bad..72216c39c2 100644
> --- a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> +++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> @@ -34,3 +34,5 @@ RDEPENDS:${PN}:class-target += "\
>      python3-shell \
>      python3-six \
>  "
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.43.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#196262): https://lists.openembedded.org/g/openembedded-core/message/196262
> Mute This Topic: https://lists.openembedded.org/mt/104600694/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Andreas Mützel Feb. 27, 2024, 11:55 a.m. UTC | #2
Some context on this: This is a dependency of some python3 packages related to 
SSH and SCP in meta-openembedded, e.g. python3-paramiko. 

My use case is to package some test tools (such as the Robot Framework and its 
SSH library) into a SDK that would not only contain the tools to build an 
image, but also allow running automated tests using these tools. These tests 
would not run on the target, but run on the host and connect to the target 
(real or qemu) and then check some things.

For that, I would likely be able to contribute the relevant python3 libraries 
to meta-openembedded (python3-robotframework-sshlibrary and its dependency, 
python3-scp). But since python3-bcrypt is a dependency of that, I can't build 
the native/sdk variants without this patch.
python3-bcrypt is the only missing piece of the dependency chain that is not 
in meta-openembedded, so my idea was that it is probably better to try and 
contribute the patch here instead of sending a .bbappend to meta-oe together 
with the new recipes.

I currently have this set in a .bbappend (and would be fine with continuing to 
do so), but I thought this might be useful for other people as well. 

If you think this use case is out of scope for this layer or not worth the 
maintenance effort, I'm also fine with that :-)

Best regards,
Andreas

On Tuesday, 27 February 2024 12:30:23 CET you wrote:
> The native and nativesdk variants of this package build fine, but the
> corresponding BBCLASSEXTENDS was missing. Add it.
> 
> Signed-off-by: Andreas Mützel <andreas.muetzel@emlix.com>
> ---
>  meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb index
> 8328594bad..72216c39c2 100644
> --- a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> +++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
> @@ -34,3 +34,5 @@ RDEPENDS:${PN}:class-target += "\
>      python3-shell \
>      python3-six \
>  "
> +
> +BBCLASSEXTEND = "native nativesdk"
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
index 8328594bad..72216c39c2 100644
--- a/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
+++ b/meta/recipes-devtools/python/python3-bcrypt_4.1.2.bb
@@ -34,3 +34,5 @@  RDEPENDS:${PN}:class-target += "\
     python3-shell \
     python3-six \
 "
+
+BBCLASSEXTEND = "native nativesdk"