diff mbox series

wavemon: add recipe for version 0.9.5

Message ID 20240221132914.26748-1-romain.naour@smile.fr
State Accepted
Headers show
Series wavemon: add recipe for version 0.9.5 | expand

Commit Message

Romain Naour Feb. 21, 2024, 1:29 p.m. UTC
wavemon is an ncurses-based monitoring application for wireless network
devices on Linux.

We have to provide the path to libnl3 headers since the build system is
not able to find them.

In order to workaround a link issue with pthread library, we have to
add -pthread to CFLAGS in order to add the library after the object
file.

  arm-none-linux-gnueabihf/bin/ld: info_scr.o: undefined reference to symbol 'pthread_mutex_trylock@@GLIBC_2.4'
  [...]/wavemon/0.9.5-r0/recipe-sysroot/lib/libpthread.so.0: error adding symbols: DSO missing from command line

  "We should mention the library on the command line after the object files being compiled" [1]

[1] https://stackoverflow.com/questions/19901934/libpthread-so-0-error-adding-symbols-dso-missing-from-command-line

Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
 .../recipes-support/wavemon/wavemon_0.9.5.bb  | 28 +++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb b/meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb
new file mode 100644
index 000000000..9da43cf9f
--- /dev/null
+++ b/meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb
@@ -0,0 +1,28 @@ 
+SUMMARY = "wavemon is a wireless device monitoring application"
+HOMEPAGE = "https://github.com/uoaerg/wavemon"
+DESCRIPTION = "wavemon is a wireless device monitoring application that \
+	allows you to watch signal and noise levels, packet \
+	statistics, device configuration and network parameters of \
+	your wireless network hardware."
+
+LICENSE = "GPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+PACKAGECONFIG ??= "cap"
+PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
+
+DEPENDS = "libnl ncurses"
+
+SRC_URI = "git://github.com/uoaerg/wavemon;branch=master;protocol=https"
+SRCREV = "a7c2f190e010db508ead31fa952478e2a1c13d64"
+
+# Needs some help to find libnl3 headers.
+# Reorder -pthread flag on the command line.
+EXTRA_OEMAKE = "\
+    CC='${CC}' CFLAGS='${CFLAGS} -pthread -I${STAGING_INCDIR}/libnl3' \
+"
+
+S = "${WORKDIR}/git"
+
+# wavemon does not support using out-of-tree builds
+inherit autotools-brokensep pkgconfig