diff mbox series

[meta-python,22/26] python3-watchdog: upgrade 3.0.0 -> 4.0.0

Message ID 1708419281-26047-22-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Headers show
Series [meta-networking,01/26] unbound: upgrade 1.19.0 -> 1.19.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 20, 2024, 8:54 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Drop support for Python 3.7.
-Add support for Python 3.12.
-Add typing to dirsnapshot (#1012)
-Added DirectorySnapshotDiff.ContextManager (#1011)
-FileSystemEvent, and subclasses, are now dataclass"es, and their "repr() has changed
-WinAPINativeEvent is now a dataclass, and its repr() has changed
-Log FileOpenedEvent, and FileClosedEvent, events in LoggingEventHandler
-Improve FileSystemEvent coverage
-Log all events in LoggerTrick
-The observers.read_directory_changes.WATCHDOG_TRAVERSE_MOVED_DIR_DELAY hack was removed.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-watchdog_3.0.0.bb => python3-watchdog_4.0.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-watchdog_3.0.0.bb => python3-watchdog_4.0.0.bb} (80%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-watchdog_3.0.0.bb b/meta-python/recipes-devtools/python/python3-watchdog_4.0.0.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-watchdog_3.0.0.bb
rename to meta-python/recipes-devtools/python/python3-watchdog_4.0.0.bb
index bcd64892a..dacf4e234 100644
--- a/meta-python/recipes-devtools/python/python3-watchdog_3.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-watchdog_4.0.0.bb
@@ -4,7 +4,7 @@  DEPENDS = "${PYTHON_PN}-argh"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRC_URI[sha256sum] = "4d98a320595da7a7c5a18fc48cb633c2e73cda78f93cac2ef42d42bf609a33f9"
+SRC_URI[sha256sum] = "e3e7065cbdabe6183ab82199d7a4f6b3ba0a438c5a512a68559846ccb76a78ec"
 
 inherit pypi setuptools3