[v2,19/32] meson: inherit setuptools_build_meta

Message ID 82c32de14862300d7171690ae2568c7af386be19.1645478020.git.tim.orling@konsulko.com
State Accepted, archived
Commit 0d9bc65139a9cabbeabe166e83f2d61f47d7bdd7
Headers show
Series [v2,01/32] python3-wheel: move 0.37.0 from meta-python | expand

Commit Message

Tim Orling Feb. 21, 2022, 9:23 p.m. UTC
Upstream provides a pyproject.toml which declares setuptools.build_meta
to be backend for PEP-517 packaging.

Set PIP_INSTALL_PACKAGE as this recipe does not inherit pypi and
therefor no PYPI_PACKAGE is defined

[YOCTO #14638]

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta/recipes-devtools/meson/meson_0.61.2.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Oleksiy Obitotskyy Feb. 22, 2022, 6:55 a.m. UTC | #1
Hi,

Could you look into this build https://autobuilder.yoctoproject.org/typhoon/#/builders/97/builds/4103/steps/15/logs/stdio

Error:
 Problem: package nativesdk-packagegroup-sdk-host-1.0-r12.aarch64_nativesdk requires nativesdk-meson, but none of the providers can be installed
  - conflicting requests
  - nothing provides nativesdk-python3-pkg-resources needed by nativesdk-meson-0.61.2-r0.aarch64_nativesdk
(try to add '--skip-broken' to skip uninstallable packages)

Regards,
Oleksiy

Patch

diff --git a/meta/recipes-devtools/meson/meson_0.61.2.bb b/meta/recipes-devtools/meson/meson_0.61.2.bb
index 45938af6ffe..a51db1e3d44 100644
--- a/meta/recipes-devtools/meson/meson_0.61.2.bb
+++ b/meta/recipes-devtools/meson/meson_0.61.2.bb
@@ -21,7 +21,9 @@  SRC_URI[sha256sum] = "0233a7f8d959079318f6052b0939c27f68a5de86ba601f25c9ee6869fb
 UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
 UPSTREAM_CHECK_REGEX = "meson-(?P<pver>\d+(\.\d+)+)\.tar"
 
-inherit setuptools3
+inherit setuptools_build_meta
+
+PIP_INSTALL_PACKAGE = "meson"
 
 RDEPENDS:${PN} = "ninja python3-modules python3-pkg-resources"