diff mbox series

[3/4] python3-numpy: inherit python_mesonpy

Message ID c57f8a02b11dd08758cb9881ae82db985dbe5ee4.1708363628.git.tim.orling@konsulko.com
State New
Headers show
Series [1/4] python3-meson-python: move from meta-python | expand

Commit Message

Tim Orling Feb. 19, 2024, 5:30 p.m. UTC
Replace the deprecated setuptools3 bbclass with python_mesonpy.

The build-backend has been defined as "mesonpy" since:
https://github.com/numpy/numpy/commit/942fb8caf33a65e449fbf198ecf1cd39be953248

The vendored meson-python was dropped in:
https://github.com/numpy/numpy/commit/6544e33ac7a3a600c2fb565401c811a17ecdb3d5

While we are at it:
* Drop ${PYTHON_PN} and use python3 instead
* Sort RDEPENDS alphabetically

The ptests run, but we still have issues with sufficient memory and
free disk space (the reason python3-numpy is in PTEST_PROBLEMS).

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../python/python3-numpy_1.26.4.bb            | 54 ++++++++++---------
 1 file changed, 28 insertions(+), 26 deletions(-)

Comments

Richard Purdie Feb. 20, 2024, 11:33 a.m. UTC | #1
On Mon, 2024-02-19 at 09:30 -0800, Tim Orling wrote:
> Replace the deprecated setuptools3 bbclass with python_mesonpy.
> 
> The build-backend has been defined as "mesonpy" since:
> https://github.com/numpy/numpy/commit/942fb8caf33a65e449fbf198ecf1cd39be953248
> 
> The vendored meson-python was dropped in:
> https://github.com/numpy/numpy/commit/6544e33ac7a3a600c2fb565401c811a17ecdb3d5
> 
> While we are at it:
> * Drop ${PYTHON_PN} and use python3 instead
> * Sort RDEPENDS alphabetically
> 
> The ptests run, but we still have issues with sufficient memory and
> free disk space (the reason python3-numpy is in PTEST_PROBLEMS).
> 
> Signed-off-by: Tim Orling <tim.orling@konsulko.com>

This looks to introduce a reproducibility issue:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4399

Cheers,

Richard
Trevor Gamblin Feb. 20, 2024, 6:10 p.m. UTC | #2
On 2024-02-20 06:33, Richard Purdie wrote:
> On Mon, 2024-02-19 at 09:30 -0800, Tim Orling wrote:
>> Replace the deprecated setuptools3 bbclass with python_mesonpy.
>>
>> The build-backend has been defined as "mesonpy" since:
>> https://github.com/numpy/numpy/commit/942fb8caf33a65e449fbf198ecf1cd39be953248
>>
>> The vendored meson-python was dropped in:
>> https://github.com/numpy/numpy/commit/6544e33ac7a3a600c2fb565401c811a17ecdb3d5
>>
>> While we are at it:
>> * Drop ${PYTHON_PN} and use python3 instead
>> * Sort RDEPENDS alphabetically
>>
>> The ptests run, but we still have issues with sufficient memory and
>> free disk space (the reason python3-numpy is in PTEST_PROBLEMS).
>>
>> Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> This looks to introduce a reproducibility issue:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4399

Hi,

I've filed a bug for this: 
https://bugzilla.yoctoproject.org/show_bug.cgi?id=15406

Let's stick with the existing backend for now and I'll fix it ASAP.

Trevor

>
> Cheers,
>
> Richard
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#195913): https://lists.openembedded.org/g/openembedded-core/message/195913
> Mute This Topic: https://lists.openembedded.org/mt/104451074/7611679
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [tgamblin@baylibre.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.4.bb b/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
index d11b03efc3d..402d74db72d 100644
--- a/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
@@ -20,7 +20,7 @@  UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$"
 
 DEPENDS += "python3-cython-native"
 
-inherit ptest setuptools3 github-releases
+inherit ptest python_mesonpy github-releases
 
 S = "${WORKDIR}/numpy-${PV}"
 
@@ -33,32 +33,34 @@  do_compile:prepend() {
 FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
 
 # install what is needed for numpy.test()
-RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
-                  ${PYTHON_PN}-difflib \
-                  ${PYTHON_PN}-pprint \
-                  ${PYTHON_PN}-pickle \
-                  ${PYTHON_PN}-shell \
-                  ${PYTHON_PN}-doctest \
-                  ${PYTHON_PN}-datetime \
-                  ${PYTHON_PN}-misc \
-                  ${PYTHON_PN}-mmap \
-                  ${PYTHON_PN}-netclient \
-                  ${PYTHON_PN}-numbers \
-                  ${PYTHON_PN}-pydoc \
-                  ${PYTHON_PN}-pkgutil \
-                  ${PYTHON_PN}-email \
-                  ${PYTHON_PN}-compression \
-                  ${PYTHON_PN}-ctypes \
-                  ${PYTHON_PN}-threading \
-                  ${PYTHON_PN}-multiprocessing \
-                  ${PYTHON_PN}-json \
+RDEPENDS:${PN} = "\
+    python3-compression \
+    python3-ctypes \
+    python3-datetime \
+    python3-difflib \
+    python3-doctest \
+    python3-email \
+    python3-json \
+    python3-misc \
+    python3-mmap \
+    python3-multiprocessing \
+    python3-netclient \
+    python3-numbers \
+    python3-pickle \
+    python3-pkgutil \
+    python3-pprint \
+    python3-pydoc \
+    python3-shell \
+    python3-threading \
+    python3-unittest \
 "
-RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
-                         ${PYTHON_PN}-hypothesis \
-                         ${PYTHON_PN}-sortedcontainers \
-                         ${PYTHON_PN}-resource \
-                         ${PYTHON_PN}-typing-extensions \
-                         ldd \
+RDEPENDS:${PN}-ptest += "\
+    ldd \
+    python3-hypothesis \
+    python3-pytest \
+    python3-resource \
+    python3-sortedcontainers \
+    python3-typing-extensions \
 "
 
 BBCLASSEXTEND = "native nativesdk"