diff mbox series

[meta-python,32/60] python3-geojson: switch to pytest --automake

Message ID c62c5d8d41976ea7d876f60b1b8739ce56c123d3.1708127759.git.tim.orling@konsulko.com
State Accepted
Headers show
Series [meta-python,01/60] python3-uritemplate: switch to pytest --automake | expand

Commit Message

Tim Orling Feb. 17, 2024, 12:15 a.m. UTC
* Also replace ${PYTHON_PN} with python3

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta-python/recipes-devtools/python/python3-geojson/run-ptest | 2 +-
 meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb  | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-geojson/run-ptest b/meta-python/recipes-devtools/python/python3-geojson/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-geojson/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-geojson/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb b/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb
index 79ad228d1c..742f921e59 100644
--- a/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb
@@ -12,7 +12,8 @@  SRC_URI += " \
 "
 
 RDEPENDS:${PN}-ptest += " \
-	${PYTHON_PN}-pytest \
+    python3-pytest \
+    python3-unittest-automake-output \
 "
 
 do_install_ptest() {