diff mbox series

[meta-python,04/60] python3-pytest-lazy-fixture: switch to pytest --automake

Message ID 2f7393705c01c72f8fd8004c5a18cadcfc889ca7.1708127759.git.tim.orling@konsulko.com
State Accepted
Headers show
Series [meta-python,01/60] python3-uritemplate: switch to pytest --automake | expand

Commit Message

Tim Orling Feb. 17, 2024, 12:14 a.m. UTC
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../python/python3-pytest-lazy-fixture/run-ptest             | 2 +-
 .../python/python3-pytest-lazy-fixture_0.6.3.bb              | 5 ++++-
 2 files changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb
index 32b5677f1a..9c50528fb0 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb
@@ -20,4 +20,7 @@  do_install_ptest() {
 
 
 RDEPENDS:${PN} += "python3-core python3-pytest"
-RDEPENDS:${PN}-ptest = " python3-unixadmin"
+RDEPENDS:${PN}-ptest = " \
+    python3-unixadmin \
+    python3-unittest-automake-output \
+    "