diff mbox series

[meta-python,2/2] python3-web3: upgrade 6.15.0 -> 6.15.1

Message ID 20240207063244.42414-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python,1/2] python3-pyunormalize: add recipe | expand

Commit Message

alperak Feb. 7, 2024, 6:32 a.m. UTC
Changelog:

Bugfixes

    Handle new geth errors related to waiting for a transaction receipt while transactions are still being indexed

Improved Documentation

    Remove annual user survey prompt from docs

Internal Changes

    Create test fixture for latest geth version. Run tests with geth in --dev mode

    Formatting updates for black==24.1.0

    Add eth-tester version that supports eth_feeHistory

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-web3_6.15.0.bb             | 21 ---------------
 .../python/python3-web3_6.15.1.bb             | 26 +++++++++++++++++++
 2 files changed, 26 insertions(+), 21 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-web3_6.15.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb b/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
deleted file mode 100644
index e216857de..000000000
--- a/meta-python/recipes-devtools/python/python3-web3_6.15.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@ 
-SUMMARY = "A Python library for interacting with Ethereum."
-HOMEPAGE = "https://github.com/ethereum/web3.py"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
-
-SRC_URI[sha256sum] = "a646d1fe5eba00625b5459d23910e472f0d0aa063788422bff2648ca4e1ebc7e"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
-    python3-aiohttp \
-    python3-eth-account \
-    python3-idna \
-    python3-jsonschema \
-    python3-google-api-core \
-    python3-lru-dict \
-    python3-requests \
-    python3-setuptools \
-    python3-websockets \
-"
diff --git a/meta-python/recipes-devtools/python/python3-web3_6.15.1.bb b/meta-python/recipes-devtools/python/python3-web3_6.15.1.bb
new file mode 100644
index 000000000..00b19bb24
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_6.15.1.bb
@@ -0,0 +1,26 @@ 
+SUMMARY = "A Python library for interacting with Ethereum."
+HOMEPAGE = "https://github.com/ethereum/web3.py"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
+
+SRC_URI[sha256sum] = "f9e7eefc1b3c3d194868a4ef9583b625c18ea3f31a48ebe143183db74898f381"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-aiohttp \
+    ${PYTHON_PN}-eth-abi \
+    ${PYTHON_PN}-eth-account \
+    ${PYTHON_PN}-eth-hash \
+    ${PYTHON_PN}-eth-typing \
+    ${PYTHON_PN}-eth-utils \
+    ${PYTHON_PN}-hexbytes \
+    ${PYTHON_PN}-jsonschema \
+    ${PYTHON_PN}-protobuf \
+    ${PYTHON_PN}-pydantic \
+    ${PYTHON_PN}-requests \
+    ${PYTHON_PN}-typing-extensions \
+    ${PYTHON_PN}-websockets \
+    ${PYTHON_PN}-pyunormalize \
+"