diff mbox series

[2/2] expat: Upgrade to 2.6.0

Message ID 20240207060239.2202928-2-raj.khem@gmail.com
State Accepted, archived
Commit 0f5a64aecec9d50b50e2ca70bb1a7e4b680bc4ce
Headers show
Series [1/2] ptest.bbclass: Handle the case when Makefile does not exist in do_install_ptest_base | expand

Commit Message

Khem Raj Feb. 7, 2024, 6:02 a.m. UTC
Package and run benchmark as part of ptest
This is a major release with following changes [1]

[1] https://github.com/libexpat/libexpat/blob/R_2_6_0/expat/Changes

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/expat/expat/run-ptest                    | 2 +-
 meta/recipes-core/expat/{expat_2.5.0.bb => expat_2.6.0.bb} | 5 +++--
 2 files changed, 4 insertions(+), 3 deletions(-)
 rename meta/recipes-core/expat/{expat_2.5.0.bb => expat_2.6.0.bb} (82%)

Comments

Khem Raj Feb. 7, 2024, 7:59 p.m. UTC | #1
This will cause a cython ptest regression as reported here

https://github.com/python/cpython/issues/115133

There is a patch proposed for cython and in progress, we can hold on
to this patch for the moment.

On Tue, Feb 6, 2024 at 10:02 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> Package and run benchmark as part of ptest
> This is a major release with following changes [1]
>
> [1] https://github.com/libexpat/libexpat/blob/R_2_6_0/expat/Changes
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-core/expat/expat/run-ptest                    | 2 +-
>  meta/recipes-core/expat/{expat_2.5.0.bb => expat_2.6.0.bb} | 5 +++--
>  2 files changed, 4 insertions(+), 3 deletions(-)
>  rename meta/recipes-core/expat/{expat_2.5.0.bb => expat_2.6.0.bb} (82%)
>
> diff --git a/meta/recipes-core/expat/expat/run-ptest b/meta/recipes-core/expat/expat/run-ptest
> index dbf602ca800..ff7986db3cf 100644
> --- a/meta/recipes-core/expat/expat/run-ptest
> +++ b/meta/recipes-core/expat/expat/run-ptest
> @@ -5,5 +5,5 @@ TIME=$(which time)
>  echo "runtests"
>  ${TIME} -f 'Execution time: %e s' bash -c "./runtests -v"
>  echo "runtestspp"
> -${TIME} -f 'Execution time: %e s' bash -c "./runtestspp -v"
> +${TIME} -f 'Execution time: %e s' bash -c "./runtests_cxx -v"
>  echo
> diff --git a/meta/recipes-core/expat/expat_2.5.0.bb b/meta/recipes-core/expat/expat_2.6.0.bb
> similarity index 82%
> rename from meta/recipes-core/expat/expat_2.5.0.bb
> rename to meta/recipes-core/expat/expat_2.6.0.bb
> index aa8d439d5fb..1f9f7b269a4 100644
> --- a/meta/recipes-core/expat/expat_2.5.0.bb
> +++ b/meta/recipes-core/expat/expat_2.6.0.bb
> @@ -15,7 +15,7 @@ SRC_URI = "${GITHUB_BASE_URI}/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2  \
>  GITHUB_BASE_URI = "https://github.com/libexpat/libexpat/releases/"
>  UPSTREAM_CHECK_REGEX = "releases/tag/R_(?P<pver>.+)"
>
> -SRC_URI[sha256sum] = "6f0e6e01f7b30025fa05c85fdad1e5d0ec7fd35d9f61b22f34998de11969ff67"
> +SRC_URI[sha256sum] = "ff60e6a6b6ce570ae012dc7b73169c7fdf4b6bf08c12ed0ec6f55736b78d85ba"
>
>  EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
>
> @@ -24,7 +24,8 @@ RDEPENDS:${PN}-ptest += "bash"
>  inherit cmake lib_package ptest github-releases
>
>  do_install_ptest:class-target() {
> -       install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
> +       install -m 755 ${B}/tests/runtests* ${D}${PTEST_PATH}
> +       install -m 755 ${B}/tests/benchmark/benchmark ${D}${PTEST_PATH}
>  }
>
>  BBCLASSEXTEND += "native nativesdk"
> --
> 2.43.0
>
diff mbox series

Patch

diff --git a/meta/recipes-core/expat/expat/run-ptest b/meta/recipes-core/expat/expat/run-ptest
index dbf602ca800..ff7986db3cf 100644
--- a/meta/recipes-core/expat/expat/run-ptest
+++ b/meta/recipes-core/expat/expat/run-ptest
@@ -5,5 +5,5 @@  TIME=$(which time)
 echo "runtests"
 ${TIME} -f 'Execution time: %e s' bash -c "./runtests -v"
 echo "runtestspp"
-${TIME} -f 'Execution time: %e s' bash -c "./runtestspp -v"
+${TIME} -f 'Execution time: %e s' bash -c "./runtests_cxx -v"
 echo
diff --git a/meta/recipes-core/expat/expat_2.5.0.bb b/meta/recipes-core/expat/expat_2.6.0.bb
similarity index 82%
rename from meta/recipes-core/expat/expat_2.5.0.bb
rename to meta/recipes-core/expat/expat_2.6.0.bb
index aa8d439d5fb..1f9f7b269a4 100644
--- a/meta/recipes-core/expat/expat_2.5.0.bb
+++ b/meta/recipes-core/expat/expat_2.6.0.bb
@@ -15,7 +15,7 @@  SRC_URI = "${GITHUB_BASE_URI}/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2  \
 GITHUB_BASE_URI = "https://github.com/libexpat/libexpat/releases/"
 UPSTREAM_CHECK_REGEX = "releases/tag/R_(?P<pver>.+)"
 
-SRC_URI[sha256sum] = "6f0e6e01f7b30025fa05c85fdad1e5d0ec7fd35d9f61b22f34998de11969ff67"
+SRC_URI[sha256sum] = "ff60e6a6b6ce570ae012dc7b73169c7fdf4b6bf08c12ed0ec6f55736b78d85ba"
 
 EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
 
@@ -24,7 +24,8 @@  RDEPENDS:${PN}-ptest += "bash"
 inherit cmake lib_package ptest github-releases
 
 do_install_ptest:class-target() {
-	install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
+	install -m 755 ${B}/tests/runtests* ${D}${PTEST_PATH}
+	install -m 755 ${B}/tests/benchmark/benchmark ${D}${PTEST_PATH}
 }
 
 BBCLASSEXTEND += "native nativesdk"