diff mbox series

[meta-arago,kirkstone] recipes-devtools: mtd-utils: Switch to infraroot.at for https over git protocol

Message ID 20240129095834.77985-1-c-shilwant@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,kirkstone] recipes-devtools: mtd-utils: Switch to infraroot.at for https over git protocol | expand

Commit Message

Chirag Shilwant Jan. 29, 2024, 9:58 a.m. UTC
- In past, there have been issues in do_fetch from infradead.org over git protocol in proxy based network [1].

- As per the latest release announcement from mtd-utils, infraroot.at is the official mirror for infradead.org [2].

- Since infradead.org has fetch failures over git, start using infraroot.at over https in SRC_URI.

Reference
---------
[1] https://e2e.ti.com/support/processors-group/processors/f/processors-forum/962170/processor-sdk-am65x-how-to-resolve-the-fetch-error-that-occurs-when-executing-bitbake
[2] https://lists.infradead.org/pipermail/linux-mtd/2023-August/100922.html

Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
---
 .../recipes-devtools/mtd/mtd-utils_git.bbappend           | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Randolph Sapp Feb. 5, 2024, 10:38 p.m. UTC | #1
On 1/29/24 03:58, Chirag Shilwant via lists.yoctoproject.org wrote:
> - In past, there have been issues in do_fetch from infradead.org over git protocol in proxy based network [1].
> 
> - As per the latest release announcement from mtd-utils, infraroot.at is the official mirror for infradead.org [2].
> 
> - Since infradead.org has fetch failures over git, start using infraroot.at over https in SRC_URI.
> 
> Reference
> ---------
> [1] https://e2e.ti.com/support/processors-group/processors/f/processors-forum/962170/processor-sdk-am65x-how-to-resolve-the-fetch-error-that-occurs-when-executing-bitbake
> [2] https://lists.infradead.org/pipermail/linux-mtd/2023-August/100922.html
> 
> Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
> ---
>   .../recipes-devtools/mtd/mtd-utils_git.bbappend           | 8 +++++++-
>   1 file changed, 7 insertions(+), 1 deletion(-)
> 
> diff --git a/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend b/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
> index aec6a1ac..341d0600 100644
> --- a/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
> +++ b/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
> @@ -1,4 +1,10 @@
> -PR:append = ".arago1"
> +PR:append = ".arago2"
> +
> +SRC_URI:remove = "git://git.infradead.org/mtd-utils.git;branch=master \
> +"
> +
> +SRC_URI:prepend = "git://git.infraroot.at/mtd-utils.git;branch=master;protocol=https \
> +"
>   
>   BBCLASSEXTEND += "nativesdk"
>   

This could be simplified as just:
MIRRORS += "git://git.infradead.org/.* 
git://git.infraroot.at/PATH;protocol=https"

Which could be upstreamable since I imagine this has been hitting a few 
people and oe-core already has a few packages that update the MIRROR var.
Randolph Sapp Feb. 5, 2024, 11:04 p.m. UTC | #2
On 2/5/24 16:38, Randolph Sapp via lists.yoctoproject.org wrote:
> On 1/29/24 03:58, Chirag Shilwant via lists.yoctoproject.org wrote:
>> - In past, there have been issues in do_fetch from infradead.org over 
>> git protocol in proxy based network [1].
>>
>> - As per the latest release announcement from mtd-utils, infraroot.at 
>> is the official mirror for infradead.org [2].
>>
>> - Since infradead.org has fetch failures over git, start using 
>> infraroot.at over https in SRC_URI.
>>
>> Reference
>> ---------
>> [1] 
>> https://e2e.ti.com/support/processors-group/processors/f/processors-forum/962170/processor-sdk-am65x-how-to-resolve-the-fetch-error-that-occurs-when-executing-bitbake
>> [2] 
>> https://lists.infradead.org/pipermail/linux-mtd/2023-August/100922.html
>>
>> Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
>> ---
>>   .../recipes-devtools/mtd/mtd-utils_git.bbappend           | 8 +++++++-
>>   1 file changed, 7 insertions(+), 1 deletion(-)
>>
>> diff --git 
>> a/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend 
>> b/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
>> index aec6a1ac..341d0600 100644
>> --- a/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
>> +++ b/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
>> @@ -1,4 +1,10 @@
>> -PR:append = ".arago1"
>> +PR:append = ".arago2"
>> +
>> +SRC_URI:remove = "git://git.infradead.org/mtd-utils.git;branch=master \
>> +"
>> +
>> +SRC_URI:prepend = 
>> "git://git.infraroot.at/mtd-utils.git;branch=master;protocol=https \
>> +"
>>   BBCLASSEXTEND += "nativesdk"
> 
> This could be simplified as just:
> MIRRORS += "git://git.infradead.org/.* 
> git://git.infraroot.at/PATH;protocol=https"
> 
> Which could be upstreamable since I imagine this has been hitting a few 
> people and oe-core already has a few packages that update the MIRROR var.
> 

Actually, it could be even shorter:
MIRRORS += "git://git.infradead.org/.* git://git.infraroot.at/PATH"

As the git fetcher has built in fail-over logic that will catch https if 
the git protocol fails anyway.
diff mbox series

Patch

diff --git a/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend b/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
index aec6a1ac..341d0600 100644
--- a/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
+++ b/meta-arago-test/recipes-devtools/mtd/mtd-utils_git.bbappend
@@ -1,4 +1,10 @@ 
-PR:append = ".arago1"
+PR:append = ".arago2"
+
+SRC_URI:remove = "git://git.infradead.org/mtd-utils.git;branch=master \
+"
+
+SRC_URI:prepend = "git://git.infraroot.at/mtd-utils.git;branch=master;protocol=https \
+"
 
 BBCLASSEXTEND += "nativesdk"