diff mbox series

[meta-networking,kirkstone] radvd: add '--shell /sbin/nologin' to /etc/passwd

Message ID 20240129062328.1689458-1-li.wang@windriver.com
State New
Headers show
Series [meta-networking,kirkstone] radvd: add '--shell /sbin/nologin' to /etc/passwd | expand

Commit Message

Li Wang Jan. 29, 2024, 6:23 a.m. UTC
the default setting USERADD_PARAM of yocto:
-s /bin/sh

follow redhat policy:
radvd/redhat/systemd/radvd.spec
  useradd ... -s /sbin/nologin ...

Signed-off-by: Li Wang <li.wang@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-networking/recipes-daemons/radvd/radvd.inc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yoann Congal Jan. 29, 2024, 8:07 a.m. UTC | #1
Hi,

Le 29/01/2024 à 07:23, Li Wang via lists.openembedded.org a écrit :
> the default setting USERADD_PARAM of yocto:
> -s /bin/sh
> 
> follow redhat policy:
> radvd/redhat/systemd/radvd.spec
>   useradd ... -s /sbin/nologin ...
> 
> Signed-off-by: Li Wang <li.wang@windriver.com>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>

Can this fix this error from autobuilder by any chance?
  stdio: ERROR: radvd-2.19-r0 do_prepare_recipe_sysroot: radvd: useradd command did not succeed.
  stdio: ERROR: radvd-2.19-r0 do_prepare_recipe_sysroot: ExecutionError('/home/pokybuild/yocto-worker/reproducible-meta-oe/build/build/build-st-meta-networking/build-st/reproducibleA/tmp/work/core2-64-poky-linux/radvd/2.19/temp/run.useradd_sysroot.818430', 1, None, None)

Link : https://autobuilder.yoctoproject.org/typhoon/#/builders/155/builds/9/steps/29/logs/errors

Thanks!

> ---
>  meta-networking/recipes-daemons/radvd/radvd.inc | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta-networking/recipes-daemons/radvd/radvd.inc b/meta-networking/recipes-daemons/radvd/radvd.inc
> index 219d88f49..5da31b3f0 100644
> --- a/meta-networking/recipes-daemons/radvd/radvd.inc
> +++ b/meta-networking/recipes-daemons/radvd/radvd.inc
> @@ -59,7 +59,7 @@ do_install:append () {
>  
>  USERADD_PACKAGES = "${PN}"
>  GROUPADD_PARAM:${PN} = "--system nogroup"
> -USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup radvd"
> +USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup --shell /sbin/nologin radvd"
>  
>  pkg_postinst:${PN} () {
>      if [ -z "$D" -a -x /etc/init.d/populate-volatile.sh ]; then
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108480): https://lists.openembedded.org/g/openembedded-devel/message/108480
> Mute This Topic: https://lists.openembedded.org/mt/104026959/4316185
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [yoann.congal@smile.fr]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Yoann Congal Feb. 8, 2024, 11:18 a.m. UTC | #2
Le lun. 29 janv. 2024 à 09:07, Yoann Congal <yoann.congal@smile.fr> a
écrit :

> Hi,
>
> Le 29/01/2024 à 07:23, Li Wang via lists.openembedded.org a écrit :
> > the default setting USERADD_PARAM of yocto:
> > -s /bin/sh
> >
> > follow redhat policy:
> > radvd/redhat/systemd/radvd.spec
> >   useradd ... -s /sbin/nologin ...
> >
> > Signed-off-by: Li Wang <li.wang@windriver.com>
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
>
> Can this fix this error from autobuilder by any chance?
>   stdio: ERROR: radvd-2.19-r0 do_prepare_recipe_sysroot: radvd: useradd
> command did not succeed.
>   stdio: ERROR: radvd-2.19-r0 do_prepare_recipe_sysroot:
> ExecutionError('/home/pokybuild/yocto-worker/reproducible-meta-oe/build/build/build-st-meta-networking/build-st/reproducibleA/tmp/work/core2-64-poky-linux/radvd/2.19/temp/run.useradd_sysroot.818430',
> 1, None, None)
>
> Link :
> https://autobuilder.yoctoproject.org/typhoon/#/builders/155/builds/9/steps/29/logs/errors


FWIW, this was an unrelated problem for which I've sent a patch:
[meta-networking][PATCH] radvd: Fix build in reproducible test
https://lists.openembedded.org/g/openembedded-devel/message/108662

Regards,


>
> Thanks!
>
> > ---
> >  meta-networking/recipes-daemons/radvd/radvd.inc | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta-networking/recipes-daemons/radvd/radvd.inc
> b/meta-networking/recipes-daemons/radvd/radvd.inc
> > index 219d88f49..5da31b3f0 100644
> > --- a/meta-networking/recipes-daemons/radvd/radvd.inc
> > +++ b/meta-networking/recipes-daemons/radvd/radvd.inc
> > @@ -59,7 +59,7 @@ do_install:append () {
> >
> >  USERADD_PACKAGES = "${PN}"
> >  GROUPADD_PARAM:${PN} = "--system nogroup"
> > -USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M
> -g nogroup radvd"
> > +USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M
> -g nogroup --shell /sbin/nologin radvd"
> >
> >  pkg_postinst:${PN} () {
> >      if [ -z "$D" -a -x /etc/init.d/populate-volatile.sh ]; then
> >
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#108480):
> https://lists.openembedded.org/g/openembedded-devel/message/108480
> > Mute This Topic: https://lists.openembedded.org/mt/104026959/4316185
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> yoann.congal@smile.fr]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
> --
> Yoann Congal
> Smile ECS - Tech Expert
>
diff mbox series

Patch

diff --git a/meta-networking/recipes-daemons/radvd/radvd.inc b/meta-networking/recipes-daemons/radvd/radvd.inc
index 219d88f49..5da31b3f0 100644
--- a/meta-networking/recipes-daemons/radvd/radvd.inc
+++ b/meta-networking/recipes-daemons/radvd/radvd.inc
@@ -59,7 +59,7 @@  do_install:append () {
 
 USERADD_PACKAGES = "${PN}"
 GROUPADD_PARAM:${PN} = "--system nogroup"
-USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup radvd"
+USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup --shell /sbin/nologin radvd"
 
 pkg_postinst:${PN} () {
     if [ -z "$D" -a -x /etc/init.d/populate-volatile.sh ]; then