diff mbox series

[meta-ti,kirkstone/master] mesa-pvr: bump srcrev and drop conditional logic

Message ID 20240126190416.1368711-1-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,kirkstone/master] mesa-pvr: bump srcrev and drop conditional logic | expand

Commit Message

Randolph Sapp Jan. 26, 2024, 7:04 p.m. UTC
From: Randolph Sapp <rs@ti.com>

Bump the SRCREV to include some useful patches that:
	- Fix the ROGUE segfault issue introduced by SGX (this was what
	  the old conditional logic was addressing)
	- Fix destruction of event queue with proxies still attached

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

Comments

Etheridge, Darren Feb. 1, 2024, 10:34 p.m. UTC | #1
On 1/26/2024 1:04 PM, rs@ti.com wrote:
> From: Randolph Sapp <rs@ti.com>
> 
> Bump the SRCREV to include some useful patches that:
> 	- Fix the ROGUE segfault issue introduced by SGX (this was what
> 	  the old conditional logic was addressing)
> 	- Fix destruction of event queue with proxies still attached
> 
Working great with Chromium v111 that we are targeting - I tested on 
AM62P  (BXS-4-64 GPU)

Tested-by: Darren Etheridge <detheridge@ti.com>

> Signed-off-by: Randolph Sapp <rs@ti.com>
> ---
>   meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb | 6 +-----
>   1 file changed, 1 insertion(+), 5 deletions(-)
> 
> diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
> index 554fadd3..5abd0793 100644
> --- a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
> +++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
> @@ -28,11 +28,7 @@ PACKAGECONFIG:append = " \
>       ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \
>   "
>   
> -# Temporary work around to use a different SRCREV for SGX Mesa, vs Rogue Mesa
> -# Idea is these two should be the same, but currently a segfault is happening
> -# on certain platforms if the sgx commit is used.
> -SRCREV = "${@bb.utils.contains('PACKAGECONFIG', 'sgx', '7c9522a4147836064f582278e4f7115735c16868', '54fd9d7dea098b6f11c2a244b0c6763dc8c5690c', d)}"
> -PR = "sgxrgx${SRCPV}"
> +SRCREV = "1be98ba80452ebe38546a7fca26b5a70f2629083"
>   
>   PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss"
>   PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
index 554fadd3..5abd0793 100644
--- a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
+++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
@@ -28,11 +28,7 @@  PACKAGECONFIG:append = " \
     ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \
 "
 
-# Temporary work around to use a different SRCREV for SGX Mesa, vs Rogue Mesa
-# Idea is these two should be the same, but currently a segfault is happening
-# on certain platforms if the sgx commit is used.
-SRCREV = "${@bb.utils.contains('PACKAGECONFIG', 'sgx', '7c9522a4147836064f582278e4f7115735c16868', '54fd9d7dea098b6f11c2a244b0c6763dc8c5690c', d)}"
-PR = "sgxrgx${SRCPV}"
+SRCREV = "1be98ba80452ebe38546a7fca26b5a70f2629083"
 
 PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss"
 PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"