diff mbox series

[meta-arago,master/kirkstone] tisdk-*-image: Fix SYSTEMD_DEFAULT_TARGET assignment

Message ID 20240125165838.5539-1-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone] tisdk-*-image: Fix SYSTEMD_DEFAULT_TARGET assignment | expand

Commit Message

Ryan Eatmon Jan. 25, 2024, 4:58 p.m. UTC
The use of the variable SYSTEMD_DEFAULT_TARGET is as a filename target.
But the extra whitespace in the string caused by the link breaks and
indents added spaces between the directory and the filename which
resulted in the following error:

run.set_systemd_default_target.23991: line 147: [: too many arguments

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 meta-arago-distro/recipes-core/images/tisdk-default-image.bb  | 4 +---
 .../recipes-core/images/tisdk-thinlinux-image.bb              | 4 +---
 2 files changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
index 33ed0f57..7761ac34 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
@@ -8,9 +8,7 @@  require arago-image.inc
 ARAGO_DEFAULT_IMAGE_EXTRA_INSTALL ?= ""
 
 # we're assuming some display manager is being installed with opengl
-SYSTEMD_DEFAULT_TARGET = " \
-    ${@bb.utils.contains('DISTRO_FEATURES','opengl','graphical.target','multi-user.target',d)} \
-"
+SYSTEMD_DEFAULT_TARGET = "${@bb.utils.contains('DISTRO_FEATURES','opengl','graphical.target','multi-user.target',d)}"
 
 IMAGE_INSTALL += "\
     packagegroup-arago-base \
diff --git a/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb b/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
index f266b14a..13e86902 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-thinlinux-image.bb
@@ -9,9 +9,7 @@  require arago-image.inc
 ARAGO_THIN_IMAGE_EXTRA_INSTALL ?= ""
 
 # we're assuming some display manager is being installed with opengl
-SYSTEMD_DEFAULT_TARGET = " \
-    ${@bb.utils.contains('DISTRO_FEATURES','opengl','graphical.target','multi-user.target',d)} \
-"
+SYSTEMD_DEFAULT_TARGET = "${@bb.utils.contains('DISTRO_FEATURES','opengl','graphical.target','multi-user.target',d)}"
 
 IMAGE_INSTALL += "\
     packagegroup-arago-base \