diff mbox series

[1/3] pkgconfig: Correct the PV

Message ID 20240125092554.3657475-1-mingli.yu@windriver.com
State Rejected, archived
Headers show
Series [1/3] pkgconfig: Correct the PV | expand

Commit Message

Yu, Mingli Jan. 25, 2024, 9:25 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Correct the PV to make the version consistent.

Before the patch:
 # rpm -qa | grep pkgconfig
 pkgconfig-0.29.2+git0+d97db4fae4-r0.core2_64
 # rpm -ql pkgconfig
 /usr
 /usr/bin
 /usr/bin/pkg-config
 /usr/bin/x86_64-wrs-linux-gnu-pkg-config
 /usr/share
 /usr/share/aclocal
 /usr/share/aclocal/pkg.m4
 # pkg-config --version
 0.29.2

After the patch:
 # rpm -qa | grep pkgconfig
 pkgconfig-0.29.2-r0.core2_64
 # rpm -ql pkgconfig
 /usr
 /usr/bin
 /usr/bin/pkg-config
 /usr/bin/x86_64-wrs-linux-gnu-pkg-config
 /usr/share
 /usr/share/aclocal
 /usr/share/aclocal/pkg.m4
 # pkg-config --version
 0.29.2

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/recipes-devtools/pkgconfig/pkgconfig_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexander Kanavin Jan. 25, 2024, 9:29 a.m. UTC | #1
On Thu, 25 Jan 2024 at 10:25, Yu, Mingli <mingli.yu@eng.windriver.com> wrote:
>
> From: Mingli Yu <mingli.yu@windriver.com>
>
> Correct the PV to make the version consistent.
>  SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2"
> -PV = "0.29.2+git"
> +PV = "0.29.2"

0.29.2 release tag maps to a different commit, so we cannot drop +git:
https://gitlab.freedesktop.org/pkg-config/pkg-config/-/tags/pkg-config-0.29.2

It helps if you explain the broader goal. Why does version as reported
by rpm need to match version as reported by component exactly? Can't
you strip all the suffixes from what rpm says?

Alex
Yu, Mingli Jan. 26, 2024, 8 a.m. UTC | #2
On 1/25/24 17:29, Alexander Kanavin wrote:
> CAUTION: This email comes from a non Wind River email account!
> Do not click links or open attachments unless you recognize the sender and know the content is safe.
> 
> On Thu, 25 Jan 2024 at 10:25, Yu, Mingli <mingli.yu@eng.windriver.com> wrote:
>>
>> From: Mingli Yu <mingli.yu@windriver.com>
>>
>> Correct the PV to make the version consistent.
>>   SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2"
>> -PV = "0.29.2+git"
>> +PV = "0.29.2"
> 
> 0.29.2 release tag maps to a different commit, so we cannot drop +git:
> https://gitlab.freedesktop.org/pkg-config/pkg-config/-/tags/pkg-config-0.29.2

Thanks Alex to pointing out! The commit [1] did make to update pkgconfig 
to a non-release version.

[1] 
https://git.openembedded.org/openembedded-core/commit/?id=fd621eefee1a4acaffa3754b76f8e14d2684ab3f

> 
> It helps if you explain the broader goal. Why does version as reported
> by rpm need to match version as reported by component exactly? Can't
> you strip all the suffixes from what rpm says?

For some reasons, the user complains the version which rpm says is not 
consistent with the version which reported by some binary as below 
though no function impacts. So we try to fix the gap.

  # rpm -qa | grep pkgconfig
  pkgconfig-0.29.2+git0+d97db4fae4-r0.core2_64

  # rpm -ql pkgconfig
  /usr
  /usr/bin
  /usr/bin/pkg-config
  /usr/bin/x86_64-wrs-linux-gnu-pkg-config
  /usr/share
  /usr/share/aclocal
  /usr/share/aclocal/pkg.m4
  # pkg-config --version
  0.29.2

Thanks,

> 
> Alex
diff mbox series

Patch

diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb b/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
index 16e6c5b609..53d2335317 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
@@ -9,7 +9,7 @@  LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2"
-PV = "0.29.2+git"
+PV = "0.29.2"
 
 SRC_URI = "git://gitlab.freedesktop.org/pkg-config/pkg-config.git;branch=master;protocol=https \
            file://pkg-config-esdk.in \