diff mbox series

[meta-python] python3-django: upgrade 5.0 -> 5.0.1

Message ID 1705974116-25699-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-django: upgrade 5.0 -> 5.0.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 23, 2024, 1:41 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Reallowed, following a regression in Django 5.0, using a foreign key to a model
 with a primary key that is not AutoField in ModelAdmin.list_filter
-Fixed a long standing bug in handling the RETURNING INTO clause that caused a
 crash when creating a model instance with a GeneratedField which output_field
 had backend-specific converters
-Fixed a regression in Django 5.0 that caused a crash of Model.save() for models
 with both GeneratedField and ForeignKey fields
-Fixed a bug in Django 5.0 that caused a migration crash on Oracle < 23c when
 adding a GeneratedField with output_field=BooleanField
-Fixed a regression in Django 5.0 where admin fields on the same line could
 overflow the page and become non-interactive
-Added compatibility for oracledb 2.0.0
-Fixed a regression in Django 5.0 where querysets referenced incorrect field
 names from FilteredRelation()
-Fixed a regression in Django 5.0 that caused a system check crash when
 ModelAdmin.filter_horizontal or filter_vertical contained a reverse
 many-to-many relation with related_name

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-django_5.0.bb => python3-django_5.0.1.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-django_5.0.bb => python3-django_5.0.1.bb} (58%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_5.0.bb b/meta-python/recipes-devtools/python/python3-django_5.0.1.bb
similarity index 58%
rename from meta-python/recipes-devtools/python/python3-django_5.0.bb
rename to meta-python/recipes-devtools/python/python3-django_5.0.1.bb
index bad424523..eed1e6edc 100644
--- a/meta-python/recipes-devtools/python/python3-django_5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-django_5.0.1.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "7d29e14dfbc19cb6a95a4bd669edbde11f5d4c6a71fdaa42c2d40b6846e807f7"
+SRC_URI[sha256sum] = "8c8659665bc6e3a44fefe1ab0a291e5a3fb3979f9a8230be29de975e57e8f854"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-sqlparse \