diff mbox series

[meta-webserver,1/2] cockpit-machines: add recipe

Message ID 20240117113911.15322-2-paul.leguendekerneizon@savoirfairelinux.com
State Changes Requested
Headers show
Series add support of cockpit-machines | expand

Commit Message

Paul Le Guen de Kerneizon Jan. 17, 2024, 11:39 a.m. UTC
`cockpit-machines` is a Cockpit plugin used to provide a web interface
to manage virtual machines. Since Cockpit version 242, cockpit-machines
has been moved to a dedicated repository.

Signed-off-by: Paul Le Guen de Kerneizon <paul.leguendekerneizon@savoirfairelinux.com>
---
 .../cockpit-machines/cockpit-machines_304.bb  | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb

Comments

Khem Raj Jan. 18, 2024, 3:36 p.m. UTC | #1
this needs to match the constraints on cockpit recipe or we get these errors

https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/3532/steps/12/logs/stdio

you might need to add

    REQUIRED_DISTRO_FEATURES = "systemd pam"

    COMPATIBLE_HOST:libc-musl = "null"

On Wed, Jan 17, 2024 at 4:13 AM Paul Le Guen de Kerneizon
<paul.leguendekerneizon@savoirfairelinux.com> wrote:
>
> `cockpit-machines` is a Cockpit plugin used to provide a web interface
> to manage virtual machines. Since Cockpit version 242, cockpit-machines
> has been moved to a dedicated repository.
>
> Signed-off-by: Paul Le Guen de Kerneizon <paul.leguendekerneizon@savoirfairelinux.com>
> ---
>  .../cockpit-machines/cockpit-machines_304.bb  | 22 +++++++++++++++++++
>  1 file changed, 22 insertions(+)
>  create mode 100644 meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb
>
> diff --git a/meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb b/meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb
> new file mode 100644
> index 000000000..b787a5cf6
> --- /dev/null
> +++ b/meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb
> @@ -0,0 +1,22 @@
> +SUMMARY = "Cockpit UI for virtual machines"
> +DESCRIPTION = "Cockpit-machines provides a user interface to manage virtual machines"
> +LICENSE = "LGPL-2.1-only"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
> +DEPENDS += "cockpit"
> +
> +SRC_URI = "https://github.com/cockpit-project/cockpit-machines/releases/download/${PV}/cockpit-machines-${PV}.tar.xz"
> +SRC_URI[sha256sum] = "b9b41d728d68ae9d21c229765e00793ad018231903c84ed653c21d25444714e3"
> +
> +S = "${WORKDIR}/${PN}"
> +
> +inherit autotools-brokensep gettext
> +
> +RDEPENDS:${PN} += "cockpit libvirt-dbus pciutils virt-install"
> +
> +# Default installation path of cockpit-machines is /usr/local/
> +FILES:${PN} = "\
> +    ${prefix}/local/ \
> +    ${datadir}/metainfo/org.cockpit-project.cockpit-machines.metainfo.xml \
> +"
> +
> +BUGTRACKER = "github.com/cockpit-project/cockpit-machines/issues"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108327): https://lists.openembedded.org/g/openembedded-devel/message/108327
> Mute This Topic: https://lists.openembedded.org/mt/103784069/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb b/meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb
new file mode 100644
index 000000000..b787a5cf6
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/cockpit-machines/cockpit-machines_304.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "Cockpit UI for virtual machines"
+DESCRIPTION = "Cockpit-machines provides a user interface to manage virtual machines"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+DEPENDS += "cockpit"
+
+SRC_URI = "https://github.com/cockpit-project/cockpit-machines/releases/download/${PV}/cockpit-machines-${PV}.tar.xz"
+SRC_URI[sha256sum] = "b9b41d728d68ae9d21c229765e00793ad018231903c84ed653c21d25444714e3"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools-brokensep gettext
+
+RDEPENDS:${PN} += "cockpit libvirt-dbus pciutils virt-install"
+
+# Default installation path of cockpit-machines is /usr/local/
+FILES:${PN} = "\
+    ${prefix}/local/ \
+    ${datadir}/metainfo/org.cockpit-project.cockpit-machines.metainfo.xml \
+"
+
+BUGTRACKER = "github.com/cockpit-project/cockpit-machines/issues"