diff mbox series

[2/2] python3-kivy: update 2.2.1 -> 2.3.0

Message ID 20240105133611.3018041-2-alex@linutronix.de
State Accepted
Headers show
Series [1/2] python3-h5py: backport a cython 3.x compatibility patch | expand

Commit Message

Alexander Kanavin Jan. 5, 2024, 1:36 p.m. UTC
License-Update: years, mention that it is MIT at the start.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} (93%)

Comments

Khem Raj Jan. 9, 2024, 3:32 a.m. UTC | #1
this fails to build here ( maybe its clang finding additional problems )

https://sprunge.us/lq5PKS

On Fri, Jan 5, 2024 at 5:36 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
>
> License-Update: years, mention that it is MIT at the start.
>
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  .../python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>  rename meta-python/recipes-devtools/python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} (93%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> similarity index 93%
> rename from meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> rename to meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> index a72ee14f6..0d4a1207f 100644
> --- a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> @@ -2,7 +2,7 @@ SUMMARY = "Open source Python library for rapid development of applications \
>      that make use of innovative user interfaces, such as multi-touch apps."
>  HOMEPAGE = "https://kivy.org/"
>  LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=ed5cd0f2cfda42852c332e3b88c85fea"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
>
>  inherit setuptools3 pkgconfig features_check
>  PIP_INSTALL_PACKAGE = "Kivy"
> @@ -11,11 +11,11 @@ PIP_INSTALL_PACKAGE = "Kivy"
>  # and mali-based OS's. We need to patch the setup file to tell Kivy setup
>  # that our machine has GLES libaries installed as well
>  # Also, if using SDL2 as backend, SDL2 needs to be configured with gles
> -SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=stable \
> +SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=master \
>             file://0001-add-support-for-glesv2.patch \
>             "
>
> -SRCREV = "344768bfefd2e8f5302cc9dfb8ca41991ce6f7e7"
> +SRCREV = "9ef218027178115a66b417ae34b21f488bdd3617"
>
>  S = "${WORKDIR}/git"
>
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108048): https://lists.openembedded.org/g/openembedded-devel/message/108048
> Mute This Topic: https://lists.openembedded.org/mt/103542151/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Jan. 9, 2024, 9:08 a.m. UTC | #2
I think it's clang, so needs to be added to conf/nonclangable.conf?

/mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux-musl/python3-kivy/2.3.0/git/kivy/graphics/cgl_backend/cgl_gl.c:4549:52:
error: incompatible function pointer types assigning to 'void
(*)(GLuint, GLsizei, const GLchar **, const GLint *)' (aka 'void
(*)(unsigned int, int, const char **, const int *)') from 'void
(GLuint, GLsizei, const GLchar *const *, const GLint *)' (aka 'void
(unsigned int, int, const char *const *, const int *)')
[-Wincompatible-function-pointer-types]
 4549 |   __pyx_v_4kivy_8graphics_3cgl_cgl->glShaderSource = glShaderSource;
      |                                                    ^ ~~~~~~~~~~~~~~

Note that this update is needed for both cython 3.x and python 3.12
compatibility.

Alex

On Tue, 9 Jan 2024 at 04:32, Khem Raj <raj.khem@gmail.com> wrote:
>
> this fails to build here ( maybe its clang finding additional problems )
>
> https://sprunge.us/lq5PKS
>
> On Fri, Jan 5, 2024 at 5:36 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> >
> > License-Update: years, mention that it is MIT at the start.
> >
> > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > ---
> >  .../python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
> >  rename meta-python/recipes-devtools/python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} (93%)
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > similarity index 93%
> > rename from meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> > rename to meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > index a72ee14f6..0d4a1207f 100644
> > --- a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> > +++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > @@ -2,7 +2,7 @@ SUMMARY = "Open source Python library for rapid development of applications \
> >      that make use of innovative user interfaces, such as multi-touch apps."
> >  HOMEPAGE = "https://kivy.org/"
> >  LICENSE = "MIT"
> > -LIC_FILES_CHKSUM = "file://LICENSE;md5=ed5cd0f2cfda42852c332e3b88c85fea"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
> >
> >  inherit setuptools3 pkgconfig features_check
> >  PIP_INSTALL_PACKAGE = "Kivy"
> > @@ -11,11 +11,11 @@ PIP_INSTALL_PACKAGE = "Kivy"
> >  # and mali-based OS's. We need to patch the setup file to tell Kivy setup
> >  # that our machine has GLES libaries installed as well
> >  # Also, if using SDL2 as backend, SDL2 needs to be configured with gles
> > -SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=stable \
> > +SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=master \
> >             file://0001-add-support-for-glesv2.patch \
> >             "
> >
> > -SRCREV = "344768bfefd2e8f5302cc9dfb8ca41991ce6f7e7"
> > +SRCREV = "9ef218027178115a66b417ae34b21f488bdd3617"
> >
> >  S = "${WORKDIR}/git"
> >
> > --
> > 2.39.2
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#108048): https://lists.openembedded.org/g/openembedded-devel/message/108048
> > Mute This Topic: https://lists.openembedded.org/mt/103542151/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Khem Raj Jan. 9, 2024, 2:56 p.m. UTC | #3
On Tue, Jan 9, 2024 at 1:08 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
>
> I think it's clang, so needs to be added to conf/nonclangable.conf?

yes, Although it will be good to report this error upstream, since
mixing const/non-const types can have
unintended consequences and result in subtle bugs.

>
> /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux-musl/python3-kivy/2.3.0/git/kivy/graphics/cgl_backend/cgl_gl.c:4549:52:
> error: incompatible function pointer types assigning to 'void
> (*)(GLuint, GLsizei, const GLchar **, const GLint *)' (aka 'void
> (*)(unsigned int, int, const char **, const int *)') from 'void
> (GLuint, GLsizei, const GLchar *const *, const GLint *)' (aka 'void
> (unsigned int, int, const char *const *, const int *)')
> [-Wincompatible-function-pointer-types]
>  4549 |   __pyx_v_4kivy_8graphics_3cgl_cgl->glShaderSource = glShaderSource;
>       |                                                    ^ ~~~~~~~~~~~~~~
>
> Note that this update is needed for both cython 3.x and python 3.12
> compatibility.
>
> Alex
>
> On Tue, 9 Jan 2024 at 04:32, Khem Raj <raj.khem@gmail.com> wrote:
> >
> > this fails to build here ( maybe its clang finding additional problems )
> >
> > https://sprunge.us/lq5PKS
> >
> > On Fri, Jan 5, 2024 at 5:36 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> > >
> > > License-Update: years, mention that it is MIT at the start.
> > >
> > > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > > ---
> > >  .../python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} | 6 +++---
> > >  1 file changed, 3 insertions(+), 3 deletions(-)
> > >  rename meta-python/recipes-devtools/python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} (93%)
> > >
> > > diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > > similarity index 93%
> > > rename from meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> > > rename to meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > > index a72ee14f6..0d4a1207f 100644
> > > --- a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> > > +++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > > @@ -2,7 +2,7 @@ SUMMARY = "Open source Python library for rapid development of applications \
> > >      that make use of innovative user interfaces, such as multi-touch apps."
> > >  HOMEPAGE = "https://kivy.org/"
> > >  LICENSE = "MIT"
> > > -LIC_FILES_CHKSUM = "file://LICENSE;md5=ed5cd0f2cfda42852c332e3b88c85fea"
> > > +LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
> > >
> > >  inherit setuptools3 pkgconfig features_check
> > >  PIP_INSTALL_PACKAGE = "Kivy"
> > > @@ -11,11 +11,11 @@ PIP_INSTALL_PACKAGE = "Kivy"
> > >  # and mali-based OS's. We need to patch the setup file to tell Kivy setup
> > >  # that our machine has GLES libaries installed as well
> > >  # Also, if using SDL2 as backend, SDL2 needs to be configured with gles
> > > -SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=stable \
> > > +SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=master \
> > >             file://0001-add-support-for-glesv2.patch \
> > >             "
> > >
> > > -SRCREV = "344768bfefd2e8f5302cc9dfb8ca41991ce6f7e7"
> > > +SRCREV = "9ef218027178115a66b417ae34b21f488bdd3617"
> > >
> > >  S = "${WORKDIR}/git"
> > >
> > > --
> > > 2.39.2
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#108048): https://lists.openembedded.org/g/openembedded-devel/message/108048
> > > Mute This Topic: https://lists.openembedded.org/mt/103542151/1997914
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
Khem Raj Jan. 9, 2024, 3:02 p.m. UTC | #4
btw, do we need to switch branch stable -> master ?
there is patch from Leon which has descriptive commit message. [1]

[1] https://patchwork.yoctoproject.org/project/oe/patch/20240109135121.3460927-3-leon.anavi@konsulko.com/

On Tue, Jan 9, 2024 at 6:56 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Tue, Jan 9, 2024 at 1:08 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> >
> > I think it's clang, so needs to be added to conf/nonclangable.conf?
>
> yes, Although it will be good to report this error upstream, since
> mixing const/non-const types can have
> unintended consequences and result in subtle bugs.
>
> >
> > /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux-musl/python3-kivy/2.3.0/git/kivy/graphics/cgl_backend/cgl_gl.c:4549:52:
> > error: incompatible function pointer types assigning to 'void
> > (*)(GLuint, GLsizei, const GLchar **, const GLint *)' (aka 'void
> > (*)(unsigned int, int, const char **, const int *)') from 'void
> > (GLuint, GLsizei, const GLchar *const *, const GLint *)' (aka 'void
> > (unsigned int, int, const char *const *, const int *)')
> > [-Wincompatible-function-pointer-types]
> >  4549 |   __pyx_v_4kivy_8graphics_3cgl_cgl->glShaderSource = glShaderSource;
> >       |                                                    ^ ~~~~~~~~~~~~~~
> >
> > Note that this update is needed for both cython 3.x and python 3.12
> > compatibility.
> >
> > Alex
> >
> > On Tue, 9 Jan 2024 at 04:32, Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > this fails to build here ( maybe its clang finding additional problems )
> > >
> > > https://sprunge.us/lq5PKS
> > >
> > > On Fri, Jan 5, 2024 at 5:36 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> > > >
> > > > License-Update: years, mention that it is MIT at the start.
> > > >
> > > > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> > > > ---
> > > >  .../python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} | 6 +++---
> > > >  1 file changed, 3 insertions(+), 3 deletions(-)
> > > >  rename meta-python/recipes-devtools/python/{python3-kivy_2.2.1.bb => python3-kivy_2.3.0.bb} (93%)
> > > >
> > > > diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > > > similarity index 93%
> > > > rename from meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> > > > rename to meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > > > index a72ee14f6..0d4a1207f 100644
> > > > --- a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
> > > > +++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
> > > > @@ -2,7 +2,7 @@ SUMMARY = "Open source Python library for rapid development of applications \
> > > >      that make use of innovative user interfaces, such as multi-touch apps."
> > > >  HOMEPAGE = "https://kivy.org/"
> > > >  LICENSE = "MIT"
> > > > -LIC_FILES_CHKSUM = "file://LICENSE;md5=ed5cd0f2cfda42852c332e3b88c85fea"
> > > > +LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
> > > >
> > > >  inherit setuptools3 pkgconfig features_check
> > > >  PIP_INSTALL_PACKAGE = "Kivy"
> > > > @@ -11,11 +11,11 @@ PIP_INSTALL_PACKAGE = "Kivy"
> > > >  # and mali-based OS's. We need to patch the setup file to tell Kivy setup
> > > >  # that our machine has GLES libaries installed as well
> > > >  # Also, if using SDL2 as backend, SDL2 needs to be configured with gles
> > > > -SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=stable \
> > > > +SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=master \
> > > >             file://0001-add-support-for-glesv2.patch \
> > > >             "
> > > >
> > > > -SRCREV = "344768bfefd2e8f5302cc9dfb8ca41991ce6f7e7"
> > > > +SRCREV = "9ef218027178115a66b417ae34b21f488bdd3617"
> > > >
> > > >  S = "${WORKDIR}/git"
> > > >
> > > > --
> > > > 2.39.2
> > > >
> > > >
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > > Links: You receive all messages sent to this group.
> > > > View/Reply Online (#108048): https://lists.openembedded.org/g/openembedded-devel/message/108048
> > > > Mute This Topic: https://lists.openembedded.org/mt/103542151/1997914
> > > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > > > -=-=-=-=-=-=-=-=-=-=-=-
> > > >
Alexander Kanavin Jan. 9, 2024, 3:50 p.m. UTC | #5
On Tue, 9 Jan 2024 at 16:02, Khem Raj <raj.khem@gmail.com> wrote:
>
> btw, do we need to switch branch stable -> master ?
> there is patch from Leon which has descriptive commit message. [1]
>
> [1] https://patchwork.yoctoproject.org/project/oe/patch/20240109135121.3460927-3-leon.anavi@konsulko.com/

When I sent mine, stable wasn't yet updated I think. So can be either way.

Alex
Alexander Kanavin Jan. 9, 2024, 3:53 p.m. UTC | #6
On Tue, 9 Jan 2024 at 15:57, Khem Raj <raj.khem@gmail.com> wrote:
>
> On Tue, Jan 9, 2024 at 1:08 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
> >
> > I think it's clang, so needs to be added to conf/nonclangable.conf?
>
> yes, Although it will be good to report this error upstream, since
> mixing const/non-const types can have
> unintended consequences and result in subtle bugs.

Reported here:
https://github.com/kivy/kivy/issues/8557

Alex
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
similarity index 93%
rename from meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
rename to meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
index a72ee14f6..0d4a1207f 100644
--- a/meta-python/recipes-devtools/python/python3-kivy_2.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
@@ -2,7 +2,7 @@  SUMMARY = "Open source Python library for rapid development of applications \
     that make use of innovative user interfaces, such as multi-touch apps."
 HOMEPAGE = "https://kivy.org/"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ed5cd0f2cfda42852c332e3b88c85fea"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
 
 inherit setuptools3 pkgconfig features_check
 PIP_INSTALL_PACKAGE = "Kivy"
@@ -11,11 +11,11 @@  PIP_INSTALL_PACKAGE = "Kivy"
 # and mali-based OS's. We need to patch the setup file to tell Kivy setup
 # that our machine has GLES libaries installed as well
 # Also, if using SDL2 as backend, SDL2 needs to be configured with gles
-SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=stable \
+SRC_URI = "git://github.com/kivy/kivy.git;protocol=https;branch=master \
            file://0001-add-support-for-glesv2.patch \
            "
 
-SRCREV = "344768bfefd2e8f5302cc9dfb8ca41991ce6f7e7"
+SRCREV = "9ef218027178115a66b417ae34b21f488bdd3617"
 
 S = "${WORKDIR}/git"