diff mbox series

linux-yocto/6.6: arm: jitter entropy backport

Message ID 20240104153721.2908762-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit 1349b759e9b8f363ab9a9feec531f3a877f97dec
Headers show
Series linux-yocto/6.6: arm: jitter entropy backport | expand

Commit Message

Bruce Ashfield Jan. 4, 2024, 3:37 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

Integrating the following commit(s) to linux-yocto/6.6:

1/1 [
    Author: Stephan Müller
    Email: smueller@chronox.de
    Subject: crypto: jitter - add RCT/APT support for different OSRs
    Date: Thu, 21 Sep 2023 13:48:11 +0200

    The oversampling rate (OSR) value specifies the heuristically implied
    entropy in the recorded data - H_submitter = 1/osr. A different entropy
    estimate implies a different APT/RCT cutoff value. This change adds
    support for OSRs 1 through 15. This OSR can be selected by the caller
    of the Jitter RNG.

    For this patch, the caller still uses one hard-coded OSR. A subsequent
    patch allows this value to be configured.

    In addition, the power-up self test is adjusted as follows:

    * It allows the caller to provide an oversampling rate that should be
    tested with - commonly it should be the same as used for the actual
    runtime operation. This makes the power-up testing therefore consistent
    with the runtime operation.

    * It calls now jent_measure_jitter (i.e. collects the full entropy
    that can possibly be harvested by the Jitter RNG) instead of only
    jent_condition_data (which only returns the entropy harvested from
    the conditioning component). This should now alleviate reports where
    the Jitter RNG initialization thinks there is too little entropy.

    * The power-up test now solely relies on the (enhanced) APT and RCT
    test that is used as a health test at runtime.

    The code allowing the different OSRs as well as the power-up test
    changes are present in the user space version of the Jitter RNG 3.4.1
    and thus was already in production use for some time.

    Reported-by "Ospan, Abylay" <aospan@amazon.com>
    Signed-off-by: Stephan Mueller <smueller@chronox.de>
    Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
]

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 .../linux/linux-yocto-rt_6.6.bb               |  2 +-
 .../linux/linux-yocto-tiny_6.6.bb             |  2 +-
 meta/recipes-kernel/linux/linux-yocto_6.6.bb  | 22 +++++++++----------
 3 files changed, 13 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
index 05a6b5f1d4..90e5ead1f4 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
@@ -14,7 +14,7 @@  python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "bfa11b7b82a8d7a3c3f5a30813a8471be20449ab"
+SRCREV_machine ?= "7e43b4538ce1a9084c4a5f1b22372c98aa888958"
 SRCREV_meta ?= "11390e802ca72f3549b9356f036b17e54afd7a34"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
index 372a8e962f..5d87855a27 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
@@ -17,7 +17,7 @@  DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
+SRCREV_machine ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
 SRCREV_meta ?= "11390e802ca72f3549b9356f036b17e54afd7a34"
 
 PV = "${LINUX_VERSION}+git"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
index 969cbb8c26..dbe4db9514 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
@@ -18,17 +18,17 @@  KBRANCH:qemux86-64 ?= "v6.6/standard/base"
 KBRANCH:qemuloongarch64  ?= "v6.6/standard/base"
 KBRANCH:qemumips64 ?= "v6.6/standard/mti-malta64"
 
-SRCREV_machine:qemuarm ?= "30f04f32ffa4d5082530a2ce565387c09a98086d"
-SRCREV_machine:qemuarm64 ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemuloongarch64 ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemumips ?= "382508b55bd871d9a81ab6d187abed39e59b277e"
-SRCREV_machine:qemuppc ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemuriscv64 ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemuriscv32 ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemux86 ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemux86-64 ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
-SRCREV_machine:qemumips64 ?= "90d9017819a05360dbf3fd2f6471cbbb3fe78db5"
-SRCREV_machine ?= "50cd24ddb6f0bcae01623196515ce62527bb79df"
+SRCREV_machine:qemuarm ?= "b0567ccb83b03434efe6bc00d7d672a59d50b82a"
+SRCREV_machine:qemuarm64 ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemuloongarch64 ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemumips ?= "df19050d1276ce9418652a39c31b77925b18fb17"
+SRCREV_machine:qemuppc ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemuriscv64 ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemuriscv32 ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemux86 ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemux86-64 ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
+SRCREV_machine:qemumips64 ?= "2cab83c3f46765b9390918a91c4fc64a873a3443"
+SRCREV_machine ?= "ff7ae7b32324226330214197e9b849d1aa35accd"
 SRCREV_meta ?= "11390e802ca72f3549b9356f036b17e54afd7a34"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll