diff mbox series

[meta-oe] v4l-utils: Add PACKAGECONFIG for v4l2-tracer to fix determinstic build

Message ID 20240102085042.3151355-1-liezhi.yang@windriver.com
State Accepted
Headers show
Series [meta-oe] v4l-utils: Add PACKAGECONFIG for v4l2-tracer to fix determinstic build | expand

Commit Message

Robert Yang Jan. 2, 2024, 8:50 a.m. UTC
From: Robert Yang <liezhi.yang@windriver.com>

Fixed do_package error when json-c is in the build dependencies chain:
ERROR: QA Issue: -dev package libv4l-dev contains non-symlink .so '/usr/lib/libv4l2tracer.so' [dev-elf]

This recipe builds out files such as av4l1compat.so v4l2convert.so and
libv4l2tracer.so which are not symlinks.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
 meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.24.1.bb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Khem Raj Jan. 8, 2024, 2:47 a.m. UTC | #1
On Tue, 02 Jan 2024 00:50:42 -0800, liezhi.yang@windriver.com wrote:
> Fixed do_package error when json-c is in the build dependencies chain:
> ERROR: QA Issue: -dev package libv4l-dev contains non-symlink .so '/usr/lib/libv4l2tracer.so' [dev-elf]
> 
> This recipe builds out files such as av4l1compat.so v4l2convert.so and
> libv4l2tracer.so which are not symlinks.
> 
> 
> [...]

Applied, thanks!

[1/1] v4l-utils: Add PACKAGECONFIG for v4l2-tracer to fix determinstic build
      commit: 9ef06c6319d2a2ce11bdc2dd21d7d03e8131be4d

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.24.1.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.24.1.bb
index c02645a6b8..f314d9b6ae 100644
--- a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.24.1.bb
+++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.24.1.bb
@@ -24,6 +24,7 @@  PACKAGECONFIG ??= "media-ctl"
 PACKAGECONFIG[media-ctl] = "--enable-v4l-utils,--disable-v4l-utils,,"
 PACKAGECONFIG[qv4l2] = ",--disable-qv4l2"
 PACKAGECONFIG[qvidcap] = ",--disable-qvidcap"
+PACKAGECONFIG[v4l2-tracer] = ",--disable-v4l2-tracer,json-c"
 
 SRC_URI = "\
     git://git.linuxtv.org/v4l-utils.git;protocol=https;branch=stable-1.24 \
@@ -77,7 +78,9 @@  FILES:${PN} = "${bindir} ${sbindir}"
 
 FILES:libv4l += "${libdir}/libv4l*${SOLIBS} ${libdir}/libv4l/*.so ${libdir}/libv4l/plugins/*.so \
                  ${libdir}/libdvbv5*${SOLIBS} \
-                 ${libdir}/libv4l/*-decomp"
+                 ${libdir}/libv4l/*-decomp \
+                 ${libdir}/libv4l2tracer.so \
+"
 
 FILES:libv4l-dev += "${includedir} ${libdir}/pkgconfig \
                      ${libdir}/libv4l*${SOLIBSDEV} ${libdir}/*.la \