diff mbox series

[01/23] fontforge: add a readline PACKAGECONFIG

Message ID 20231231122329.405225-1-alex@linutronix.de
State Accepted
Headers show
Series [01/23] fontforge: add a readline PACKAGECONFIG | expand

Commit Message

Alexander Kanavin Dec. 31, 2023, 12:23 p.m. UTC
This helps with build determinism; also if readline is not in sysroot
but readline-native is, fontforge erroneously decides to build with it.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
index 404e86b86..31dd495fd 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
@@ -24,6 +24,8 @@  SRC_URI = "git://github.com/${BPN}/${BPN}.git;branch=master;protocol=https \
 S = "${WORKDIR}/git"
 
 EXTRA_OECMAKE = "-DENABLE_DOCS=OFF"
+PACKAGECONFIG = "readline"
+PACKAGECONFIG[readline] = "-DENABLE_READLINE=ON,-DENABLE_READLINE=OFF,readline"
 
 CFLAGS += "-fno-strict-aliasing"
 LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"