diff mbox series

[v3,03/10] meta-selftest: hello-rs: Simple rust test recipe

Message ID 20231228145917.18147-4-alex.kiernan@gmail.com
State Accepted, archived
Commit 885e8e1fbfce79170ff7544dec5406d724da2560
Headers show
Series Stepwise rust upgrade 1.71.1 -> 1.74.1 | expand

Commit Message

Alex Kiernan Dec. 28, 2023, 2:59 p.m. UTC
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

(no changes since v1)

 .../hello-rs/hello-rs-crates.inc              |  8 +++++++
 .../hello-rs/0001-Greet-OE-Core.patch         | 24 +++++++++++++++++++
 .../hello-rs/hello-rs_0.1.0.bb                | 19 +++++++++++++++
 3 files changed, 51 insertions(+)
 create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
 create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
 create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb

Comments

Alexandre Belloni Dec. 29, 2023, 8:07 a.m. UTC | #1
Hello Alex,

This fails the reproducibility test:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4159/steps/13/logs/stdio

https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20231228-881dx278/packages/diff-html/

On 28/12/2023 14:59:10+0000, Alex Kiernan wrote:
> Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
> ---
> 
> (no changes since v1)
> 
>  .../hello-rs/hello-rs-crates.inc              |  8 +++++++
>  .../hello-rs/0001-Greet-OE-Core.patch         | 24 +++++++++++++++++++
>  .../hello-rs/hello-rs_0.1.0.bb                | 19 +++++++++++++++
>  3 files changed, 51 insertions(+)
>  create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
>  create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
>  create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
> 
> diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc b/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
> new file mode 100644
> index 000000000000..9646482b2875
> --- /dev/null
> +++ b/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
> @@ -0,0 +1,8 @@
> +# Autogenerated with 'bitbake -c update_crates hello-rs'
> +
> +# from Cargo.lock
> +SRC_URI += " \
> +    crate://crates.io/figlet-rs/0.1.5 \
> +"
> +
> +SRC_URI[figlet-rs-0.1.5.sha256sum] = "4742a071cd9694fc86f9fa1a08fa3e53d40cc899d7ee532295da2d085639fbc5"
> diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch b/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
> new file mode 100644
> index 000000000000..7569ccef7bbb
> --- /dev/null
> +++ b/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
> @@ -0,0 +1,24 @@
> +From 3aea1ece0ca6ac0bf0ffe42736827af22966f767 Mon Sep 17 00:00:00 2001
> +From: Alex Kiernan <alexk@zuma.ai>
> +Date: Wed, 27 Dec 2023 09:55:48 +0000
> +Subject: [PATCH] Greet "OE-Core"
> +
> +Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
> +Upstream-Status: Inappropriate
> +---
> + src/main.rs | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/src/main.rs b/src/main.rs
> +index f4a310758b19..224eca65c38d 100644
> +--- a/src/main.rs
> ++++ b/src/main.rs
> +@@ -3,7 +3,7 @@ use hello_lib::greet;
> + 
> + fn main() {
> +     let standard_font = FIGfont::standard().unwrap();
> +-    let greeting = greet(None);
> ++    let greeting = greet(Some("OE-Core"));
> +     let figure = standard_font.convert(&greeting);
> +     println!("{}", figure.unwrap());
> + }
> diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb b/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
> new file mode 100644
> index 000000000000..0046b2ca0356
> --- /dev/null
> +++ b/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
> @@ -0,0 +1,19 @@
> +SUMMARY = "Simple hello world example"
> +HOMEPAGE = "https://github.com/akiernan/hello-bin"
> +LICENSE = "Unlicense"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=7246f848faa4e9c9fc0ea91122d6e680"
> +
> +SRC_URI = "git://github.com/akiernan/hello-bin.git;protocol=https;branch=main;subpath=rust \
> +           file://0001-Greet-OE-Core.patch \
> +           git://github.com/akiernan/hello-lib.git;protocol=https;branch=main;name=hello-lib;destsuffix=hello-lib;type=git-dependency \
> +	   "
> +SRCREV = "d3d096eda182644868f8e7458dcfa538ff637db3"
> +
> +SRCREV_FORMAT .= "_hello-lib"
> +SRCREV_hello-lib = "59c84574e844617043cf337bc8fa537cf87ad8ae"
> +
> +S = "${WORKDIR}/rust"
> +
> +inherit cargo cargo-update-recipe-crates ptest-cargo
> +
> +require ${BPN}-crates.inc
> -- 
> 2.39.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192985): https://lists.openembedded.org/g/openembedded-core/message/192985
> Mute This Topic: https://lists.openembedded.org/mt/103401571/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alex Kiernan Dec. 29, 2023, 8:38 a.m. UTC | #2
I wondered if that was going to be the case, since we saw that with
zvariant too... I guess we exclude it :| I'll respin the patch set

On Fri, Dec 29, 2023 at 8:07 AM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> Hello Alex,
>
> This fails the reproducibility test:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4159/steps/13/logs/stdio
>
> https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20231228-881dx278/packages/diff-html/
>
> On 28/12/2023 14:59:10+0000, Alex Kiernan wrote:
> > Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
> > ---
> >
> > (no changes since v1)
> >
> >  .../hello-rs/hello-rs-crates.inc              |  8 +++++++
> >  .../hello-rs/0001-Greet-OE-Core.patch         | 24 +++++++++++++++++++
> >  .../hello-rs/hello-rs_0.1.0.bb                | 19 +++++++++++++++
> >  3 files changed, 51 insertions(+)
> >  create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
> >  create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
> >  create mode 100644 meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
> >
> > diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc b/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
> > new file mode 100644
> > index 000000000000..9646482b2875
> > --- /dev/null
> > +++ b/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
> > @@ -0,0 +1,8 @@
> > +# Autogenerated with 'bitbake -c update_crates hello-rs'
> > +
> > +# from Cargo.lock
> > +SRC_URI += " \
> > +    crate://crates.io/figlet-rs/0.1.5 \
> > +"
> > +
> > +SRC_URI[figlet-rs-0.1.5.sha256sum] = "4742a071cd9694fc86f9fa1a08fa3e53d40cc899d7ee532295da2d085639fbc5"
> > diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch b/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
> > new file mode 100644
> > index 000000000000..7569ccef7bbb
> > --- /dev/null
> > +++ b/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
> > @@ -0,0 +1,24 @@
> > +From 3aea1ece0ca6ac0bf0ffe42736827af22966f767 Mon Sep 17 00:00:00 2001
> > +From: Alex Kiernan <alexk@zuma.ai>
> > +Date: Wed, 27 Dec 2023 09:55:48 +0000
> > +Subject: [PATCH] Greet "OE-Core"
> > +
> > +Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
> > +Upstream-Status: Inappropriate
> > +---
> > + src/main.rs | 2 +-
> > + 1 file changed, 1 insertion(+), 1 deletion(-)
> > +
> > +diff --git a/src/main.rs b/src/main.rs
> > +index f4a310758b19..224eca65c38d 100644
> > +--- a/src/main.rs
> > ++++ b/src/main.rs
> > +@@ -3,7 +3,7 @@ use hello_lib::greet;
> > +
> > + fn main() {
> > +     let standard_font = FIGfont::standard().unwrap();
> > +-    let greeting = greet(None);
> > ++    let greeting = greet(Some("OE-Core"));
> > +     let figure = standard_font.convert(&greeting);
> > +     println!("{}", figure.unwrap());
> > + }
> > diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb b/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
> > new file mode 100644
> > index 000000000000..0046b2ca0356
> > --- /dev/null
> > +++ b/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
> > @@ -0,0 +1,19 @@
> > +SUMMARY = "Simple hello world example"
> > +HOMEPAGE = "https://github.com/akiernan/hello-bin"
> > +LICENSE = "Unlicense"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=7246f848faa4e9c9fc0ea91122d6e680"
> > +
> > +SRC_URI = "git://github.com/akiernan/hello-bin.git;protocol=https;branch=main;subpath=rust \
> > +           file://0001-Greet-OE-Core.patch \
> > +           git://github.com/akiernan/hello-lib.git;protocol=https;branch=main;name=hello-lib;destsuffix=hello-lib;type=git-dependency \
> > +        "
> > +SRCREV = "d3d096eda182644868f8e7458dcfa538ff637db3"
> > +
> > +SRCREV_FORMAT .= "_hello-lib"
> > +SRCREV_hello-lib = "59c84574e844617043cf337bc8fa537cf87ad8ae"
> > +
> > +S = "${WORKDIR}/rust"
> > +
> > +inherit cargo cargo-update-recipe-crates ptest-cargo
> > +
> > +require ${BPN}-crates.inc
> > --
> > 2.39.0
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#192985): https://lists.openembedded.org/g/openembedded-core/message/192985
> > Mute This Topic: https://lists.openembedded.org/mt/103401571/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc b/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
new file mode 100644
index 000000000000..9646482b2875
--- /dev/null
+++ b/meta-selftest/recipes-extended/hello-rs/hello-rs-crates.inc
@@ -0,0 +1,8 @@ 
+# Autogenerated with 'bitbake -c update_crates hello-rs'
+
+# from Cargo.lock
+SRC_URI += " \
+    crate://crates.io/figlet-rs/0.1.5 \
+"
+
+SRC_URI[figlet-rs-0.1.5.sha256sum] = "4742a071cd9694fc86f9fa1a08fa3e53d40cc899d7ee532295da2d085639fbc5"
diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch b/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
new file mode 100644
index 000000000000..7569ccef7bbb
--- /dev/null
+++ b/meta-selftest/recipes-extended/hello-rs/hello-rs/0001-Greet-OE-Core.patch
@@ -0,0 +1,24 @@ 
+From 3aea1ece0ca6ac0bf0ffe42736827af22966f767 Mon Sep 17 00:00:00 2001
+From: Alex Kiernan <alexk@zuma.ai>
+Date: Wed, 27 Dec 2023 09:55:48 +0000
+Subject: [PATCH] Greet "OE-Core"
+
+Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
+Upstream-Status: Inappropriate
+---
+ src/main.rs | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/main.rs b/src/main.rs
+index f4a310758b19..224eca65c38d 100644
+--- a/src/main.rs
++++ b/src/main.rs
+@@ -3,7 +3,7 @@ use hello_lib::greet;
+ 
+ fn main() {
+     let standard_font = FIGfont::standard().unwrap();
+-    let greeting = greet(None);
++    let greeting = greet(Some("OE-Core"));
+     let figure = standard_font.convert(&greeting);
+     println!("{}", figure.unwrap());
+ }
diff --git a/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb b/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
new file mode 100644
index 000000000000..0046b2ca0356
--- /dev/null
+++ b/meta-selftest/recipes-extended/hello-rs/hello-rs_0.1.0.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "Simple hello world example"
+HOMEPAGE = "https://github.com/akiernan/hello-bin"
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7246f848faa4e9c9fc0ea91122d6e680"
+
+SRC_URI = "git://github.com/akiernan/hello-bin.git;protocol=https;branch=main;subpath=rust \
+           file://0001-Greet-OE-Core.patch \
+           git://github.com/akiernan/hello-lib.git;protocol=https;branch=main;name=hello-lib;destsuffix=hello-lib;type=git-dependency \
+	   "
+SRCREV = "d3d096eda182644868f8e7458dcfa538ff637db3"
+
+SRCREV_FORMAT .= "_hello-lib"
+SRCREV_hello-lib = "59c84574e844617043cf337bc8fa537cf87ad8ae"
+
+S = "${WORKDIR}/rust"
+
+inherit cargo cargo-update-recipe-crates ptest-cargo
+
+require ${BPN}-crates.inc