diff mbox series

[meta-webserver,1/1] netdata: version bump 1.43.2 -> 1.44.1

Message ID 20231223171142.2369168-1-jan.vermaete@gmail.com
State New
Headers show
Series [meta-webserver,1/1] netdata: version bump 1.43.2 -> 1.44.1 | expand

Commit Message

Jan Vermaete Dec. 23, 2023, 5:11 p.m. UTC
* package size increased with 3%
* fixed a few oelint_adv issues

Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 ...error-when-using-disable-dbengine-16.patch | 53 +++++++++++++++++++
 .../{netdata_1.43.2.bb => netdata_1.44.1.bb}  | 25 ++++++---
 2 files changed, 71 insertions(+), 7 deletions(-)
 create mode 100644 meta-webserver/recipes-webadmin/netdata/netdata/0001-Fix-compilation-error-when-using-disable-dbengine-16.patch
 rename meta-webserver/recipes-webadmin/netdata/{netdata_1.43.2.bb => netdata_1.44.1.bb} (81%)
diff mbox series

Patch

diff --git a/meta-webserver/recipes-webadmin/netdata/netdata/0001-Fix-compilation-error-when-using-disable-dbengine-16.patch b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Fix-compilation-error-when-using-disable-dbengine-16.patch
new file mode 100644
index 000000000..09b2db0fc
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/netdata/netdata/0001-Fix-compilation-error-when-using-disable-dbengine-16.patch
@@ -0,0 +1,53 @@ 
+From db1825667e186be17401b7497a29b77d8027d2e7 Mon Sep 17 00:00:00 2001
+From: Stelios Fragkakis <52996999+stelfrag@users.noreply.github.com>
+Date: Thu, 21 Dec 2023 08:48:44 +0200
+Subject: [PATCH 1/1] Fix compilation error when using --disable-dbengine
+ (#16645)
+
+Upstream-Status: Backport [https://github.com/netdata/netdata/commit/db1825667e186be17401b7497a29b77d8027d2e7]
+
+---
+ daemon/global_statistics.c | 2 ++
+ daemon/main.c              | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/daemon/global_statistics.c b/daemon/global_statistics.c
+index 8392a3c88..6e286b18a 100644
+--- a/daemon/global_statistics.c
++++ b/daemon/global_statistics.c
+@@ -857,6 +857,7 @@ static void global_statistics_charts(void) {
+ 
+     // ----------------------------------------------------------------
+ 
++#ifdef ENABLE_DBENGINE
+     if (tier_page_type[0] == PAGE_GORILLA_METRICS)
+     {
+         static RRDSET *st_tier0_gorilla_pages = NULL;
+@@ -918,6 +919,7 @@ static void global_statistics_charts(void) {
+ 
+         rrdset_done(st_tier0_compression_info);
+     }
++#endif
+ }
+ 
+ // ----------------------------------------------------------------------------
+diff --git a/daemon/main.c b/daemon/main.c
+index fc15f0c9d..7c7452c4a 100644
+--- a/daemon/main.c
++++ b/daemon/main.c
+@@ -1502,11 +1502,11 @@ int main(int argc, char **argv) {
+ #ifdef ENABLE_DBENGINE
+                         char* createdataset_string = "createdataset=";
+                         char* stresstest_string = "stresstest=";
+-#endif
+ 
+                         if(strcmp(optarg, "pgd-tests") == 0) {
+                             return pgd_test(argc, argv);
+                         }
++#endif
+ 
+                         if(strcmp(optarg, "sqlite-meta-recover") == 0) {
+                             sql_init_database(DB_CHECK_RECOVER, 0);
+-- 
+2.39.2
+
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.43.2.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.44.1.bb
similarity index 81%
rename from meta-webserver/recipes-webadmin/netdata/netdata_1.43.2.bb
rename to meta-webserver/recipes-webadmin/netdata/netdata_1.44.1.bb
index c56da3744..dda8ddc7a 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.43.2.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.44.1.bb
@@ -1,21 +1,32 @@ 
 SUMMARY = "Real-time performance monitoring"
-DESCRIPTION = "Netdata is high-fidelity infrastructure monitoring and troubleshooting. \
-               Open-source, free, preconfigured, opinionated, and always real-time."
+DESCRIPTION = "\
+    Netdata is high-fidelity infrastructure monitoring and troubleshooting. \
+    Open-source, free, preconfigured, opinionated, and always real-time. \
+"
 HOMEPAGE = "https://github.com/netdata/netdata/"
 LICENSE = "GPL-3.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
 
-DEPENDS += "libuv util-linux zlib libyaml json-c"
+DEPENDS += "\
+    json-c \
+    libuv \
+    libyaml \
+    util-linux \
+    zlib \
+"
 
-SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \
+SRC_URI = "\
+    https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz \
+    file://0001-Fix-compilation-error-when-using-disable-dbengine-16.patch \
 "
-SRC_URI[sha256sum] = "d4a7ea2717ac7c8f04865f18e13aeaa0a36784156059f1b5ced75a44f74afc4d"
+
+SRC_URI[sha256sum] = "77e94acf7085c23ab20b2d0d2d4d2bc5a289f121fc7aac5d0daffb960041fd95"
 
 # default netdata.conf for netdata configuration
-SRC_URI += "file://netdata.conf"
+SRC_URI:append = " file://netdata.conf"
 
 # file for providing systemd service support
-SRC_URI += "file://netdata.service"
+SRC_URI:append = " file://netdata.service"
 
 UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/tags"
 UPSTREAM_CHECK_REGEX = "${BPN}/releases/tag/v(?P<pver>\d+(?:\.\d+)*)"