diff mbox series

[1/2] lemon: upgrade to 3.44.2

Message ID 20231220155334.1055853-1-ross.burton@arm.com
State Accepted
Headers show
Series [1/2] lemon: upgrade to 3.44.2 | expand

Commit Message

Ross Burton Dec. 20, 2023, 3:53 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Lemon is packaged as part of sqlite, and sqlite 3.7.3 was released back
in 2010[1].

As the small source tarballs no longer include the tools, fetch the
sqlite github mirror instead.

Don't bother installing a pretty minimal manpage, as very few projects
use lemon (sqlite itself, and libpbnjson).

[1] https://www.sqlite.org/releaselog/3_7_3.html

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-oe/recipes-devtools/lemon/files/lemon.1  | 63 -------------------
 meta-oe/recipes-devtools/lemon/lemon.inc      | 25 --------
 .../recipes-devtools/lemon/lemon_3.44.2.bb    | 24 +++++++
 meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb |  7 ---
 4 files changed, 24 insertions(+), 95 deletions(-)
 delete mode 100644 meta-oe/recipes-devtools/lemon/files/lemon.1
 delete mode 100644 meta-oe/recipes-devtools/lemon/lemon.inc
 create mode 100644 meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
 delete mode 100644 meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb

Comments

Khem Raj Dec. 20, 2023, 9:41 p.m. UTC | #1
On Wed, Dec 20, 2023 at 7:53 AM Ross Burton <ross.burton@arm.com> wrote:
>
> From: Ross Burton <ross.burton@arm.com>
>
> Lemon is packaged as part of sqlite, and sqlite 3.7.3 was released back
> in 2010[1].
>
> As the small source tarballs no longer include the tools, fetch the
> sqlite github mirror instead.
>
> Don't bother installing a pretty minimal manpage, as very few projects
> use lemon (sqlite itself, and libpbnjson).
>
> [1] https://www.sqlite.org/releaselog/3_7_3.html
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta-oe/recipes-devtools/lemon/files/lemon.1  | 63 -------------------
>  meta-oe/recipes-devtools/lemon/lemon.inc      | 25 --------
>  .../recipes-devtools/lemon/lemon_3.44.2.bb    | 24 +++++++
>  meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb |  7 ---
>  4 files changed, 24 insertions(+), 95 deletions(-)
>  delete mode 100644 meta-oe/recipes-devtools/lemon/files/lemon.1
>  delete mode 100644 meta-oe/recipes-devtools/lemon/lemon.inc
>  create mode 100644 meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
>  delete mode 100644 meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
>
> diff --git a/meta-oe/recipes-devtools/lemon/files/lemon.1 b/meta-oe/recipes-devtools/lemon/files/lemon.1
> deleted file mode 100644
> index 914ee07013..0000000000
> --- a/meta-oe/recipes-devtools/lemon/files/lemon.1
> +++ /dev/null
> @@ -1,63 +0,0 @@
> -.Dd 2002-10-04
> -.Dt LEMON 1
> -.Os "Debian GNU/Linux"
> -.\" Manual page created by Guus Sliepen <guus@debian.org>
> -.Sh NAME
> -.Nm lemon
> -.Nd The Lemon Parser Generator
> -.Sh SYNOPSIS
> -.Nm
> -.Op Fl bcgmqsx
> -.Ar input
> -.Sh DESCRIPTION
> -.Nm
> -is an LALR(1) parser generator for C or C++.
> -It does the same job as bison and yacc.
> -But
> -.Nm
> -is not another bison or yacc clone.
> -It uses a different grammar syntax which is designed to reduce the number of coding errors.
> -.Nm
> -also uses a more sophisticated parsing engine that is faster than yacc and bison
> -and which is both reentrant and thread-safe.
> -Furthermore,
> -.Nm
> -implements features that can be used to eliminate resource leaks,
> -making is suitable for use in long-running programs such as graphical user interfaces or embedded controllers.
> -.Pp
> -.Nm
> -will read the grammer from
> -.Ar input
> -and write out a parser for that grammar in the C language.
> -.Sh OPTIONS
> -.Bl -tag -width indent
> -.It Fl b
> -Print only the basis in report.
> -.It Fl c
> -Don't compress the action table.
> -.It Fl g
> -Print grammar without actions.
> -.It Fl m
> -Output a makeheaders compatible file.
> -.It Fl q
> -(Quiet) Don't print the report file.
> -.It Fl s
> -Print parser stats to standard output.
> -.It Fl x
> -Print the version number.
> -.El
> -.Sh FILES
> -.Bl -tag -width indent
> -.It Pa /usr/share/lemon/lempar.c
> -Driver template for the
> -.Nm
> -parser generator.
> -.El
> -.Sh AUTHOR
> -.Nm
> -has been written by
> -.An D. Richard Hipp Aq drh@hwaci.com .
> -.Pp
> -This manual page was written by
> -.An Guus Sliepen Aq guus@debian.org
> -for the Debian GNU/Linux system.
> diff --git a/meta-oe/recipes-devtools/lemon/lemon.inc b/meta-oe/recipes-devtools/lemon/lemon.inc
> deleted file mode 100644
> index 57b9fb710e..0000000000
> --- a/meta-oe/recipes-devtools/lemon/lemon.inc
> +++ /dev/null
> @@ -1,25 +0,0 @@
> -DESCRIPTION = "The Lemon Parser Generator"
> -HOMEPAGE = "http://www.hwaci.com/sw/lemon/"
> -LICENSE = "PD"
> -SECTION = "devel"
> -
> -SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
> -           file://lemon.1"
> -
> -S = "${WORKDIR}/sqlite-${PV}/tool"
> -
> -do_compile() {
> -    ${CC} ${CFLAGS} lemon.c -c -o lemon.o
> -    ${CCLD} ${LDFLAGS} lemon.o -o lemon
> -}
> -
> -do_install() {
> -    install -d ${D}${bindir}
> -    install -m 0755 lemon ${D}${bindir}
> -    install -m 0644 lempar.c ${D}${bindir}
> -    install -d ${D}${mandir}/man1
> -    install -m 0644 ${WORKDIR}/lemon.1 ${D}${mandir}/man1/
> -}
> -
> -BBCLASSEXTEND = "native"
> -
> diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
> new file mode 100644
> index 0000000000..1b849922a6
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
> @@ -0,0 +1,24 @@
> +DESCRIPTION = "The Lemon Parser Generator"
> +HOMEPAGE = "https://sqlite.org/src/file/doc/lemon.html"
> +LICENSE = "PD"
> +SECTION = "devel"
> +
> +LIC_FILES_CHKSUM = "file://tool/lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
> +
> +SRC_URI = "git://github.com/sqlite/sqlite;protocol=https;branch=branch-3.44"
> +
> +SRCREV = "c8f9803dc32bfee78a9ca2b1abbe39499729219b"
> +
> +S = "${WORKDIR}/git"
> +
> +do_compile() {
> +    ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} tool/lemon.c -o lemon

why do we need CPPFLAGS here ?

> +}
> +
> +do_install() {
> +    install -d ${D}${bindir}
> +    install -m 0755 lemon ${D}${bindir}
> +    install -m 0644 tool/lempar.c ${D}${bindir}

.c file in bindir seems odd.

> +}
> +
> +BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb b/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
> deleted file mode 100644
> index 354db17e6e..0000000000
> --- a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
> +++ /dev/null
> @@ -1,7 +0,0 @@
> -require lemon.inc
> -
> -LIC_FILES_CHKSUM = "file://lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
> -
> -SRC_URI[md5sum] = "5437978aae90350cf984993091e0d695"
> -SRC_URI[sha256sum] = "dbf352e8fbb74829f5e7a88f9f6ceeb80a709537f668c36e4b6cdfb271309ef6"
> -
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107664): https://lists.openembedded.org/g/openembedded-devel/message/107664
> Mute This Topic: https://lists.openembedded.org/mt/103283009/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Martin Jansa Dec. 20, 2023, 10 p.m. UTC | #2
On Wed, Dec 20, 2023 at 10:42 PM Khem Raj <raj.khem@gmail.com> wrote:

> On Wed, Dec 20, 2023 at 7:53 AM Ross Burton <ross.burton@arm.com> wrote:
> >
> > From: Ross Burton <ross.burton@arm.com>
> >
> > Lemon is packaged as part of sqlite, and sqlite 3.7.3 was released back
> > in 2010[1].
> >
> > As the small source tarballs no longer include the tools, fetch the
> > sqlite github mirror instead.
> >
> > Don't bother installing a pretty minimal manpage, as very few projects
> > use lemon (sqlite itself, and libpbnjson).
> >
> > [1] https://www.sqlite.org/releaselog/3_7_3.html
> >
> ...

> diff --git a/meta-oe/recipes-devtools/lemon/lemon.inc
> b/meta-oe/recipes-devtools/lemon/lemon.inc
> > deleted file mode 100644
> > index 57b9fb710e..0000000000
> > --- a/meta-oe/recipes-devtools/lemon/lemon.inc
> > +++ /dev/null
> > @@ -1,25 +0,0 @@
> > -DESCRIPTION = "The Lemon Parser Generator"
> > -HOMEPAGE = "http://www.hwaci.com/sw/lemon/"
> > -LICENSE = "PD"
> > -SECTION = "devel"
> > -
> > -SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
> > -           file://lemon.1"
> > -
> > -S = "${WORKDIR}/sqlite-${PV}/tool"
> > -
> > -do_compile() {
> > -    ${CC} ${CFLAGS} lemon.c -c -o lemon.o
> > -    ${CCLD} ${LDFLAGS} lemon.o -o lemon
> > -}
> > -
> > -do_install() {
> > -    install -d ${D}${bindir}
> > -    install -m 0755 lemon ${D}${bindir}
> > -    install -m 0644 lempar.c ${D}${bindir}
> > -    install -d ${D}${mandir}/man1
> > -    install -m 0644 ${WORKDIR}/lemon.1 ${D}${mandir}/man1/
> > -}
> > -
> > -BBCLASSEXTEND = "native"
> > -
> > diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
> b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
> > new file mode 100644
> > index 0000000000..1b849922a6
> > --- /dev/null
> > +++ b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
> > @@ -0,0 +1,24 @@
> > +DESCRIPTION = "The Lemon Parser Generator"
> > +HOMEPAGE = "https://sqlite.org/src/file/doc/lemon.html"
> > +LICENSE = "PD"
> > +SECTION = "devel"
> > +
> > +LIC_FILES_CHKSUM =
> "file://tool/lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
> > +
> > +SRC_URI = "git://
> github.com/sqlite/sqlite;protocol=https;branch=branch-3.44"
> > +
> > +SRCREV = "c8f9803dc32bfee78a9ca2b1abbe39499729219b"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +do_compile() {
> > +    ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} tool/lemon.c -o lemon
>
> why do we need CPPFLAGS here ?
>
> > +}
> > +
> > +do_install() {
> > +    install -d ${D}${bindir}
> > +    install -m 0755 lemon ${D}${bindir}
> > +    install -m 0644 tool/lempar.c ${D}${bindir}
>
> .c file in bindir seems odd.
>

I was wondering about it as well, but looks like lemon binary looks for
this as a default template next to lemon binary in:
https://github.com/sqlite/sqlite/blob/master/tool/lemon.c#L3654

that's why it's in bindir and was there before this upgrade as well.

> +}
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
> b/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
> > deleted file mode 100644
> > index 354db17e6e..0000000000
> > --- a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
> > +++ /dev/null
> > @@ -1,7 +0,0 @@
> > -require lemon.inc
> > -
> > -LIC_FILES_CHKSUM =
> "file://lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
> > -
> > -SRC_URI[md5sum] = "5437978aae90350cf984993091e0d695"
> > -SRC_URI[sha256sum] =
> "dbf352e8fbb74829f5e7a88f9f6ceeb80a709537f668c36e4b6cdfb271309ef6"
> > -
> > --
> > 2.34.1
> >
> >
> >
> >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107675):
> https://lists.openembedded.org/g/openembedded-devel/message/107675
> Mute This Topic: https://lists.openembedded.org/mt/103283009/3617156
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> martin.jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Dec. 20, 2023, 10:03 p.m. UTC | #3
On Wed, Dec 20, 2023 at 2:00 PM Martin Jansa <martin.jansa@gmail.com> wrote:
>
>
>
> On Wed, Dec 20, 2023 at 10:42 PM Khem Raj <raj.khem@gmail.com> wrote:
>>
>> On Wed, Dec 20, 2023 at 7:53 AM Ross Burton <ross.burton@arm.com> wrote:
>> >
>> > From: Ross Burton <ross.burton@arm.com>
>> >
>> > Lemon is packaged as part of sqlite, and sqlite 3.7.3 was released back
>> > in 2010[1].
>> >
>> > As the small source tarballs no longer include the tools, fetch the
>> > sqlite github mirror instead.
>> >
>> > Don't bother installing a pretty minimal manpage, as very few projects
>> > use lemon (sqlite itself, and libpbnjson).
>> >
>> > [1] https://www.sqlite.org/releaselog/3_7_3.html
>> >
>> ...
>>
>> > diff --git a/meta-oe/recipes-devtools/lemon/lemon.inc b/meta-oe/recipes-devtools/lemon/lemon.inc
>> > deleted file mode 100644
>> > index 57b9fb710e..0000000000
>> > --- a/meta-oe/recipes-devtools/lemon/lemon.inc
>> > +++ /dev/null
>> > @@ -1,25 +0,0 @@
>> > -DESCRIPTION = "The Lemon Parser Generator"
>> > -HOMEPAGE = "http://www.hwaci.com/sw/lemon/"
>> > -LICENSE = "PD"
>> > -SECTION = "devel"
>> > -
>> > -SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
>> > -           file://lemon.1"
>> > -
>> > -S = "${WORKDIR}/sqlite-${PV}/tool"
>> > -
>> > -do_compile() {
>> > -    ${CC} ${CFLAGS} lemon.c -c -o lemon.o
>> > -    ${CCLD} ${LDFLAGS} lemon.o -o lemon
>> > -}
>> > -
>> > -do_install() {
>> > -    install -d ${D}${bindir}
>> > -    install -m 0755 lemon ${D}${bindir}
>> > -    install -m 0644 lempar.c ${D}${bindir}
>> > -    install -d ${D}${mandir}/man1
>> > -    install -m 0644 ${WORKDIR}/lemon.1 ${D}${mandir}/man1/
>> > -}
>> > -
>> > -BBCLASSEXTEND = "native"
>> > -
>> > diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
>> > new file mode 100644
>> > index 0000000000..1b849922a6
>> > --- /dev/null
>> > +++ b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
>> > @@ -0,0 +1,24 @@
>> > +DESCRIPTION = "The Lemon Parser Generator"
>> > +HOMEPAGE = "https://sqlite.org/src/file/doc/lemon.html"
>> > +LICENSE = "PD"
>> > +SECTION = "devel"
>> > +
>> > +LIC_FILES_CHKSUM = "file://tool/lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
>> > +
>> > +SRC_URI = "git://github.com/sqlite/sqlite;protocol=https;branch=branch-3.44"
>> > +
>> > +SRCREV = "c8f9803dc32bfee78a9ca2b1abbe39499729219b"
>> > +
>> > +S = "${WORKDIR}/git"
>> > +
>> > +do_compile() {
>> > +    ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} tool/lemon.c -o lemon
>>
>> why do we need CPPFLAGS here ?
>>
>> > +}
>> > +
>> > +do_install() {
>> > +    install -d ${D}${bindir}
>> > +    install -m 0755 lemon ${D}${bindir}
>> > +    install -m 0644 tool/lempar.c ${D}${bindir}
>>
>> .c file in bindir seems odd.
>
>
> I was wondering about it as well, but looks like lemon binary looks for this as a default template next to lemon binary in:
> https://github.com/sqlite/sqlite/blob/master/tool/lemon.c#L3654
>
> that's why it's in bindir and was there before this upgrade as well.

Cool. Makes sense. Thanks Martin

>
>> > +}
>> > +
>> > +BBCLASSEXTEND = "native nativesdk"
>> > diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb b/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
>> > deleted file mode 100644
>> > index 354db17e6e..0000000000
>> > --- a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
>> > +++ /dev/null
>> > @@ -1,7 +0,0 @@
>> > -require lemon.inc
>> > -
>> > -LIC_FILES_CHKSUM = "file://lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
>> > -
>> > -SRC_URI[md5sum] = "5437978aae90350cf984993091e0d695"
>> > -SRC_URI[sha256sum] = "dbf352e8fbb74829f5e7a88f9f6ceeb80a709537f668c36e4b6cdfb271309ef6"
>> > -
>> > --
>> > 2.34.1
>> >
>> >
>> >
>> >
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107675): https://lists.openembedded.org/g/openembedded-devel/message/107675
>> Mute This Topic: https://lists.openembedded.org/mt/103283009/3617156
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [martin.jansa@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Ross Burton Dec. 21, 2023, 10:40 a.m. UTC | #4
On 20 Dec 2023, at 21:41, Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org> wrote:
>> +    ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} tool/lemon.c -o lemon
> 
> why do we need CPPFLAGS here ?

I’ve just realised that CFLAGS includes CPPFLAGS. I wonder how many times I’ve done this. :)

Ross
Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #5
On Wed, 20 Dec 2023 15:53:33 +0000, ross.burton@arm.com wrote:
> Lemon is packaged as part of sqlite, and sqlite 3.7.3 was released back
> in 2010[1].
> 
> As the small source tarballs no longer include the tools, fetch the
> sqlite github mirror instead.
> 
> Don't bother installing a pretty minimal manpage, as very few projects
> use lemon (sqlite itself, and libpbnjson).
> 
> [...]

Applied, thanks!

[1/2] lemon: upgrade to 3.44.2
      commit: c3ac5cf180f960dbbf6e3a3e76d6d44094873c72
[2/2] php: remove lemon-native build dependency
      commit: 668ba95ea7d1d5a9ea37e2a725f152eaf5eebd94

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/lemon/files/lemon.1 b/meta-oe/recipes-devtools/lemon/files/lemon.1
deleted file mode 100644
index 914ee07013..0000000000
--- a/meta-oe/recipes-devtools/lemon/files/lemon.1
+++ /dev/null
@@ -1,63 +0,0 @@ 
-.Dd 2002-10-04
-.Dt LEMON 1
-.Os "Debian GNU/Linux"
-.\" Manual page created by Guus Sliepen <guus@debian.org>
-.Sh NAME
-.Nm lemon
-.Nd The Lemon Parser Generator
-.Sh SYNOPSIS
-.Nm
-.Op Fl bcgmqsx
-.Ar input
-.Sh DESCRIPTION
-.Nm
-is an LALR(1) parser generator for C or C++.
-It does the same job as bison and yacc.
-But 
-.Nm
-is not another bison or yacc clone.
-It uses a different grammar syntax which is designed to reduce the number of coding errors.
-.Nm
-also uses a more sophisticated parsing engine that is faster than yacc and bison
-and which is both reentrant and thread-safe.
-Furthermore, 
-.Nm
-implements features that can be used to eliminate resource leaks,
-making is suitable for use in long-running programs such as graphical user interfaces or embedded controllers.
-.Pp
-.Nm
-will read the grammer from
-.Ar input
-and write out a parser for that grammar in the C language.
-.Sh OPTIONS
-.Bl -tag -width indent
-.It Fl b
-Print only the basis in report.
-.It Fl c
-Don't compress the action table.
-.It Fl g
-Print grammar without actions.
-.It Fl m
-Output a makeheaders compatible file.
-.It Fl q
-(Quiet) Don't print the report file.
-.It Fl s
-Print parser stats to standard output.
-.It Fl x
-Print the version number.
-.El
-.Sh FILES
-.Bl -tag -width indent
-.It Pa /usr/share/lemon/lempar.c
-Driver template for the
-.Nm
-parser generator.
-.El
-.Sh AUTHOR
-.Nm
-has been written by
-.An D. Richard Hipp Aq drh@hwaci.com .
-.Pp
-This manual page was written by
-.An Guus Sliepen Aq guus@debian.org
-for the Debian GNU/Linux system.
diff --git a/meta-oe/recipes-devtools/lemon/lemon.inc b/meta-oe/recipes-devtools/lemon/lemon.inc
deleted file mode 100644
index 57b9fb710e..0000000000
--- a/meta-oe/recipes-devtools/lemon/lemon.inc
+++ /dev/null
@@ -1,25 +0,0 @@ 
-DESCRIPTION = "The Lemon Parser Generator"
-HOMEPAGE = "http://www.hwaci.com/sw/lemon/"
-LICENSE = "PD"
-SECTION = "devel"
-
-SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
-           file://lemon.1"
-
-S = "${WORKDIR}/sqlite-${PV}/tool"
-
-do_compile() {
-    ${CC} ${CFLAGS} lemon.c -c -o lemon.o
-    ${CCLD} ${LDFLAGS} lemon.o -o lemon
-}
-
-do_install() {
-    install -d ${D}${bindir}
-    install -m 0755 lemon ${D}${bindir}
-    install -m 0644 lempar.c ${D}${bindir}
-    install -d ${D}${mandir}/man1
-    install -m 0644 ${WORKDIR}/lemon.1 ${D}${mandir}/man1/
-}
-
-BBCLASSEXTEND = "native"
-
diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
new file mode 100644
index 0000000000..1b849922a6
--- /dev/null
+++ b/meta-oe/recipes-devtools/lemon/lemon_3.44.2.bb
@@ -0,0 +1,24 @@ 
+DESCRIPTION = "The Lemon Parser Generator"
+HOMEPAGE = "https://sqlite.org/src/file/doc/lemon.html"
+LICENSE = "PD"
+SECTION = "devel"
+
+LIC_FILES_CHKSUM = "file://tool/lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
+
+SRC_URI = "git://github.com/sqlite/sqlite;protocol=https;branch=branch-3.44"
+
+SRCREV = "c8f9803dc32bfee78a9ca2b1abbe39499729219b"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+    ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} tool/lemon.c -o lemon
+}
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 lemon ${D}${bindir}
+    install -m 0644 tool/lempar.c ${D}${bindir}
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb b/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
deleted file mode 100644
index 354db17e6e..0000000000
--- a/meta-oe/recipes-devtools/lemon/lemon_3.7.3.bb
+++ /dev/null
@@ -1,7 +0,0 @@ 
-require lemon.inc
-
-LIC_FILES_CHKSUM = "file://lemon.c;endline=8;md5=c7551a78fa3fdecd96d1ad6761d205ee"
-
-SRC_URI[md5sum] = "5437978aae90350cf984993091e0d695"
-SRC_URI[sha256sum] = "dbf352e8fbb74829f5e7a88f9f6ceeb80a709537f668c36e4b6cdfb271309ef6"
-