diff mbox series

[v4] systemd-boot: Add recipe to compile native

Message ID 20231216002503.3681891-1-quic_vkraleti@quicinc.com
State Accepted, archived
Commit 8063bcb2d4fcfeded5edac3b0895151e8dc8bf0f
Headers show
Series [v4] systemd-boot: Add recipe to compile native | expand

Commit Message

Viswanath Kraleti Dec. 16, 2023, 12:25 a.m. UTC
systemd-boot native recipe provides ukify tool to build
UKI images for systemd-boot

Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
---
 .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb

Comments

Alexander Kanavin Dec. 16, 2023, 11:34 a.m. UTC | #1
Can we rather fold it into systemd-boot with bbassextend?

Alex

On Sat 16. Dec 2023 at 1.26, Viswanath Kraleti <quic_vkraleti@quicinc.com>
wrote:

> systemd-boot native recipe provides ukify tool to build
> UKI images for systemd-boot
>
> Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
> ---
>  .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>
> diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> new file mode 100644
> index 0000000000..73db59b14e
> --- /dev/null
> +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> @@ -0,0 +1,15 @@
> +require systemd.inc
> +
> +inherit native
> +
> +deltask do_configure
> +deltask do_compile
> +
> +do_install () {
> +       install -Dm 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
> +}
> +addtask install after do_unpack
> +
> +PACKAGES = "${PN}"
> +
> +FILES:${PN} = "${bindir}/ukify"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192554):
> https://lists.openembedded.org/g/openembedded-core/message/192554
> Mute This Topic: https://lists.openembedded.org/mt/103202155/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Viswanath Kraleti Dec. 16, 2023, 11:49 a.m. UTC | #2
Initial patch is for the same. However got a feedback to use a separate 
recipe as extending systemd-boot recipe made is messy with a bunch of 
overrides for almost all tasks.

check: https://lists.openembedded.org/g/openembedded-core/message/191307

//Viswanath

On 12/16/2023 5:04 PM, Alexander Kanavin wrote:
> Can we rather fold it into systemd-boot with bbassextend?
> 
> Alex
> 
> On Sat 16. Dec 2023 at 1.26, Viswanath Kraleti 
> <quic_vkraleti@quicinc.com <mailto:quic_vkraleti@quicinc.com>> wrote:
> 
>     systemd-boot native recipe provides ukify tool to build
>     UKI images for systemd-boot
> 
>     Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com
>     <mailto:quic_vkraleti@quicinc.com>>
>     ---
>       .../systemd/systemd-boot-native_254.4.bb
>     <http://systemd-boot-native_254.4.bb>          | 15 +++++++++++++++
>       1 file changed, 15 insertions(+)
>       create mode 100644
>     meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>     <http://systemd-boot-native_254.4.bb>
> 
>     diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>     <http://systemd-boot-native_254.4.bb>
>     b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>     <http://systemd-boot-native_254.4.bb>
>     new file mode 100644
>     index 0000000000..73db59b14e
>     --- /dev/null
>     +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
>     <http://systemd-boot-native_254.4.bb>
>     @@ -0,0 +1,15 @@
>     +require systemd.inc
>     +
>     +inherit native
>     +
>     +deltask do_configure
>     +deltask do_compile
>     +
>     +do_install () {
>     +       install -Dm 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
>     +}
>     +addtask install after do_unpack
>     +
>     +PACKAGES = "${PN}"
>     +
>     +FILES:${PN} = "${bindir}/ukify"
>     -- 
>     2.25.1
> 
> 
> 
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192556): https://lists.openembedded.org/g/openembedded-core/message/192556
> Mute This Topic: https://lists.openembedded.org/mt/103202155/5192326
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [quic_vkraleti@quicinc.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexandre Belloni Dec. 20, 2023, 7:59 a.m. UTC | #3
Hello,

You didn't fix this one:

The following recipes do not have a maintainer assigned to them. Please add an entry to meta/conf/distro/include/maintainers.inc file.
systemd-boot-native (/home/pokybuild/yocto-worker/oe-selftest-ubuntu/build/meta/recipes-core/systemd/systemd-boot-native_254.4.bb)

On 16/12/2023 05:55:03+0530, Viswanath Kraleti wrote:
> systemd-boot native recipe provides ukify tool to build
> UKI images for systemd-boot
> 
> Signed-off-by: Viswanath Kraleti <quic_vkraleti@quicinc.com>
> ---
>  .../systemd/systemd-boot-native_254.4.bb          | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> 
> diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> new file mode 100644
> index 0000000000..73db59b14e
> --- /dev/null
> +++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
> @@ -0,0 +1,15 @@
> +require systemd.inc
> +
> +inherit native
> +
> +deltask do_configure
> +deltask do_compile
> +
> +do_install () {
> +       install -Dm 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
> +}
> +addtask install after do_unpack
> +
> +PACKAGES = "${PN}"
> +
> +FILES:${PN} = "${bindir}/ukify"
> -- 
> 2.25.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192554): https://lists.openembedded.org/g/openembedded-core/message/192554
> Mute This Topic: https://lists.openembedded.org/mt/103202155/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Viswanath Kraleti Dec. 29, 2023, 5:06 a.m. UTC | #4
Assigned maintainer assigned with https://lists.openembedded.org/g/openembedded-core/message/192993 ( https://lists.openembedded.org/g/openembedded-core/message/192993 )
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot-native_254.4.bb b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
new file mode 100644
index 0000000000..73db59b14e
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot-native_254.4.bb
@@ -0,0 +1,15 @@ 
+require systemd.inc
+
+inherit native
+
+deltask do_configure
+deltask do_compile
+
+do_install () {
+       install -Dm 0755 ${S}/src/ukify/ukify.py ${D}${bindir}/ukify
+}
+addtask install after do_unpack
+
+PACKAGES = "${PN}"
+
+FILES:${PN} = "${bindir}/ukify"