diff mbox series

[V2] rxvt-unicode: set correct outdir for tic

Message ID 20231214094101.3010549-1-changqing.li@windriver.com
State New
Headers show
Series [V2] rxvt-unicode: set correct outdir for tic | expand

Commit Message

Changqing Li Dec. 14, 2023, 9:41 a.m. UTC
From: Changqing Li <changqing.li@windriver.com>

tic is from ncurses-native, and set TERMINFO as
${RECIPE_SYSROOT_NATIVE}/${datadir}/terminfo of ncurses-native, so the
rxvt-unicode terminfo will be wrongly installed in there.  set the
outdir explicitly to install them to correct dir.

Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
 .../rxvt-unicode/rxvt-unicode.inc             |  5 +--
 .../0001-Makefile.in-set-outdir-for-tic.patch | 35 +++++++++++++++++++
 2 files changed, 38 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch

Comments

Alexandre Belloni Dec. 18, 2023, 4:08 p.m. UTC | #1
Hello,

This causes:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4106/steps/12/logs/stdio
https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20231218-s_bdlb3l/packages/diff-html/

On 14/12/2023 17:41:01+0800, Changqing Li wrote:
> From: Changqing Li <changqing.li@windriver.com>
> 
> tic is from ncurses-native, and set TERMINFO as
> ${RECIPE_SYSROOT_NATIVE}/${datadir}/terminfo of ncurses-native, so the
> rxvt-unicode terminfo will be wrongly installed in there.  set the
> outdir explicitly to install them to correct dir.
> 
> Signed-off-by: Changqing Li <changqing.li@windriver.com>
> ---
>  .../rxvt-unicode/rxvt-unicode.inc             |  5 +--
>  .../0001-Makefile.in-set-outdir-for-tic.patch | 35 +++++++++++++++++++
>  2 files changed, 38 insertions(+), 2 deletions(-)
>  create mode 100644 meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch
> 
> diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc b/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc
> index e7d520ebef..2f01f54305 100644
> --- a/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc
> +++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc
> @@ -11,7 +11,8 @@ DEPENDS = "virtual/libx11 libxt libxft gdk-pixbuf libxmu libptytty"
>  SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
>  	   file://xwc.patch \
>  	   file://rxvt.desktop \
> -	   file://rxvt.png"
> +	   file://rxvt.png \
> +	   file://0001-Makefile.in-set-outdir-for-tic.patch "
>  
>  inherit autotools pkgconfig update-alternatives
>  
> @@ -55,4 +56,4 @@ do_install:append () {
>  	install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
>  }
>  
> -FILES:${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"
> +FILES:${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png ${datadir}/terminfo"
> diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch b/meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch
> new file mode 100644
> index 0000000000..7ba0e668dc
> --- /dev/null
> +++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch
> @@ -0,0 +1,35 @@
> +From 1b7d547453fc57806ef86f64c86706530a23e62e Mon Sep 17 00:00:00 2001
> +From: Changqing Li <changqing.li@windriver.com>
> +Date: Wed, 13 Dec 2023 11:53:18 +0800
> +Subject: [PATCH] Makefile.in: set outdir for tic
> +
> +tic is from ncurses-native, and set TERMINFO as
> +${RECIPE_SYSROOT_NATIVE}/${datadir}/terminfo of ncurses-native, so the
> +rxvt-unicode terminfo will be wrongly installed in there.  set the
> +outdir explicitly to install them to correct dir.
> +
> +Upstream-Status: Submitted [ https://github.com/exg/rxvt-unicode/pull/4 ]
> +
> +Signed-off-by: Changqing Li <changqing.li@windriver.com>
> +---
> + doc/Makefile.in | 4 ++--
> + 1 file changed, 2 insertions(+), 2 deletions(-)
> +
> +diff --git a/doc/Makefile.in b/doc/Makefile.in
> +index e3d1fe8..1de56d3 100644
> +--- a/doc/Makefile.in
> ++++ b/doc/Makefile.in
> +@@ -100,8 +100,8 @@ install: all
> + 	$(INSTALL_DATA) rxvtd.1.man   $(DESTDIR)$(man1dir)/$(RXVTNAME)d.$(man1ext)
> + 	$(INSTALL_DATA) rxvt.7.man    $(DESTDIR)$(man7dir)/$(RXVTNAME).$(man7ext)
> + 	$(INSTALL_DATA) rclock.1.man  $(DESTDIR)$(man1dir)/urclock.$(man1ext)
> +-	@TIC@ -x $(srcdir)/etc/rxvt-unicode.terminfo || \
> +-           @TIC@ $(srcdir)/etc/rxvt-unicode.terminfo
> ++	@TIC@ -x $(srcdir)/etc/rxvt-unicode.terminfo -o $(DESTDIR)$(datadir)/terminfo || \
> ++           @TIC@ $(srcdir)/etc/rxvt-unicode.terminfo -o $(DESTDIR)$(datadir)/terminfo
> + 
> + distdepend: alldoc
> + 
> +-- 
> +2.25.1
> +
> -- 
> 2.25.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192340): https://lists.openembedded.org/g/openembedded-core/message/192340
> Mute This Topic: https://lists.openembedded.org/mt/103167118/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc b/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc
index e7d520ebef..2f01f54305 100644
--- a/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode.inc
@@ -11,7 +11,8 @@  DEPENDS = "virtual/libx11 libxt libxft gdk-pixbuf libxmu libptytty"
 SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
 	   file://xwc.patch \
 	   file://rxvt.desktop \
-	   file://rxvt.png"
+	   file://rxvt.png \
+	   file://0001-Makefile.in-set-outdir-for-tic.patch "
 
 inherit autotools pkgconfig update-alternatives
 
@@ -55,4 +56,4 @@  do_install:append () {
 	install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
 }
 
-FILES:${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"
+FILES:${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png ${datadir}/terminfo"
diff --git a/meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch b/meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch
new file mode 100644
index 0000000000..7ba0e668dc
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/rxvt-unicode/0001-Makefile.in-set-outdir-for-tic.patch
@@ -0,0 +1,35 @@ 
+From 1b7d547453fc57806ef86f64c86706530a23e62e Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Wed, 13 Dec 2023 11:53:18 +0800
+Subject: [PATCH] Makefile.in: set outdir for tic
+
+tic is from ncurses-native, and set TERMINFO as
+${RECIPE_SYSROOT_NATIVE}/${datadir}/terminfo of ncurses-native, so the
+rxvt-unicode terminfo will be wrongly installed in there.  set the
+outdir explicitly to install them to correct dir.
+
+Upstream-Status: Submitted [ https://github.com/exg/rxvt-unicode/pull/4 ]
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+---
+ doc/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/doc/Makefile.in b/doc/Makefile.in
+index e3d1fe8..1de56d3 100644
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -100,8 +100,8 @@ install: all
+ 	$(INSTALL_DATA) rxvtd.1.man   $(DESTDIR)$(man1dir)/$(RXVTNAME)d.$(man1ext)
+ 	$(INSTALL_DATA) rxvt.7.man    $(DESTDIR)$(man7dir)/$(RXVTNAME).$(man7ext)
+ 	$(INSTALL_DATA) rclock.1.man  $(DESTDIR)$(man1dir)/urclock.$(man1ext)
+-	@TIC@ -x $(srcdir)/etc/rxvt-unicode.terminfo || \
+-           @TIC@ $(srcdir)/etc/rxvt-unicode.terminfo
++	@TIC@ -x $(srcdir)/etc/rxvt-unicode.terminfo -o $(DESTDIR)$(datadir)/terminfo || \
++           @TIC@ $(srcdir)/etc/rxvt-unicode.terminfo -o $(DESTDIR)$(datadir)/terminfo
+ 
+ distdepend: alldoc
+ 
+-- 
+2.25.1
+