diff mbox series

[meta-python] python3-sentry-sdk: upgrade 1.37.1 -> 1.39.0

Message ID 1702544736-28467-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-sentry-sdk: upgrade 1.37.1 -> 1.39.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 9:05 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Add support for cluster clients from Redis SDK 
-Improve location reporting for timer metrics 
-Fix Celery TypeError with no-argument apply_async 
-Fix Lambda integration with EventBridge source 
-Add max tries to Spotlight 
-Handle os.path.devnull access issues 
-Change code.filepath frame picking logic 
-Trigger AWS Lambda tests on label 
-Run permissions step on pull_request_target but not push 
-Hash AWS Lambda test functions based on current revision 
-Update Django version in tests 
-Make metrics tests non-flaky 
-Various fixes & improvements
-Only add trace context to checkins and do not run event_processors for checkins 
-Metric span summaries 
-Add source context to code locations 
-Use in-app filepath instead of absolute path 
-Switch to jinja2 for generating CI yamls 

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ython3-sentry-sdk_1.37.1.bb => python3-sentry-sdk_1.39.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-sentry-sdk_1.37.1.bb => python3-sentry-sdk_1.39.0.bb} (86%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Thu, 14 Dec 2023 17:05:36 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ===========
> -Add support for cluster clients from Redis SDK
> -Improve location reporting for timer metrics
> -Fix Celery TypeError with no-argument apply_async
> -Fix Lambda integration with EventBridge source
> -Add max tries to Spotlight
> -Handle os.path.devnull access issues
> -Change code.filepath frame picking logic
> -Trigger AWS Lambda tests on label
> -Run permissions step on pull_request_target but not push
> -Hash AWS Lambda test functions based on current revision
> -Update Django version in tests
> -Make metrics tests non-flaky
> -Various fixes & improvements
> -Only add trace context to checkins and do not run event_processors for checkins
> -Metric span summaries
> -Add source context to code locations
> -Use in-app filepath instead of absolute path
> -Switch to jinja2 for generating CI yamls
> 
> [...]

Applied, thanks!

[1/1] python3-sentry-sdk: upgrade 1.37.1 -> 1.39.0
      commit: 6c98ed4d1af68cf0a6e236e5cb6e5a0d798f874c

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.37.1.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.39.0.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-sentry-sdk_1.37.1.bb
rename to meta-python/recipes-devtools/python/python3-sentry-sdk_1.39.0.bb
index 868a7e2f3..81828737f 100644
--- a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.37.1.bb
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.39.0.bb
@@ -15,7 +15,7 @@  RDEPENDS:${PN} += "\
 	${PYTHON_PN}-datetime \
 "
 
-SRC_URI[sha256sum] = "7cd324dd2877fdc861f75cba4242bce23a58272a6fea581fcb218bb718bd9cc5"
+SRC_URI[sha256sum] = "67f62238af273eebd6432f85116dc6cd5422d4bc02df886514e8139e755f48e4"
 
 PYPI_PACKAGE = "sentry-sdk"