[meta-oe] googlebenchmark: add 1.6.1

Message ID 20220214224720.16203-1-jsbronder@cold-front.org
State New
Headers show
Series [meta-oe] googlebenchmark: add 1.6.1 | expand

Commit Message

Justin Bronder Feb. 14, 2022, 10:47 p.m. UTC
As meta-oe already has googletest, it seems appropriate to me to also
add googlebenchmark which is structured quite similarly.

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 .../googlebenchmark/googlebenchmark_1.6.1.bb  | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb

Patch

diff --git a/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb b/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
new file mode 100644
index 0000000000..b44d3bee27
--- /dev/null
+++ b/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
@@ -0,0 +1,20 @@ 
+DESCRIPTION = "A microbenchmark support library"
+HOMEPAGE = "https://github.com/google/benchmark"
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://github.com/google/benchmark.git;protocol=https;branch=main"
+SRCREV = "0d98dba29d66e93259db7daa53a9327df767a415"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE = " \
+    -DBUILD_SHARED_LIBS=yes \
+    -DBENCHMARK_ENABLE_TESTING=no \
+    -DCMAKE_BUILD_TYPE=Release \
+"
+
+inherit cmake
+
+FILES:${PN}-dev += "${libdir}/cmake"