diff mbox series

[meta-python,3/7] python3-pydantic: fix RDEPENDS

Message ID e4660bc7f55d5e9eaa76f27d39f20d4fcb762689.1701991044.git.ticotimo@gmail.com
State Accepted
Headers show
Series [meta-python,1/7] python3-pydantic-core: add v2.14.5 | expand

Commit Message

Tim Orling Dec. 7, 2023, 11:23 p.m. UTC
* Newer python3-pydantic offloaded some of its code to python3-pydantic-core
* Add python3-annotated-types to RDEPENDS.
* Add DESCRIPTION and trim SUMMARY.

Signed-off-by: Tim Orling <ticotimo@gmail.com>
---
 .../recipes-devtools/python/python3-pydantic_2.5.2.bb  | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
index 3750d49a9..226c58e87 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
@@ -1,4 +1,10 @@ 
-SUMMARY = "Data validation and settings management using Python type hinting"
+SUMMARY = "Data validation using Python type hinting"
+DESCRIPTION = "Data validation and settings management using Python \
+type hints.\
+\
+Fast and extensible, Pydantic plays nicely with your linters/IDE/brain. \
+Define how data should be in pure, canonical Python 3.7+; validate it with \
+Pydantic."
 HOMEPAGE = "https://github.com/samuelcolvin/pydantic"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
@@ -10,6 +16,7 @@  SRC_URI[sha256sum] = "ff177ba64c6faf73d7afa2e8cad38fd456c0dbe01c9954e71038001cd1
 DEPENDS += "python3-hatch-fancy-pypi-readme-native"
 
 RDEPENDS:${PN} += "\
+    python3-annotated-types \
     python3-core \
     python3-datetime \
     python3-image \
@@ -19,5 +26,6 @@  RDEPENDS:${PN} += "\
     python3-netclient \
     python3-numbers \
     python3-profile \
+    python3-pydantic-core \
     python3-typing-extensions \
 "