diff mbox series

[meta-oe] snappy: upgrade 1.1.9 -> 1.1.10

Message ID 20231204075356.26863-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] snappy: upgrade 1.1.9 -> 1.1.10 | expand

Commit Message

Alper Ak Dec. 4, 2023, 7:53 a.m. UTC
* 0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch removed because fixed in the new version

Changelog:

* Performance improvements
* Compilation fixes for various environments

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 ...-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch | 71 -------------------
 .../{snappy_1.1.9.bb => snappy_1.1.10.bb}     |  8 +--
 2 files changed, 3 insertions(+), 76 deletions(-)
 delete mode 100644 meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
 rename meta-oe/recipes-extended/snappy/{snappy_1.1.9.bb => snappy_1.1.10.bb} (85%)

Comments

Khem Raj Dec. 5, 2023, 6:06 p.m. UTC | #1
this fails on arm
https://errors.yoctoproject.org/Errors/Details/745647/

On Sun, Dec 3, 2023 at 11:54 PM Alper Ak <alperyasinak1@gmail.com> wrote:
>
> * 0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch removed because fixed in the new version
>
> Changelog:
>
> * Performance improvements
> * Compilation fixes for various environments
>
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  ...-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch | 71 -------------------
>  .../{snappy_1.1.9.bb => snappy_1.1.10.bb}     |  8 +--
>  2 files changed, 3 insertions(+), 76 deletions(-)
>  delete mode 100644 meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
>  rename meta-oe/recipes-extended/snappy/{snappy_1.1.9.bb => snappy_1.1.10.bb} (85%)
>
> diff --git a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch b/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> deleted file mode 100644
> index 27357d88a..000000000
> --- a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> +++ /dev/null
> @@ -1,71 +0,0 @@
> -From 4728803cc8687431449c8c9fbfabb1da04943400 Mon Sep 17 00:00:00 2001
> -From: "Georgi D. Sotirov" <gdsotirov@gmail.com>
> -Date: Wed, 5 May 2021 14:16:46 +0300
> -Subject: [PATCH] Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> -
> -Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE on AdvanceToNextTag to
> -fix the following compilation errors and a warning with GCC:
> -
> -[  2%] Building CXX object CMakeFiles/snappy.dir/snappy.cc.o
> -/usr/bin/c++   -DHAVE_CONFIG_H -Dsnappy_EXPORTS
> --I/tmp/snappy-1.1.9/build -I/tmp/snappy-1.1.9  -O3
> --march=i586 -mtune=i686 -Wall -Wextra -fno-exceptions -fno-rtti -O3
> --DNDEBUG -fPIC   -std=c++11 -o CMakeFiles/snappy.dir/snappy.cc.o -c
> -/tmp/snappy-1.1.9/snappy.cc
> -/tmp/snappy-1.1.9/snappy.cc:1017:8: warning: always_inline
> -function might not be inlinable [-Wattributes]
> - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> -        ^
> -/tmp/snappy-1.1.9/snappy.cc: In function 'std::pair<const
> -unsigned char*, int> snappy::DecompressBranchless(const uint8_t*, const
> -uint8_t*, ptrdiff_t, T, ptrdiff_t) [with T = char*; uint8_t = unsigned
> -char; ptrdiff_t = int]':
> -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> -size_t*)': function body can be overwritten at link time
> -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> -                                                     ^
> -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> -size_t*)': function body can be overwritten at link time
> - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> -        ^
> -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> -                                                     ^
> -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> -size_t*)': function body can be overwritten at link time
> - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> -        ^
> -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> -                                                     ^
> -CMakeFiles/snappy.dir/build.make:137: recipe for target
> -'CMakeFiles/snappy.dir/snappy.cc.o' failed
> -
> -Just like with other functions using SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> -macro (i.e. __attribute__((always_inline)) ) it is necessary to use C++
> -inline specifier.
> -
> -Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> -
> -Upstream-Status: Submitted [https://github.com/google/snappy/pull/128]
> ----
> - snappy.cc | 2 +-
> - 1 file changed, 1 insertion(+), 1 deletion(-)
> -
> -diff --git a/snappy.cc b/snappy.cc
> -index 79dc0e8..51157be 100644
> ---- a/snappy.cc
> -+++ b/snappy.cc
> -@@ -1014,7 +1014,7 @@ void MemMove(ptrdiff_t dst, const void* src, size_t size) {
> - }
> -
> - SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> --size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> -+inline size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> -   const uint8_t*& ip = *ip_p;
> -   // This section is crucial for the throughput of the decompression loop.
> -   // The latency of an iteration is fundamentally constrained by the
> diff --git a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> similarity index 85%
> rename from meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
> rename to meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> index 9e0e43ce8..7baf9c647 100644
> --- a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
> +++ b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> @@ -10,12 +10,10 @@ compression ratio."
>  LICENSE = "BSD-3-Clause"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
>
> -SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main \
> -    file://0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch \
> -"
> -SRCREV = "2b63814b15a2aaae54b7943f0cd935892fae628f"
> -S = "${WORKDIR}/git"
> +SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main"
> +SRCREV = "dc05e026488865bc69313a68bcc03ef2e4ea8e83"
>
> +S = "${WORKDIR}/git"
>
>  inherit cmake pkgconfig
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107200): https://lists.openembedded.org/g/openembedded-devel/message/107200
> Mute This Topic: https://lists.openembedded.org/mt/102966758/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alper Ak Dec. 5, 2023, 7:09 p.m. UTC | #2
I think, I found the issue but I don't know how to solve it. Btw,
works on arm64.

When I looked at the errors, I saw lines like:

error: use of undeclared identifier 'vminvq_u8'; did you mean 'vmvnq_u8'?
error: use of undeclared identifier 'vmaxvq_u8'
error: use of undeclared identifier 'vqtbl1q_u8'; did you mean 'vtbl1_u8'?
error: cannot initialize a parameter of type 'uint8x8_t' (vector of 8
'uint8_t' values) with an lvalue of type 'V128' (aka 'uint8x16_t')

When I checked the intrinsics from ARM, I saw that the supported
architecture is A64.

https://arm-software.github.io/acle/neon_intrinsics/advsimd.html

Khem Raj <raj.khem@gmail.com>, 5 Ara 2023 Sal, 21:06 tarihinde şunu yazdı:
>
> this fails on arm
> https://errors.yoctoproject.org/Errors/Details/745647/
>
> On Sun, Dec 3, 2023 at 11:54 PM Alper Ak <alperyasinak1@gmail.com> wrote:
> >
> > * 0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch removed because fixed in the new version
> >
> > Changelog:
> >
> > * Performance improvements
> > * Compilation fixes for various environments
> >
> > Signed-off-by: alperak <alperyasinak1@gmail.com>
> > ---
> >  ...-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch | 71 -------------------
> >  .../{snappy_1.1.9.bb => snappy_1.1.10.bb}     |  8 +--
> >  2 files changed, 3 insertions(+), 76 deletions(-)
> >  delete mode 100644 meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> >  rename meta-oe/recipes-extended/snappy/{snappy_1.1.9.bb => snappy_1.1.10.bb} (85%)
> >
> > diff --git a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch b/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> > deleted file mode 100644
> > index 27357d88a..000000000
> > --- a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> > +++ /dev/null
> > @@ -1,71 +0,0 @@
> > -From 4728803cc8687431449c8c9fbfabb1da04943400 Mon Sep 17 00:00:00 2001
> > -From: "Georgi D. Sotirov" <gdsotirov@gmail.com>
> > -Date: Wed, 5 May 2021 14:16:46 +0300
> > -Subject: [PATCH] Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> > -
> > -Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE on AdvanceToNextTag to
> > -fix the following compilation errors and a warning with GCC:
> > -
> > -[  2%] Building CXX object CMakeFiles/snappy.dir/snappy.cc.o
> > -/usr/bin/c++   -DHAVE_CONFIG_H -Dsnappy_EXPORTS
> > --I/tmp/snappy-1.1.9/build -I/tmp/snappy-1.1.9  -O3
> > --march=i586 -mtune=i686 -Wall -Wextra -fno-exceptions -fno-rtti -O3
> > --DNDEBUG -fPIC   -std=c++11 -o CMakeFiles/snappy.dir/snappy.cc.o -c
> > -/tmp/snappy-1.1.9/snappy.cc
> > -/tmp/snappy-1.1.9/snappy.cc:1017:8: warning: always_inline
> > -function might not be inlinable [-Wattributes]
> > - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > -        ^
> > -/tmp/snappy-1.1.9/snappy.cc: In function 'std::pair<const
> > -unsigned char*, int> snappy::DecompressBranchless(const uint8_t*, const
> > -uint8_t*, ptrdiff_t, T, ptrdiff_t) [with T = char*; uint8_t = unsigned
> > -char; ptrdiff_t = int]':
> > -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> > -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> > -size_t*)': function body can be overwritten at link time
> > -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> > -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> > -                                                     ^
> > -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> > -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> > -size_t*)': function body can be overwritten at link time
> > - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > -        ^
> > -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> > -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> > -                                                     ^
> > -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> > -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> > -size_t*)': function body can be overwritten at link time
> > - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > -        ^
> > -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> > -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> > -                                                     ^
> > -CMakeFiles/snappy.dir/build.make:137: recipe for target
> > -'CMakeFiles/snappy.dir/snappy.cc.o' failed
> > -
> > -Just like with other functions using SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> > -macro (i.e. __attribute__((always_inline)) ) it is necessary to use C++
> > -inline specifier.
> > -
> > -Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> > -
> > -Upstream-Status: Submitted [https://github.com/google/snappy/pull/128]
> > ----
> > - snappy.cc | 2 +-
> > - 1 file changed, 1 insertion(+), 1 deletion(-)
> > -
> > -diff --git a/snappy.cc b/snappy.cc
> > -index 79dc0e8..51157be 100644
> > ---- a/snappy.cc
> > -+++ b/snappy.cc
> > -@@ -1014,7 +1014,7 @@ void MemMove(ptrdiff_t dst, const void* src, size_t size) {
> > - }
> > -
> > - SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> > --size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > -+inline size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > -   const uint8_t*& ip = *ip_p;
> > -   // This section is crucial for the throughput of the decompression loop.
> > -   // The latency of an iteration is fundamentally constrained by the
> > diff --git a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> > similarity index 85%
> > rename from meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
> > rename to meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> > index 9e0e43ce8..7baf9c647 100644
> > --- a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
> > +++ b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> > @@ -10,12 +10,10 @@ compression ratio."
> >  LICENSE = "BSD-3-Clause"
> >  LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
> >
> > -SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main \
> > -    file://0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch \
> > -"
> > -SRCREV = "2b63814b15a2aaae54b7943f0cd935892fae628f"
> > -S = "${WORKDIR}/git"
> > +SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main"
> > +SRCREV = "dc05e026488865bc69313a68bcc03ef2e4ea8e83"
> >
> > +S = "${WORKDIR}/git"
> >
> >  inherit cmake pkgconfig
> >
> > --
> > 2.25.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#107200): https://lists.openembedded.org/g/openembedded-devel/message/107200
> > Mute This Topic: https://lists.openembedded.org/mt/102966758/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Khem Raj Dec. 8, 2023, 2:41 a.m. UTC | #3
On Tue, Dec 5, 2023 at 11:09 AM alper ak <alperyasinak1@gmail.com> wrote:
>
> I think, I found the issue but I don't know how to solve it. Btw,
> works on arm64.
>
> When I looked at the errors, I saw lines like:
>
> error: use of undeclared identifier 'vminvq_u8'; did you mean 'vmvnq_u8'?
> error: use of undeclared identifier 'vmaxvq_u8'
> error: use of undeclared identifier 'vqtbl1q_u8'; did you mean 'vtbl1_u8'?
> error: cannot initialize a parameter of type 'uint8x8_t' (vector of 8
> 'uint8_t' values) with an lvalue of type 'V128' (aka 'uint8x16_t')
>
> When I checked the intrinsics from ARM, I saw that the supported
> architecture is A64.

Please bring this patch along
https://github.com/google/snappy/pull/169

Which should help fix the 32 bit arm build failure.

>
> https://arm-software.github.io/acle/neon_intrinsics/advsimd.html
>
> Khem Raj <raj.khem@gmail.com>, 5 Ara 2023 Sal, 21:06 tarihinde şunu yazdı:
> >
> > this fails on arm
> > https://errors.yoctoproject.org/Errors/Details/745647/
> >
> > On Sun, Dec 3, 2023 at 11:54 PM Alper Ak <alperyasinak1@gmail.com> wrote:
> > >
> > > * 0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch removed because fixed in the new version
> > >
> > > Changelog:
> > >
> > > * Performance improvements
> > > * Compilation fixes for various environments
> > >
> > > Signed-off-by: alperak <alperyasinak1@gmail.com>
> > > ---
> > >  ...-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch | 71 -------------------
> > >  .../{snappy_1.1.9.bb => snappy_1.1.10.bb}     |  8 +--
> > >  2 files changed, 3 insertions(+), 76 deletions(-)
> > >  delete mode 100644 meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> > >  rename meta-oe/recipes-extended/snappy/{snappy_1.1.9.bb => snappy_1.1.10.bb} (85%)
> > >
> > > diff --git a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch b/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> > > deleted file mode 100644
> > > index 27357d88a..000000000
> > > --- a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
> > > +++ /dev/null
> > > @@ -1,71 +0,0 @@
> > > -From 4728803cc8687431449c8c9fbfabb1da04943400 Mon Sep 17 00:00:00 2001
> > > -From: "Georgi D. Sotirov" <gdsotirov@gmail.com>
> > > -Date: Wed, 5 May 2021 14:16:46 +0300
> > > -Subject: [PATCH] Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> > > -
> > > -Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE on AdvanceToNextTag to
> > > -fix the following compilation errors and a warning with GCC:
> > > -
> > > -[  2%] Building CXX object CMakeFiles/snappy.dir/snappy.cc.o
> > > -/usr/bin/c++   -DHAVE_CONFIG_H -Dsnappy_EXPORTS
> > > --I/tmp/snappy-1.1.9/build -I/tmp/snappy-1.1.9  -O3
> > > --march=i586 -mtune=i686 -Wall -Wextra -fno-exceptions -fno-rtti -O3
> > > --DNDEBUG -fPIC   -std=c++11 -o CMakeFiles/snappy.dir/snappy.cc.o -c
> > > -/tmp/snappy-1.1.9/snappy.cc
> > > -/tmp/snappy-1.1.9/snappy.cc:1017:8: warning: always_inline
> > > -function might not be inlinable [-Wattributes]
> > > - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > > -        ^
> > > -/tmp/snappy-1.1.9/snappy.cc: In function 'std::pair<const
> > > -unsigned char*, int> snappy::DecompressBranchless(const uint8_t*, const
> > > -uint8_t*, ptrdiff_t, T, ptrdiff_t) [with T = char*; uint8_t = unsigned
> > > -char; ptrdiff_t = int]':
> > > -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> > > -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> > > -size_t*)': function body can be overwritten at link time
> > > -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> > > -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> > > -                                                     ^
> > > -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> > > -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> > > -size_t*)': function body can be overwritten at link time
> > > - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > > -        ^
> > > -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> > > -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> > > -                                                     ^
> > > -/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
> > > -call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
> > > -size_t*)': function body can be overwritten at link time
> > > - size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > > -        ^
> > > -/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
> > > -         size_t tag_type = AdvanceToNextTag(&ip, &tag);
> > > -                                                     ^
> > > -CMakeFiles/snappy.dir/build.make:137: recipe for target
> > > -'CMakeFiles/snappy.dir/snappy.cc.o' failed
> > > -
> > > -Just like with other functions using SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> > > -macro (i.e. __attribute__((always_inline)) ) it is necessary to use C++
> > > -inline specifier.
> > > -
> > > -Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> > > -
> > > -Upstream-Status: Submitted [https://github.com/google/snappy/pull/128]
> > > ----
> > > - snappy.cc | 2 +-
> > > - 1 file changed, 1 insertion(+), 1 deletion(-)
> > > -
> > > -diff --git a/snappy.cc b/snappy.cc
> > > -index 79dc0e8..51157be 100644
> > > ---- a/snappy.cc
> > > -+++ b/snappy.cc
> > > -@@ -1014,7 +1014,7 @@ void MemMove(ptrdiff_t dst, const void* src, size_t size) {
> > > - }
> > > -
> > > - SNAPPY_ATTRIBUTE_ALWAYS_INLINE
> > > --size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > > -+inline size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
> > > -   const uint8_t*& ip = *ip_p;
> > > -   // This section is crucial for the throughput of the decompression loop.
> > > -   // The latency of an iteration is fundamentally constrained by the
> > > diff --git a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> > > similarity index 85%
> > > rename from meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
> > > rename to meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> > > index 9e0e43ce8..7baf9c647 100644
> > > --- a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
> > > +++ b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
> > > @@ -10,12 +10,10 @@ compression ratio."
> > >  LICENSE = "BSD-3-Clause"
> > >  LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
> > >
> > > -SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main \
> > > -    file://0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch \
> > > -"
> > > -SRCREV = "2b63814b15a2aaae54b7943f0cd935892fae628f"
> > > -S = "${WORKDIR}/git"
> > > +SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main"
> > > +SRCREV = "dc05e026488865bc69313a68bcc03ef2e4ea8e83"
> > >
> > > +S = "${WORKDIR}/git"
> > >
> > >  inherit cmake pkgconfig
> > >
> > > --
> > > 2.25.1
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#107200): https://lists.openembedded.org/g/openembedded-devel/message/107200
> > > Mute This Topic: https://lists.openembedded.org/mt/102966758/1997914
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #4
On Mon, 04 Dec 2023 10:53:56 +0300, alperak wrote:
> * 0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch removed because fixed in the new version
> 
> Changelog:
> 
> * Performance improvements
> * Compilation fixes for various environments
> 
> [...]

Applied, thanks!

[1/1] snappy: upgrade 1.1.9 -> 1.1.10
      commit: 0f0c4c96d90d0eaf78ef6fa93a150dd5fa8fa182

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch b/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
deleted file mode 100644
index 27357d88a..000000000
--- a/meta-oe/recipes-extended/snappy/snappy/0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch
+++ /dev/null
@@ -1,71 +0,0 @@ 
-From 4728803cc8687431449c8c9fbfabb1da04943400 Mon Sep 17 00:00:00 2001
-From: "Georgi D. Sotirov" <gdsotirov@gmail.com>
-Date: Wed, 5 May 2021 14:16:46 +0300
-Subject: [PATCH] Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE
-
-Add inline with SNAPPY_ATTRIBUTE_ALWAYS_INLINE on AdvanceToNextTag to
-fix the following compilation errors and a warning with GCC:
-
-[  2%] Building CXX object CMakeFiles/snappy.dir/snappy.cc.o
-/usr/bin/c++   -DHAVE_CONFIG_H -Dsnappy_EXPORTS
--I/tmp/snappy-1.1.9/build -I/tmp/snappy-1.1.9  -O3
--march=i586 -mtune=i686 -Wall -Wextra -fno-exceptions -fno-rtti -O3
--DNDEBUG -fPIC   -std=c++11 -o CMakeFiles/snappy.dir/snappy.cc.o -c
-/tmp/snappy-1.1.9/snappy.cc
-/tmp/snappy-1.1.9/snappy.cc:1017:8: warning: always_inline
-function might not be inlinable [-Wattributes]
- size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
-        ^
-/tmp/snappy-1.1.9/snappy.cc: In function 'std::pair<const
-unsigned char*, int> snappy::DecompressBranchless(const uint8_t*, const
-uint8_t*, ptrdiff_t, T, ptrdiff_t) [with T = char*; uint8_t = unsigned
-char; ptrdiff_t = int]':
-/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
-call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
-size_t*)': function body can be overwritten at link time
-/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
-         size_t tag_type = AdvanceToNextTag(&ip, &tag);
-                                                     ^
-/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
-call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
-size_t*)': function body can be overwritten at link time
- size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
-        ^
-/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
-         size_t tag_type = AdvanceToNextTag(&ip, &tag);
-                                                     ^
-/tmp/snappy-1.1.9/snappy.cc:1017:8: error: inlining failed in
-call to always_inline 'size_t snappy::AdvanceToNextTag(const uint8_t**,
-size_t*)': function body can be overwritten at link time
- size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
-        ^
-/tmp/snappy-1.1.9/snappy.cc:1097:53: error: called from here
-         size_t tag_type = AdvanceToNextTag(&ip, &tag);
-                                                     ^
-CMakeFiles/snappy.dir/build.make:137: recipe for target
-'CMakeFiles/snappy.dir/snappy.cc.o' failed
-
-Just like with other functions using SNAPPY_ATTRIBUTE_ALWAYS_INLINE
-macro (i.e. __attribute__((always_inline)) ) it is necessary to use C++
-inline specifier.
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
-Upstream-Status: Submitted [https://github.com/google/snappy/pull/128]
----
- snappy.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/snappy.cc b/snappy.cc
-index 79dc0e8..51157be 100644
---- a/snappy.cc
-+++ b/snappy.cc
-@@ -1014,7 +1014,7 @@ void MemMove(ptrdiff_t dst, const void* src, size_t size) {
- }
- 
- SNAPPY_ATTRIBUTE_ALWAYS_INLINE
--size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
-+inline size_t AdvanceToNextTag(const uint8_t** ip_p, size_t* tag) {
-   const uint8_t*& ip = *ip_p;
-   // This section is crucial for the throughput of the decompression loop.
-   // The latency of an iteration is fundamentally constrained by the
diff --git a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
similarity index 85%
rename from meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
rename to meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
index 9e0e43ce8..7baf9c647 100644
--- a/meta-oe/recipes-extended/snappy/snappy_1.1.9.bb
+++ b/meta-oe/recipes-extended/snappy/snappy_1.1.10.bb
@@ -10,12 +10,10 @@  compression ratio."
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
 
-SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main \
-    file://0001-Add-inline-with-SNAPPY_ATTRIBUTE_ALWAYS_INLINE.patch \
-"
-SRCREV = "2b63814b15a2aaae54b7943f0cd935892fae628f"
-S = "${WORKDIR}/git"
+SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main"
+SRCREV = "dc05e026488865bc69313a68bcc03ef2e4ea8e83"
 
+S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig